Problembeschreibung
Nachdem Sie ein Update für Microsoft Exchange Server 2019 installiert haben, erhalten Sie möglicherweise unvollständige Ergebnisse, wenn Sie in einem Postfach nach Elementen suchen.
Ursache
Während jedes Exchange Server Upgrades wird die Microsoft Search Foundation neu installiert. Obwohl dieser Prozess nicht immer erfolgreich abgeschlossen wird, verhindert ein solcher Fehler nicht, dass das Exchange Server Upgrade abgeschlossen wird.
In dieser Situation scheint der aktualisierte Server voll funktionsfähig zu sein. Mehrere Probleme wirken sich jedoch auf die Dienste aus, die der Microsoft Search Foundation zugeordnet sind. Beispielsweise ist die Microsoft Exchange-Suchdienst deaktiviert, oder der Noderunner.exe Prozess wird beendet. Aufgrund dieser Probleme beendet der Server, auf dem Exchange Server ausgeführt wird, die Indizierung von Postfachelementen. Wenn der Indizierungsfehler über einen längeren Zeitraum fortgesetzt wird, werden die Postfachelemente, die nicht indiziert sind, in einen dauerhaften Fehlerzustand versetzt.
Wenn die Probleme, die sich auf die Suchprozesse auswirken, behoben sind, nachdem die Elemente in diesen Fehlerzustand versetzt wurden, setzt der Server die Indizierung von Elementen fort. Standardmäßig versucht der Server jedoch nicht, die Elemente zu indizieren, die in einen dauerhaften Fehlerzustand versetzt wurden. Daher werden diese Elemente nicht in den Suchergebnissen angezeigt.
Lösung
Um dieses Problem zu beheben, erstellen Sie eine neue Außerkraftsetzung für die Elemente, die sich in einem dauerhaften Fehlerzustand befinden, und indizieren Sie die Elemente dann neu. Gehen Sie folgendermaßen vor:
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Erstellen Sie eine Einstellungsüberschreibung, indem Sie das folgende Cmdlet ausführen:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Hinweis Ersetzen Sie in diesem Cmdlet <Buildnummer> durch die Nummer des Exchange Server Builds, der auf dem Server ausgeführt wird, der das betroffene Postfach enthält.
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Aktualisieren Sie die Konfiguration, indem Sie das folgende Cmdlet ausführen:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Nachdem Sie dieses Cmdlet ausgeführt haben, sollte die datei BigFunnel.Overrides.ini im Verzeichnis %ExchangeInstallPath%\v15\config angezeigt werden.
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Lösen Sie Exchange Server aus, um die Postfachelemente zu indizieren, die zuvor nicht indiziert wurden. Führen Sie dazu das folgende Cmdlet aus:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Hinweise:
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Ersetzen Sie in diesem Cmdlet <Postfach-ID> durch den Namen des betroffenen Postfachs.
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Bei dem Namen des Assistent, der im Cmdlet verwendet wird (BigFunnelRetryFeederTimeBasedAssistant), wird die Groß-/Kleinschreibung beachtet.
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Das Cmdlet ist in Exchange Server kumulativen Update 11 und höheren Versionen von Exchange Server 2019 verfügbar.
Dieses Cmdlet behandelt nicht alle indexbezogenen Probleme. Stattdessen wird der Exchange-Suchdienst daran erinnert, Elemente zu indizieren, die nie indiziert wurden und sich im Zustand Nicht indiziert befinden.
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Hinweis: Durch die Einstellungsüberschreibung können Sie vermeiden, dass Postfächer verschoben werden müssen, um Elemente neu zu indizieren. Es wird jedoch empfohlen, die außer Kraft gesetzte Außerkraftsetzung nicht dauerhaft in der Umgebung zu belassen, da dies zu einer höheren CPU-Auslastung führen kann. Nachdem die Elemente neu indiziert wurden, entfernen Sie die Außerkraftsetzung mithilfe des Cmdlets Remove-SettingOverride .