Problembeschreibung
Nach der Installation eines Updates für Microsoft Exchange Server 2019 erhalten Sie möglicherweise unvollständige Ergebnisse, wenn Sie in einem Postfach nach Elementen suchen.
Ursache
Bei jedem Exchange Server wird Microsoft Search Foundation erneut installiert. Obwohl dieser Vorgang nicht immer erfolgreich abgeschlossen wird, wird ein solcher Fehler nicht zum Abschluss Exchange Server Upgrades führen.
In diesem Fall scheint der aktualisierte Server voll funktionsfähig zu sein. Es gibt jedoch mehrere Probleme, die sich auf die Dienste auswirken, die der Microsoft Search Foundation zugeordnet sind. Beispielsweise ist der Microsoft Exchange Search-Dienst deaktiviert oder der Noderunner.exe nicht mehr. Aufgrund dieser Probleme beendet der Server, auf dem die Exchange Server die Indizierung von Postfachelementen. Wenn der Indizierungsfehler für einen längeren Zeitraum fortgesetzt wird, werden die Postfachelemente, die nicht indiziert sind, in den Status eines dauerhaften Fehlers übergehen.
Wenn die Probleme, die auswirkungen auf die Suchprozesse haben, behoben sind, kann der Server die Indizierung der Elemente jederzeit fortsetzen, nachdem die Elemente in den Status "Fehler" übergehen. Standardmäßig versucht der Server jedoch nicht, die Elemente zu indizieren, die in einen dauerhaften Fehlerzustand gelaufen sind. Daher werden diese Elemente nicht in Den Suchergebnissen angezeigt.
Lösung
Um dieses Problem zu beheben, erstellen Sie eine neue Außerkraftsetzung für die Elemente, die sich im Status "Dauerhafter Fehler" befinden, und indizieren Sie die Elemente dann erneut. Gehen Sie folgendermaßen vor:
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Erstellen Sie eine Einstellungsüberschreibung, indem Sie das folgende Cmdlet ausführen:New-SettingOverride -Name "Big Funnel Permanent Retry" -Component "BigFunnel" -Section "BigFunnelFailedItemsQuerySettings" -Parameters @("ExcludePermanentFailures=false") -Reason "Re-Index Messages" -MinVersion "<Build Number>" -MaxVersion "<Build Number>"Hinweis Ersetzen Sie in diesem Cmdlet <Buildnummer> durch die Nummer des Exchange Server-Build, der auf dem Server ausgeführt wird, der das betroffene Postfach enthält.
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Aktualisieren Sie die Konfiguration, indem Sie das folgende Cmdlet ausführen:Get-ExchangeDiagnosticInfo -Process Microsoft.Exchange.Directory.TopologyService -Component VariantConfiguration -Argument Refresh Nachdem Sie dieses Cmdlet ausgeführt haben, sollte die BigFunnel.Overrides.ini im Verzeichnis "%ExchangeInstallPath%\v15\config" angezeigt werden.
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Auslösen Exchange Server, um Postfachelemente zu indizieren, die zuvor nicht indiziert wurden. Führen Sie dazu das folgende Cmdlet aus:Start-MailboxAssistant -Identity <mailbox ID> -AssistantName BigFunnelRetryFeederTimeBasedAssistant
Hinweise:
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Ersetzen Sie in diesem Cmdlet <Postfach-ID> durch den Namen des betroffenen Postfachs.
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Beim Namen des Assistenten, der im Cmdlet ("BigFunnelRetryFeederTimeBasedAssistant") verwendet wird, wird die Groß-/Kleinschreibung beachtet.
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Das Cmdlet ist in Exchange Server 2019 kumulativem Update 11 und höher verfügbar.
Mit diesem Cmdlet werden nicht alle indexbezogenen Probleme gelöst. Stattdessen erinnert sie den Exchange Suchdienst daran, Elemente zu indizieren, die nie indiziert wurden und sich im Status "Nicht indiziert" befinden.
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Hinweis: Mit der Einstellungsüberschreibung können Sie verhindern, dass Postfächer verschoben werden müssen, um Elemente neu zu indizieren. Es wird jedoch empfohlen, die Außerkraftsetzung nicht dauerhaft in der Umgebung zu be lassen, da dies zu einer erhöhten CPU-Auslastung führen kann. Nachdem die Elemente neu indiziert wurden, entfernen Sie die Außerkraftsetzung mithilfe des Cmdlets Remove-SettingOverride .