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KB-978268

Problembeschreibung

Wenn Sie versuchen, in HRMSSS for Business Portal (BP) in Microsoft Dynamics GP einen neu erstellten Bezahlzeitplan zuzuordnen oder einen vorhandenen Bezahlzeitplan zu ändern, erhalten Sie eine der folgenden Fehlermeldungen:

 

Der Zahlungszeitplan hat Termine, die sich mit dem aktiven Pay-Zeitplan des letzten Jahres überschneiden. Sie können keine zwei aktiven Kostenpläne speichern, die Datumsangaben gemeinsam haben.

oder

Die diesem Kostenplan zugewiesenen Pay-Perioden entsprechen nicht der Häufigkeit der Bezahlung. Berechnen Sie die Pay-Perioden für den Zahlungszeitplan neu.

Ursache

Das Problem mit der ersten meldung oben tritt auf, weil das Startdatum des ersten Zeitraums im neuen Kostenplan mit dem Datum im letzten Zeitraum im vorherigen Kostenplan überlappt. Das HRMSSS-Modul erfordert jedoch, dass ein Kostenplan 365 Tage lang sein muss und es nicht zu lässt, dass Datumsangaben übersprungen oder überlappend zwischen zwei Zeitplänen liegen.


Das Problem bei der zweiten Meldung oben ist, dass der Bezahlzeitplan 364 Tage lang ist und das System es erfordert, dass er 365 Tage lang ist, bevor Änderungen daran zulässig sind, oder dass ein neuer, danebenstehender Kostenplan erstellt werden kann.
 

Lösung


Beispiel:

Angenommen, Ihr Kostenplan für 2021 läuft vom 23. Dezember 2021 bis zum 22. Dezember 2022. In diesem Beispiel möchten Sie einen neuen Kostenplan namens "2022" erstellen, der am 22. Dezember 2022 beginnt. Dies ist jedoch nicht der Grund, dass er bereits vom vorherigen Kostenplan verwendet wurde. 

Kostenplan: Startdatum -Enddatum

2021: ist derzeit für die Datumsangaben 23.12.2021 bis 22.12.2022 eingerichtet.

2022: Sie möchten Datumsangaben vom 22.12.2022 bis zum 21.12.2023 wünschen. Sie möchten diesen neuen Zeitplan am 22.12.2022 beginnen, können dies aber nicht, da dieses Datum bereits vom vorherigen Zahlungszeitplan für das vorherige Jahr verwendet wurde. 

Hinweis: Das System erfordert, dass der "Name" der Periode mit dem Stempel "Jahr" auf dem "Startdatum" in diesem Kostenplan zusammen stimmt.

Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben:

  • Wenn Sie BP 4.0 mit Microsoft Dynamics GP 10.0 verwenden, haben Sie unten Methode 1 oder Methode 2 verwendet.

  • Wenn Sie BP 5.0 oder BP 5.1 mit Microsoft Dynamics GP 2010 oder BP 6.0/6.1 mit Microsoft Dynamics GP 2013 verwenden und über 27 Zeiträume (zweiwochen) oder 53 Zeiträume (wöchentlich) verfügen, verwenden Sie unten Methode 1 oder Methode 2.

  • Wenn Sie BP 5.0 oder BP 5.1 mit Microsoft Dynamics GP 2010 oder BP 6.0/6.1 mit Microsoft Dynamics GP 2013 verwenden und über 26 Zeiträume (zweiwochen) oder 52 Zeiträume (wöchentlich) verfügen, weil Sie auf die Option für "Ausschließliche Zahlungszeiträume verwenden" geklickt haben, verwenden Sie unten Methode 1 oder Methode 3. Ihr Kostenplan für 2021 (ausschließlich mit vollständigen Zeiträumen) endet anscheinend am 21.12.2022, aber Sie können keinen neuen Zeitplan für 2022 erstellen, der am 22.12.2022 beginnt, obwohl dieses Datum nicht im vorherigen Zahlungszeitplan verwendet wurde.

Methode 1: Weisen Sie den bisherigen Zahlungsplan nicht zu, damit das System ihn nicht mehr anschaut.


Wenn Sie mit der Verwendung des bisherigen Bezahlzeitplans fertig sind und alle diese Zeitkarten bis zum Abschluss genehmigt wurden, können Sie die Zuweisung dieses Kostenplans von allen Mitarbeitern einfach wieder auf den Weg machen, und das System wird ihn nicht mehr in Betracht ziehen. Anschließend können Sie ab dem von Ihnen gewünschten Datum den neuen Kostenplan erstellen. Dies ist die schnellste und einfachste Methode, dieses Problem zu beheben, wenn Sie warten können, bis der vorherige Zeitplan nicht mehr verwendet wird und alle Zeitkarten, die diesen Zahlungsplan verwenden, genehmigt/abgeschlossen wurden.

1. Melden Sie sich bei BP als Administrator an.

2. Klicken Sie auf die Registerkarte Verwaltung.

3. Klicken Sie auf Timecard Setup.

4. Wählen Sie den richtigen Zeitplan für die Bezahlung aus, und klicken Sie auf die Schaltfläche Zuweisen.

5. Wählen Sie in der Dropdownliste Einschränken nach die Option Abteilung aus, und klicken Sie auf Markierung für alle entfernen. Wählen Sie dann Nach Mitarbeiter einschränken und Markierung für alle entfernen aus. (Überprüfen Sie auch nach Ort und Position, auch wenn diese weniger häufig verwendet werden.) "Speichern" aus.

6. Jetzt können Sie auf Hinzufügen klicken und einen neuen Kostenplan erstellen, der an dem von Ihnen gewünschten Datum beginnt.



Hinweis Löschen Sie den vorherigen Kostenplan nicht im Business Portal. Der Kostenplan muss vorhanden sein, damit Verlaufsdaten angezeigt werden können. Wenn jedoch der bisherige Kostenplan aus dem Fenster "Kostenplan" gelöscht wird, können Sie ihn einfach erneut erstellen, ihn aber keinem Mitarbeiter zuweisen. Sie muss lediglich vorhanden sein, um den Zeitkartenverlauf der Vergangenheit anzeigen zu können.

Methode 2: Ändern Sie die Datumsangaben im Zahlungsplan, wenn Sie über 27 oder 53 Zahlungszeiträume verfügen, mithilfe von Microsoft SQL Skripts.

Hinweis Stellen Sie vor dem Befolgen der Anweisungen in diesem Artikel sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie im Fall eines Problems wiederherstellen können.


Weitere Hinweise:

  • Wir empfehlen, eine Sicherung zu erstellen. Notieren Sie sich die Start- und Enddaten für alle Zeitpläne, damit Sie die Skripts SQL bearbeiten können.

  • Es wird empfohlen, alle Zeitkarten im Kostenplan zu genehmigen, die geändert werden sollen. Führen Sie diese Schritte daher erst am Ende des Kostenplans aus.


Mit den nachstehenden Schritten soll der letzte Zeitraum (27. oder Zeitraum 53) in "Zeitraum 0" umbenannt werden, sodass das System diesen Zeitraum an den Anfang des Zeitplans verschiebt. Anschließend ändern wir den Jahresstempel für den aktuellen Zeitraum, sodass der zusätzliche Tag am Anfang des Zeitplans im vorherigen Jahr hinzugefügt und vom Ende des Zeitplans entfernt wird, um dieses Datum frei zu machen. Damit verschieben wir also den Zeitplan um einen Tag früher (oder 22.12.2020- 21.12.2021). Dies ist erforderlich, da der Zeitplan für das System weiterhin 365 Tage lang sein muss. 

Schritt 1
Führen Sie das entsprechende Skript aus, um den Wert für "Period ID" wie folgt von "zweiwochen- oder wochenweise" in "0" zu ändern. Dadurch wird der letzte Zeitraum an den Anfang des Kostenplans verschieben:

BIWEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='27' and yearid='2021' and frequencyid ='2'
WEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='53' and yearid='2021' and frequencyid ='1'



Hinweis Aktualisieren Sie die JAHR-ID im obigen Skript so, dass sie der Name des alten Kostenplans ist. Diese Beispielskripts decken nur wochen- und zweiwochenweise ab, können aber auch entsprechend bearbeitet werden, wenn es sich bei Ihrem Zeitplan um eine andere Häufigkeit handelt, z. B. monatlich oder halbmonatlich. Öffnen Sie einen Supportfall, um diese Werte in das Skript einfügen zu können.
 

Schritt 2

Führen Sie das entsprechende Skript unten aus, um den Wert für Periodenname entsprechend zu ändern:

BIWEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 27' and Yearid = '2021' and frequencyid = '2'

WEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 53' and Yearid = '2021' and frequencyid = '1'





Schritt 3
Jetzt müssen Sie das Start- und Enddatum des Zeitraums 0 so ändern, dass es sich um das vorherige Jahr ändert, sodass der zusätzliche Tag am Anfang des Kostenplans addiert wird. Führen Sie beide Skripts aus, um zuerst das Startdatum für "Zeitraum 0" und dann das Enddatum für "Zeitraum 0" zu ändern:

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

Hinweis Das Datum in der letzten Periode war der 22.12.2022-22.12.2022, und Sie haben es jetzt in den 22.12.2021-22.12.2021 geändert, wodurch der zusätzliche Tag am Anfang des Zeitplans addiert wird, indem nur der Jahresstempel geändert wird. Die Periode 26 oder 52 endet am 21.12.2022.



Schritt 4
Führen Sie das folgende Skript aus, um HRM_PaySchedule Tabelle so zu aktualisieren, dass sie mit dem neuen Startdatum von "Zeitraum 0" in der Tabelle "HRM_PayPeriod wird:

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:

update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Hinweis Führen Sie das folgende Skript aus, um zu überprüfen, ob der Wert für "BeginDate" in der Tabelle "HRM_PaySchedule" mit dem Wert für "BeginDate" von "Zeitraum 0" in der Tabelle "HRM_PayPeriod" entspricht:

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1
 


Schritt 5
Jetzt können Sie einen neuen Kostenplan für 2022 mit dem Startdatum "22.12.2022" erstellen. Klicken Sie in BP auf die Registerkarte Verwaltung, und klicken Sie auf Timecard Setup. Klicken Sie im Abschnitt "Kostenpläne" auf die Schaltfläche Hinzufügen. Geben Sie die Häufigkeit und das Startdatum des 22.12.2022 ein, und klicken Sie auf Zahlungszeiträume berechnen. "Speichern" aus.


Hinweis Der neue Kostenplan erstellt auch einen zusätzlichen Zeitraum von 27 oder Zeitraum 53 für den zusätzlichen Tag (da 365 nicht zu gleichen Teilen durch 7 teilbar ist). Es wird jedoch nicht empfohlen, den zusätzlichen Zeitraum zu diesem Zeitpunkt zu ändern. Andernfalls überlappt der Zeitplan wieder mit dem vorherigen aktuellen Kostenplan, daher sollten Sie mit der Änderung bis zum Ende des Jahres warten.


Schritt 6
Wählen Sie zeitplan aus, und klicken Sie auf die Schaltfläche Zuweisen, um den neuen Zeitplan Abteilungen, Standorten, bestimmten Mitarbeitern oder Positionen zuzuordnen.



 

Methode 3: Ändern Sie die Datumsangaben im Zahlungsplan, wenn Sie über 26 oder 52 Zahlungszeiträume verfügen, mithilfe von Microsoft SQL Skripts.



Hinweis Stellen Sie vor dem Befolgen der Anweisungen in diesem Artikel sicher, dass Sie über eine vollständige Sicherungskopie der Datenbank verfügen, die Sie im Fall eines Problems wiederherstellen können.


Weitere Hinweise:

  • Wir empfehlen, eine Sicherung zu erstellen. Notieren Sie sich die Start- und Enddaten für alle Zeitpläne, damit Sie die Skripts SQL bearbeiten können.

  • Es wird empfohlen, alle Zeitkarten im Kostenplan zu genehmigen, die geändert werden sollen. Führen Sie diese Schritte daher erst am Ende des Kostenplans aus.



In diesem Beispiel geht der vorhandene Kostenplan für 2021 vom 23.12.2021 bis zum 21.12.2022 (und hat 26 oder 52 Zahlungszeiträume). Sie möchten eine Änderung am vorhandenen Kostenplan oder einen neuen Zeitplan erstellen, der am 22.12.2022 beginnt, bei dem aber weiterhin ein Fehler angezeigt wird, obwohl dieses Datum nicht vom vorhandenen Kostenplan verwendet wird. Das System lässt Sie nicht zu, den neuen Kostenplan zu erstellen, da der vorherige Zeitplan nicht 365 Tage lang ist.  


Die nachstehenden Schritte sollen dem vorhandenen Zeitplan einen zusätzlichen Tag hinzufügen, damit er 365 Tage lang ist, sodass Sie dann den neuen Kostenplan erstellen können. 

Schritt 1
Überprüfen Sie die aktuellen Daten des ersten und letzten Zeitraums (26. oder Zeitraum 52) im vorhandenen Kostenplan:

BIWEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='2'
WEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='1'



Hinweis Aktualisieren Sie die JAHR-ID im obigen Skript so, dass sie der Name des vorhandenen Kostenplans ist. Diese Beispielskripts decken nur wochen- und zweiwochenweise ab, können aber auch entsprechend bearbeitet werden, wenn es sich bei Ihrem Zeitplan um eine andere Häufigkeit handelt, z. B. monatlich oder halbmonatlich. Öffnen Sie einen Supportfall, um diese Werte in das Skript einfügen zu können.

Schritt 2

Sichern Sie das Startdatum in Zeitraum 1 um einen Tag, um einen zusätzlichen Tag zum Anfang des Kostenplans hinzuzufügen, damit er 365 Tage lang ist.

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='1'

Hinweis Wenn sich das Hinzufügen des Startdatums mit dem Kostenplan des vorherigen Jahres überschneidet, müssen Sie möglicherweise zuerst die Zuweisung dieses alten Zeitplans von allen Mitarbeitern entfernen, damit es dem System keine Sorgen macht und kein weiteres überlappendes Problem zu sehen ist.



Hinweis Dadurch wird der Kostenplan vom 22.12.2021 bis zum 21.12.2022 berechnet, wodurch der zusätzliche Tag am Anfang des Zeitplans hinzufügt wird, damit er 365 Tage lang ist. 


Schritt 3
Führen Sie das folgende Skript aus, um HRM_PaySchedule Tabelle so zu aktualisieren, dass sie mit dem neuen Startdatum von "Zeitraum 1" in der Tabelle "HRM_PayPeriod wird:

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Hinweis Führen Sie das folgende Skript aus, um zu überprüfen, ob der Wert für "BeginDate" in der Tabelle "HRM_PaySchedule" mit dem Wert für "BeginDate" von "Zeitraum 0" in der Tabelle "HRM_PayPeriod" entspricht:

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1


Schritt 4
Jetzt können Sie einen neuen Bezahlplan für 2022 erstellen, der das Startdatum "22.12.2022" hat. Klicken Sie in BP auf die Registerkarte Verwaltung, und klicken Sie auf Timecard Setup. Klicken Sie im Abschnitt "Kostenpläne" auf die Schaltfläche Hinzufügen. Geben Sie die Häufigkeit und das Startdatum des 22.12.2022 ein, und klicken Sie auf Zahlungszeiträume berechnen. "Speichern" aus.


Hinweis Der neue Kostenplan erstellt auch einen zusätzlichen Zeitraum von 27 oder Zeitraum 53 für den zusätzlichen Tag (da 365 nicht zu gleichen Teilen durch 7 teilbar ist) oder wenn Sie "Nur vollständige Zahlungszeiträume verwenden" verwenden, werden wieder 26 oder 52 Zahlungszeiträume erstellt. Es wird jedoch nicht empfohlen, den zusätzlichen Zeitraum zu diesem Zeitpunkt zu ändern. Andernfalls überlappt der Zeitplan wieder mit dem vorherigen aktuellen Kostenplan, daher sollten Sie mit der Änderung bis zum Ende des Jahres warten.


Schritt 5
Wählen Sie zeitplan aus, und klicken Sie auf die Schaltfläche Zuweisen, um den neuen Zeitplan Abteilungen, Standorten, bestimmten Mitarbeitern oder Positionen zuzuordnen.

 

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