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Problembeschreibung

Stellen Sie sich folgendes Szenario vor:

  • Sie verfügen über eine Drittanbieteranwendung, die eine falsche Reihenfolge für die Zugriffssteuerungsliste eines Kalenderordners in einem Postfach fest legt.

  • Sie verschieben das Postfach, das den Ordner Kalender enthält, auf einen Microsoft Exchange Server 2010-Postfachserver. Der Verschiebevorgang wurde erfolgreich abgeschlossen.

  • Sie versuchen, die Zugriffsberechtigung des Kalenderordners mithilfe einer Exchange Web Service (EWS)-Anwendung oder mithilfe einer MAPI-Anwendung wie Microsoft Outlook zu ändern.

In diesem Szenario können Sie die Zugriffsberechtigungen des Kalenderordners nicht ändern.

Ursache

Dieses Problem tritt aufgrund eines Fehlers auf, wenn der Exchange Store kanonische Zugriffssteuerungslisten überprüft. Daher kann die MAPI- oder EWS-Anwendung die Listentabelle für das Zugriffssteuerelement des Ordners Kalender nicht abrufen.

Lösung

Installieren Sie das folgende Updaterollup, um dieses Problem zu beheben:

2685289 Beschreibung des Updaterollup 3 für Exchange Server 2010 Service Pack 2 Nachdem das Update installiert wurde, können Sie die Überprüfung kanonischer ACLs aktivieren, indem Sie einen Registrierungsschlüssel
konfigurieren. Damit wir die Überprüfung kanonischer ACLs für Sie aktivieren können, wechseln Sie zum Abschnitt "Fix it for me". Wenn Sie die Überprüfung kanonischer ACLs lieber selbst aktivieren möchten, wechseln Sie zum Abschnitt " Letme fix it yourself".

Problem automatisch beheben



Um die Überprüfung kanonischer ACLs automatisch zu aktivieren, klicken Sie auf die Schaltfläche oder den Link Fix it. Klicken Sie dann im Dialogfeld Dateidownload auf Ausführen, und führen Sie die Schritte im Assistenten Beheben aus.




Notizen

  • Installieren Sie das Update, das im Microsoft Knowledge Base (KB)-Artikel 2685289 beschrieben wird, bevor Sie diese Lösung beheben ausführen.

  • Dieser Assistent ist möglicherweise nur in Englisch verfügbar. Die automatische Korrektur funktioniert aber auch für andere Sprachversionen von Windows.

  • Wenn Sie sich nicht an dem Computer befinden, auf dem das Problem auftritt, speichern Sie die Fix it-Lösung auf einem USB-Speicherstick oder einer CD, und führen Sie sie anschließend auf dem vom Problem betroffenen Computer aus.


Wechseln Sie dann zum Abschnitt "Wurde das Problem dadurch behoben?".



Problem manuell beheben

Führen Sie die folgenden Schritte aus, um die Überprüfung kanonischer ACLs durch Konfigurieren eines Registrierungsschlüssels zu aktivieren:

  1. Öffnen Sie den Registrierungs-Editor. Klicken Sie dazu auf Start,geben Sie regedit in das Feld Suche starten ein, und drücken Sie dann die EINGABETASTE.

  2. Suchen Und klicken Sie dann auf den folgenden Registrierungsunterschlüssel:HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

  3. Zeigen Sie im Menü Bearbeiten auf Neu, und klicken Sie dann auf DWORD (32 Bit) Wert.

  4. Geben Sie CheckCanonicalACLDuringMove ein, und drücken Sie dann die EINGABETASTE.

  5. Klicken Sie im Menü Bearbeiten auf Ändern.

  6. Geben Sie im Feld Wertdaten den Wert 1 ein, und klicken Sie dann auf OK.

  7. Beenden Sie den Registrierungs-Editor.

Nachdem die Überprüfung des Features für kanonische Zugriffssteuerungslisten aktiviert wurde, können Sie keine Ordner verschieben, in denen sich die Liste der Zugriffssteuerelemente nicht in kanonischer Reihenfolge befindet. Darüber hinaus wird die folgende Fehlermeldung angezeigt, wenn Sie versuchen, den Ordner zu verschieben:

Fehler: MapiExceptionInvalidParameter: Eigenschaften für Das Objekt können nicht festgelegt werden. (hr=0x80070057, ec=-2147024809)
Diagnostic context:
Lid: 55847 EMSMDBPOOL.EcPoolSessionDoRpc called [length=267]
Lid: 43559 EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=232][latency=0]
Lid: 23226 --- ROP Parse Start ---
Lid: 27962 ROP: ropSetProps [10]
Lid: 17082 ROP Error: 0x80070057
Lid: 30561
Lid: 21921 StoreEc: 0x80070057
Lid: 27962 ROP: ropExtendedError [250]
Lid: 1494 ---- Remote Context Beg ----
Lid: 26426 ROP: ropSetProps [10]
Lid: 21970 StoreEc: 0x8004010F PropTag: 0x668F0040
Lid: 25000
Lid: 24936
Lid: 24952
Lid: 47113
Lid: 7915 StoreEc: 0x80070057
Lid: 5263 StoreEc: 0x80070057
Lid: 19768
Lid: 4559 StoreEc: 0x80070057
Lid: 1750 ---- Remote Context End ----
Lid: 26849
Lid: 21817 ROP Failure: 0x80070057
Lid: 25761
Lid: 1940 StoreEc: 0x80070057
Lid: 25297
Lid: 21201 StoreEc: 0x80070057


Wurde das Problem behoben?

  • Testen Sie, ob das Problem behoben ist. Wenn das Problem beseitigt ist, sind Sie mit diesem Abschnitt fertig. Wenn das Problem noch nicht behoben ist, wenden Sie sich an den Support.

  • Ihr Feedback ist uns wichtig. Wenn Sie Feedback geben oder Probleme mit dieser Lösung melden möchten, hinterlassen Sie bitte einen Kommentar im Blog"Fix it for me"oder senden Sie uns eine E-Mail.

Weitere Informationen

Weitere Informationen zu Zugriffssteuerungslisten finden Sie auf der folgenden Microsoft-Website:

Allgemeine Informationen zu ZugriffssteuerungslistenWeitere Informationen zu Zugriffssteuerungseinträgen finden Sie auf der folgenden Microsoft-Website:

Allgemeine Informationen zu ZugriffssteuerungseinträgenWeitere Informationen zur Verwendung von Visual Basic und ADsSecurity.dll zum geeigneten Bestellen von ACEs in einer ACL finden Sie auf der folgenden Microsoft-Website:

Verwenden von Visual Basic und ADsSecurity.dll, um ACEs in einer ACL entsprechend zu bestellen

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