Problembeschreibung
Stellen Sie sich folgendes Szenario vor:
-
Sie installieren eine Hostinstanz von Microsoft BizTalk Server 2010 auf einem Computer.
-
Die Verbindung zur BizTalk-bezogene Datenbank geht verloren. Die Verbindung wird fortgesetzt, nachdem die Verbindung unterbrochen, beträgt eine Minute wird.
In diesem Szenario wird BizTalk Server-Hostinstanz nicht fortzusetzen. Darüber hinaus werden die folgenden Ereignisse protokolliert, im Anwendungsprotokoll oder im Systemprotokoll:Hinweis dieses Problem nicht in früheren Versionen von tritt BizTalk Server.
Ursache
Dieses Problem tritt auf, da BizTalk Server 2010 keine unerwartete Beendigung zu Service Control Manager (SCM) melden. Wird die Verbindung verloren, die Hostinstanz einen Beendigungsstatus erreicht und versucht, innerhalb einer Minute neu zu starten. Jedoch der Neustart fehlschlägt und BizTalk Server 2010 die unerwartete Beendigung SCM nicht gemeldet. SCM behandelt außerdem die unerwartete Beendigung als Benutzerinitiierte Stop Servicearbeitsgang. SCM fortsetzen daher nicht die Hostinstanz BizTalk Server 2010 wurde beendet.
Lösung
Informationen zum kumulativen Update
Kumulierte Updatepaket 2 für BizTalk Server 2010 gehört der Hotfix, der dieses Problem behebt.Weitere Informationen dazu, wie Sie das kumulative Updatepaket beziehen, finden im folgenden Artikel der Microsoft Knowledge Base:
2573000 Kumulierte Updatepaket 2 für BizTalk Server 2010
Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.
Informationsquellen
Weitere Informationen zu Servicepacks und kumulativen Updatepakete für BizTalk Server finden Sie auf folgender Microsoft-Website:
Allgemeine Informationen über Servicepacks und kumulativen Updatepakete für BizTalk ServerWeitere Informationen zu BizTalk Server Updates klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:
2003907 Informationen zu BizTalk Server-Updates