Problembeschreibung
Betrachten Sie das folgende Szenario:
-
Kumulative Update 7 ist für Microsoft SQL Server 2012 Service Pack 1 (SP1).
-
Sie aktivieren das Feature AlwaysOn Availability Gruppen in SQL Server 2012.
-
Sie aktivieren die Funktion Protokollversand für einige Datenbanken in AlwaysOn Availability Group.
-
Legen Sie backup Präferenz für die Availability Group auf Sekundäre bevorzugen.
-
System-Funktion sys.fn_hadr_backup_is_preferred_replica um festzustellen, ob das aktuelle Replikat bevorzugte backup Replikat sowohl auf primäre und sekundäre Datenbank ausführen.
In diesem Szenario kann die Systemfunktion 1 falsch auf beiden Seiten zurück.
Ursache
Dieses Problem tritt aufgrund einer Regression tritt auf, wenn das Update KB 2887115 installiert ist.
Problemlösung
Kumulative Update 8 für SQL Server 2012 SP1/en-us/help/2917531
Jedes neue kumulative Update für SQL Server enthält alle Hotfixes und alle Sicherheits-Updates, die im vorherigen kumulativen Update enthalten waren. Sehen Sie sich die neuesten kumulativen Updates für SQL Server an:
Hotfix-InformationenEin unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix soll nur der Behebung des Problems dienen, das in diesem Artikel beschrieben wird. Verwenden Sie diesen Hotfix nur auf Systemen, bei denen dieses spezielle Problem auftritt.
Wenn der Hotfix zum Download zur Verfügung steht, gibt es einen Abschnitt "Hotfix download available" ("Hotfixdownload verfügbar") im oberen Bereich dieses Knowledge Base-Artikels. Wenn dieser Abschnitt nicht angezeigt wird, senden Sie eine Anforderung an Microsoft Customer Service and Support, um den Hotfix zu erhalten.
Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich sind, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die nicht diesem speziellen Hotfix zugeordnet werden können. Eine vollständige Liste der Telefonnummern von Microsoft Customer Service and Support oder eine separate Serviceanfrage erstellen finden Sie auf folgender Microsoft-Website:
http://support.microsoft.com/contactus/?ws=supportHinweis Das Formular "Hotfix Download Available" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist dieser Hotfix für Ihre Sprache nicht verfügbar.
NeustartanforderungSie müssen keinen Neustart des Computers nach der Installation dieses Hotfixes durchführen.
Informationen zu ersetzten HotfixesDieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.
Status
Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt „Eigenschaften“ aufgeführt sind.