Συμπτώματα
Εξετάστε το ακόλουθο σενάριο:
-
Χρησιμοποιείτε το Microsoft Exchange αντιμετώπιση Βοηθού (Extra.exe) για την αντιμετώπιση προβλημάτων σε ένα διακομιστή Microsoft Exchange Server 2010.
-
Χρησιμοποιείτε Exchange αντιμετώπιση Βοηθό για να ζητήσετε τα ίχνη και να συλλέξουν διαγνωστικές πληροφορίες.
-
Το στοιχείο ανίχνευσης ADProvider και η ετικέτα ανίχνευσης ClientThrottlingState επιλέγονται της ιχνογράφησης.
-
Εκτέλεση μιας εντολής στο κέλυφος διαχείρισης Exchange (EMS) ή να εκτελέσετε μια λειτουργία στην κονσόλα διαχείρισης Exchange (EMC). Για παράδειγμα, μπορείτε να εκτελέσετε την εντολή Get-γραμματοκιβώτιο .
Σε αυτό το σενάριο, λαμβάνετε το ακόλουθο μήνυμα λάθους στο EMS ή σε ένα αναδυόμενο παράθυρο από EMC:
Επεξεργασία δεδομένων από απομακρυσμένο διακομιστή απέτυχε με το ακόλουθο μήνυμα λάθους: Ο υπολογιστής-πελάτης δεν μπορεί να συνδεθεί στον προορισμό που καθορίζεται στην αίτηση. Βεβαιωθείτε ότι η υπηρεσία στον προορισμό εκτελείται και δέχεται αιτήσεις. Συμβουλευτείτε τα αρχεία καταγραφής και την τεκμηρίωση για την υπηρεσία WS-Management εκτελείται στον προορισμό, συνήθως οι υπηρεσίες IIS ή το WinRM. Εάν ο προορισμός είναι η υπηρεσία WinRM, εκτελέστε την ακόλουθη εντολή στον προορισμό για να αναλύσετε και να ρυθμίσετε τις παραμέτρους της υπηρεσίας WinRM: "winrm quickconfig". Για περισσότερες πληροφορίες, ανατρέξτε στο θέμα της Βοήθειας about_Remote_Troubleshooting. + CategoryInfo: OperationStopped: [] (System.Manageme...pressionSyncJob:PSInvokeExpressionSyncJob), PSRemotingTransportException + FullyQualifiedErrorId: JobFailure
Αιτία
Αυτό το ζήτημα παρουσιάζεται επειδή η ετικέτα ανίχνευσης ClientThrottlingState είναι ενεργοποιημένη. Όταν είναι ενεργοποιημένη αυτή η ετικέτα ανίχνευσης και κατά την εκτέλεση μιας εντολής, το χώρο συγκέντρωσης εφαρμογών PowerShell διακόπτεται η λειτουργία του και στη συνέχεια κάνει επανεκκίνηση.
Επίλυση
Για να επιλύσετε αυτό το ζήτημα, εγκαταστήστε τη συνάθροιση ενημερώσεων που περιγράφεται στο ακόλουθο άρθρο της Γνωσιακής Βάσης της Microsoft:
982639 Περιγραφή της συλλογής ενημερωμένων εκδόσεων 4 για τον Exchange Server 2010
Λύση
Για να επιλύσετε αυτό το ζήτημα, απενεργοποιήστε την ADProvider ετικέτα και η ετικέτα ClientThrottlingState. Ή, αφήστε τις ετικέτες ενεργοποιημένη και στη συνέχεια καταργήστε τον τύπο εντοπισμού σφαλμάτων . Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:
-
Κάντε κλικ στο κουμπί Έναρξη και, στη συνέχεια, κάντε κλικ στην επιλογή Εκτέλεση.
-
Πληκτρολογήστε C:\Program Files\Microsoft\Exchange Server\V14\Bin\extra.exe στο πεδίο Άνοιγμα και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
-
Κάντε κλικ στο κουμπί Μετάβαση στην οθόνη υποδοχήςκαι, στη συνέχεια, κάντε κλικ στην επιλογή Επιλέξτε μια εργασία.
-
Κάντε κλικ στο Στοιχείο ελέγχου ανίχνευσηςκαι, στη συνέχεια, κάντε κλικ στο κουμπί OK.
-
Κάντε κλικ στο κουμπί Ορισμός μη αυτόματη ανίχνευση ετικέτες.
-
Στην επόμενη σελίδα, κάντε κλικ στο κουμπί " ADProvider " στην καρτέλα στοιχεία ανίχνευσης και, στη συνέχεια, καταργήστε την επιλογή του πλαισίου ελέγχου ClientThrottlingState κάτω από την καρτέλα Ετικέτες ανίχνευσης . Εναλλακτικά, απενεργοποιήστε το πλαίσιο ελέγχου σφαλμάτων .
-
Κάντε κλικ στο κουμπί Έναρξη ανίχνευσηςκαι, στη συνέχεια, κάντε κλικ στο κουμπί Διακοπή ανίχνευσης τώρα.
-
Κάντε κλικ στο κουμπί Έξοδος.
Ακόμη και μετά τη διακοπή της ανίχνευσης και απενεργοποιήστε το tag, αυτό το πρόβλημα μπορεί να συνεχιστεί για ένα χρονικό διάστημα. Αυτό το ζήτημα εξακολουθεί να υφίσταται, εάν η ιδιότητα Debug TraceLevel περιέχεται στην ετικέτα ADProvider:ClientThrottlingState στο αρχείο EnabledTraces.Config . Εάν εξακολουθείτε να αντιμετωπίζετε αυτό το ζήτημα, μετονομάστε ή διαγράψτε το αρχείο EnabledTraces.Config στη μονάδα δίσκου συστήματος (η μονάδα δίσκου C).
Κατάσταση
Η Microsoft έχει επιβεβαιώσει ότι πρόκειται για ένα ζήτημα των προϊόντων της Microsoft που παρατίθενται στην ενότητα "Ισχύει για".