Συμπτώματα
Όταν προσπαθείτε να τροποποιήσετε εταιρικά δεδομένα στο παράθυρο "Διαχείριση ρύθμισης εταιρείας", λαμβάνετε το ακόλουθο μήνυμα σφάλματος:
Η επιλεγμένη εταιρεία τροποποιείται από άλλο χρήστη
Αυτό το πρόβλημα παρουσιάζεται όταν χρησιμοποιείτε τη Διαχείριση αναπλήρωσης στην Επιχειρηματική πύλη για το Microsoft Dynamics GP και για τις επιχειρηματικές λύσεις της Microsoft - Great Plains.
Όταν παρουσιαστεί αυτό το πρόβλημα, κανένας άλλος χρήστης δεν έχει πρόσβαση σε αυτά τα εταιρικά δεδομένα στην Επιχειρηματική πύλη.
Αιτία
Το μήνυμα σφάλματος προκαλείται από μια εγγραφή χρήστη που δεν απαλείφεται από τον πίνακα MultiUserManager. Ο πίνακας MultiUserManager βρίσκεται στη βάση δεδομένων Dynamics.
Επίλυση
Για να επιλύσετε αυτό το πρόβλημα, ακολουθήστε τα παρακάτω βήματα:
-
Εκτελέστε την ακόλουθη δέσμη ενεργειών SQL "Ανάλυση ερωτήματος" για να δείτε ποιες εγγραφές χρηστών δεν απαλείφονται στον πίνακα MultiUserManager.
SELECT * FROM DYNAMICS..MultiUserManager
Σημειώστε ότι ο πίνακας MultiUserManager θα πρέπει να απαλείφεται κάθε 20 λεπτά. Ωστόσο, ορισμένες φορές οι εγγραφές χρηστών παραμένουν στον πίνακα.
-
Για να διαγράψετε την εγγραφή χρήστη από τον πίνακα, εκτελέστε την ακόλουθη δέσμη ενεργειών.
Σημείωση Δημιουργία αντίγραφου ασφαλείας της βάσης δεδομένων Dynamics πριν από την εκτέλεση της δέσμης ενεργειών.DELETE DYNAMICS..MultiUserManager WHERE UserID = XXX
Σημείωση Αντικατάσταση XXX με το αναγνωριστικό χρήστη της εγγραφής χρήστη που επιστράφηκε στο βήμα 1.
Περισσότερες πληροφορίες
Βήματα για την αναπαραγωγή του ζητήματος
-
Έναρξη επιχειρηματικής πύλης.
-
Κάντε κλικ στην επιλογή "Ρυθμίσεις", τοποθετήστε το δείκτη του ποντικιού στην επιλογή "Εφαρμογή Ρυθμίσεις",τοποθετήστε το δείκτη του ποντικιού στην επιλογή "Αιτήσεις" και, στη συνέχεια, κάντε κλικ στην επιλογή "Ρύθμιση εταιρείας".
-
Επιλέξτε μια εταιρεία και, στη συνέχεια, κάντε κλικ στην επιλογή "Τροποποίηση".