Μετάβαση στο κύριο περιεχόμενο
Υποστήριξη
Είσοδος με Microsoft
Είσοδος ή δημιουργία λογαριασμού.
Γεια σας,
Επιλέξτε διαφορετικό λογαριασμό.
Έχετε πολλούς λογαριασμούς
Επιλέξτε τον λογαριασμό με τον οποίο θέλετε να εισέλθετε.

Συμπτώματα

Όταν ξεκινάτε τον Microsoft FRx Report Server, λαμβάνετε το ακόλουθο μήνυμα σφάλματος:

Σφάλμα 3709 - Η σύνδεση δεν μπορεί να χρησιμοποιηθεί για την εκτέλεση αυτής της λειτουργίας

Αιτία

Αυτό το πρόβλημα παρουσιάζεται για έναν από τους ακόλουθους λόγους.

Αιτία 1

Οι σταθμοί εργασίας δεν έχουν την ίδια έκδοση του Microsoft FRx Designer ή του Microsoft FRx Report Server. Ανατρέξτε στην ανάλυση 1 στην ενότητα "Επίλυση".

Αιτία 2

Οι απαραίτητοι φάκελοι Microsoft FRx έχουν εσφαλμένα δικαιώματα χρήστη. Ανατρέξτε στην ανάλυση 2 στην ενότητα "Επίλυση".

Αιτία 3

Το μπλοκ δόμησης είναι κατεστραμμένο, το σύνολο προδιαγραφών είναι κατεστραμμένο ή τα αρχεία .f32 είναι κατεστραμμένα. Ανατρέξτε στην ανάλυση 3 στην ενότητα "Επίλυση".

Αιτία 4

Το αρχείο FRxQue32.mdb είναι κατεστραμμένο. Ανατρέξτε στην Ανάλυση 4 στην ενότητα "Επίλυση".

Επίλυση

Ανάλυση 1

Για να επιλύσετε αυτό το πρόβλημα, ελέγξτε την έκδοση του Microsoft FRx σε κάθε υπολογιστή που έχει κώδικα FRx της Microsoft. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα.

Microsoft FRx Designer

  1. Κάντε κλικ στην επιλογή "Έναρξη",κάντε κλικστην επιλογή "Αναζήτηση" και, στη συνέχεια, πληκτρολογήστε FRx32.exe.

  2. Κάντε δεξί κλικ στην επιλογήFRx32.exeκαι, στη συνέχεια, κάντε κλικ στην επιλογή "Ιδιότητες".

  3. Κάντε κλικ στην καρτέλα "Έκδοση" και, στη συνέχεια, σημειώστε την έκδοση αρχείου.

Microsoft FRx Report Server

  1. Κάντε κλικ στην επιλογή "Έναρξη",κάντε κλικστην επιλογή "Αναζήτηση" και, στη συνέχεια, πληκτρολογήστε RptSvr32.exe.

  2. Κάντε δεξί κλικ στην επιλογήRptSvr32.exeκαι, στη συνέχεια, κάντε κλικ στην επιλογή "Ιδιότητες".

  3. Κάντε κλικ στην καρτέλα "Έκδοση" και, στη συνέχεια, σημειώστε την έκδοση αρχείου.

Αυτές οι εκδόσεις αρχείων πρέπει να είναι πανομοιότυπες σε κάθε σταθμό εργασίας στο δίκτυο. Εάν οι εκδόσεις αρχείων δεν είναι πανομοιότυπες, πρέπει να εφαρμόσετε το κατάλληλο service pack στην εφαρμογή που δεν έχει την ίδια έκδοση αρχείου.


Μπορείτε επίσης να κάνετε ενημέρωση στο πιο πρόσφατο service pack. Για περισσότερες πληροφορίες, επισκεφθείτε μία από τις ακόλουθες τοποθεσίες της Microsoft στο Web, ανάλογα με το αν είστε συνεργάτης ή πελάτης.

Συνεργάτες

https://mbs.microsoft.com/partnersource/products/GreatPlains/downloads/servicepackΠελάτες

https://mbs.microsoft.com/customersource/support/downloads/servicepacks

Ανάλυση 2

Ορισμός των σωστών δικαιωμάτων

Ορίστε τα σωστά δικαιώματα σε όλους τους φακέλους στους οποίο πρέπει να έχει πρόσβαση το Microsoft FRx. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα.

  1. Συνδεθείτε στον υπολογιστή ως τοπικός διαχειριστής ή ως διαχειριστής τομέα.

  2. Κάντε κλικ στην επιλογή "Έναρξη",κάντε κλικ στην επιλογή "Αναζήτηση"και, στη συνέχεια, κάντε κλικ στην επιλογή "Όλα τα αρχεία και οι φάκελοι".

  3. Αναζητήστε τους ακόλουθους φακέλους:

    • Ο φάκελος κώδικα FRx. Από προεπιλογή, η διαδρομή είναι C:\Program Files\FRx Software

    • Ο IO_Data φακέλου.

    • Ο φάκελος SysData.

    • Ο φάκελος Temp.

    • Ο φάκελος MSInfo.

    • Ο φάκελος System32.

  4. Για κάθε φάκελο που παρατίθενται στο βήμα 3, ακολουθήστε τα παρακάτω βήματα:

    1. Κάντε δεξί κλικ στο φάκελο και, στη συνέχεια, κάντε κλικ στην επιλογή "Ιδιότητες".

    2. Στο παράθυρο διαλόγου "Ιδιότητες", κάντε κλικ στην καρτέλα "Ασφάλεια".

    3. Βεβαιωθείτε ότι ο χρήστης διαχειριστή και όλοι οι χρήστες του Microsoft FRx έχουν τα ακόλουθα δικαιώματα:

      • Για το φάκελο κώδικα FRx: Πλήρης έλεγχος

      • Για τον IO_Data: Πλήρης έλεγχος

      • Για το φάκελο SysData: Πλήρης έλεγχος

      • Για το φάκελο Temp: Πλήρης έλεγχος

      • Για το φάκελο MSInfo: Πλήρης έλεγχος

      • Για το φάκελο System32: Τουλάχιστον "Ανάγνωση & Εκτέλεση"

    4. Εάν υπάρχουν χρήστες που έχουν ρυθμιστεί σε διαφορετικές ομάδες ασφαλείας, βεβαιωθείτε ότι αυτοί οι χρήστες έχουν τα ίδια δικαιώματα με τις ομάδες στο βήμα 4c.

Ανάλυση 3

Για να επιλύσετε αυτό το πρόβλημα, διορθώστε το μπλοκ δόμησης, διορθώστε το σύνολο προδιαγραφών ή διορθώστε τα αρχεία .f32. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:

  1. Εάν το σφάλμα περιορίζεται σε έναν κατάλογο, μία γραμμή, μία στήλη ή ένα δέντρο, δημιουργήστε εκ νέου αυτό το συγκεκριμένο μπλοκ δόμησης.

  2. Εάν το σφάλμα παρουσιάζεται για πολλά μπλοκ δόμησης, δημιουργήστε ένα νέο σύνολο προδιαγραφών που περιέχει ένα νέο αρχείο .f32. Για να το κάνετε αυτό, ακολουθήστε τα παρακάτω βήματα:

    1. Ξεκινήστε το Microsoft FRx, κάντε κλικ στην επιλογή "Εταιρεία" και,στη συνέχεια, κάντε κλικ στην επιλογή "Σύνολα προδιαγραφών".

    2. Επιλέξτε το σύνολο προδιαγραφών που χρησιμοποιεί η εταιρεία.

    3. Κάντε κλικ στην επιλογή"Εξαγωγή" και, στη συνέχεια, επιλέξτε όλα τα στοιχεία σε κάθε καρτέλα.

    4. Κάντε ξανά κλικ στην επιλογή "Εξαγωγή". Δημιουργείται ένα αρχείο .tdb.

    5. Για να δημιουργήσετε ένα νέο σύνολο προδιαγραφών, κάντε κλικ στην επιλογή "Δημιουργία" και,στη συνέχεια, πληκτρολογήστε ένα νέο όνομα αρχείου για το αρχείο .f32 στο
      πλαίσιο "Θέση".

    6. Αποθηκεύστε το νέο σύνολο προδιαγραφών.

    7. Κάντε κλικ στηνεπιλογή "Εισαγωγή" και, στη συνέχεια, επιλέξτε το αρχείο .tdb που δημιουργήθηκε στο βήμα 2d παραπάνω σε αυτή την ενότητα.

    8. Αποθηκεύστε το σύνολο προδιαγραφών.

    9. Κάντε κλικ στην επιλογή"Εταιρεία", κάντεκλικ στην επιλογή "Πληροφορίες" και, στη συνέχεια, επιλέξτε το νέο σύνολο προδιαγραφών στη λίστα "Σύνολο προδιαγραφών". Αποθηκεύστε την εγγραφή της εταιρείας.

    10. Ορίστε την εταιρεία ως την προεπιλεγμένη εταιρεία.

Ανάλυση 4


Για να επιλύσετε αυτό το πρόβλημα, αντικαταστήστε το αρχείο FRxQue32.mdb. Για να το κάνετε αυτό, ακολουθήστε τα εξής βήματα:

  1. Διακόψτε την Οθόνη ουράς FRx της Microsoft. Για να το κάνετε αυτό, κάντε κλικ στο κουμπί "Διακοπή/Τερματισμός".

  2. Μετονομάστε το αρχείο FRxQue32.mdb στον κατάλογο ουράς FRx της Microsoft. Για παράδειγμα, μετονομάστε το αρχείο ως FRxQue32.old.

  3. Κάντε ένα αντίγραφο του αρχείου FRxQue32.tpl και, στη συνέχεια, μετονομάστε το αντίγραφο σε FRxQue32.mdb. Το αρχείο FRxQue32.tpl βρίσκεται στον κατάλογο SysData.

  4. Κάντε διπλό κλικ στο αρχείοRptSvr32.exe για να επανεκκινήσετε την Οθόνη ουράς FRx της Microsoft. Για να βρείτε το RptSvr32.exe, ακολουθήστε τα παρακάτω βήματα:

    1. Κάντε δεξί κλικ στην Έναρξη και, στησυνέχεια, κάντε κλικ στην επιλογή "Εξερεύνηση όλων των χρηστών".

    2. Εντοπίστε το φάκελο κώδικα του Microsoft FRx Report Server. Από προεπιλογή, η διαδρομή είναι η εξής:

      C:\Program Files\FRx Software\FRx 6.7 Report ServerThe RptSvr32.exe αρχείο βρίσκεται σε αυτόν το φάκελο.

    ΣημείωσηΜπορείτε να αντιμετωπίσετε το ακόλουθο πρόβλημα:

    • Τα αρχεία που έχουν επέκταση ονόματος αρχείου .ldb ή επέκταση ονόματος αρχείου .lck παραμένουν στο φάκελο Microsoft FRx SysData ακόμα και όταν δεν υπάρχουν χρήστες συνδεδεμένοι στο Microsoft FRx.

    Εάν αντιμετωπίσετε αυτό το πρόβλημα, το καιροσκοπικό κλείδωμα μπορεί να καταστρέψει τη βάση δεδομένων Microsoft Jet. Αυτό το πρόβλημα μπορεί να προκύψει εάν ο διακομιστής που φιλοξενεί το φάκελο Microsoft FRx SysData εκτελεί οποιοδήποτε από τα ακόλουθα προγράμματα:

    • Microsoft Windows Server 2003 ή Windows Server 2003 Terminal Server

    • Microsoft Windows 2000 Server ή Windows 2000 Server Terminal Services

    • Windows Server 2003 Terminal Server μαζί με Citrix

    Για να αποτρέψετε το καιροσκοπικό κλείδωμα από την καταστροφή της βάσης δεδομένων Microsoft Jet, εγκαταστήστε το πιο πρόσφατο service pack Windows Server. Ωστόσο, εάν αυτό το πρόβλημα εξακολουθεί να παρουσιάζεται μετά την εγκατάσταση του πιο πρόσφατου service pack Windows Server, απενεργοποιήστε το καιροσκοπικό κλείδωμα. Για περισσότερες πληροφορίες σχετικά με τον τρόπο απενεργοποίησης του οπορτουνιστικού κλειδώματος, κάντε κλικ στους αριθμούς των άρθρων παρακάτω για να προβάλετε τα άρθρα της Γνωσιακής Βάσης της Microsoft:

    296264 Ρύθμιση παραμέτρων του οπορτουνιστικού κλειδώματος Windows

    129202 PC Ext: Επεξήγηση του οπορτουνιστικού κλειδώματος σε Windows NT Τα προϊόντα τρίτων κατασκευαστών που αναφέρονται σε αυτό το άρθρο κατασκευάζονται από εταιρείες που είναι ανεξάρτητες

    από τη Microsoft. Η Microsoft δεν παρέχει καμία εγγύηση, ρητή ή άλλη, σχετικά με τις επιδόσεις ή την αξιοπιστία αυτών των προϊόντων.

Χρειάζεστε περισσότερη βοήθεια;

Θέλετε περισσότερες επιλογές;

Εξερευνήστε τα πλεονεκτήματα της συνδρομής, περιηγηθείτε σε εκπαιδευτικά σεμινάρια, μάθετε πώς μπορείτε να προστατεύσετε τη συσκευή σας και πολλά άλλα.

Οι κοινότητες σάς βοηθούν να κάνετε και να απαντάτε σε ερωτήσεις, να δίνετε σχόλια και να ακούτε από ειδικούς με πλούσια γνώση.

Σας βοήθησαν αυτές οι πληροφορίες;

Πόσο ικανοποιημένοι είστε με τη γλωσσική ποιότητα;
Τι επηρέασε την εμπειρία σας;
Πατώντας "Υποβολή" τα σχόλια σας θα χρησιμοποιηθούν για τη βελτίωση των προϊόντων και των υπηρεσιών της Microsoft. Ο διαχειριστής IT θα έχει τη δυνατότητα να συλλέξει αυτά τα δεδομένα. Δήλωση προστασίας προσωπικών δεδομένων.

Σας ευχαριστούμε για τα σχόλιά σας!

×