Symptoms
After you change your user account password, you can't sign in to the Skype for Business (Microsoft Lync 2013) client.
Note The only way to sign in to the client is to manually rename files in the following system folder:C:\Users\<User>\AppData\Roaming\Microsoft\Crypto\RSA
Cause
This issue occurs because the Rivst-Shamir-Adleman (RSA) key is not updated as expected.
Resolution
To fix this issue, install the November 1, 2016, update (KB3127934) for Skype for Business. Note Lync 2013 was upgraded to Skype for Business in April 2015.