Symptoms

The Export-ModernPublicFolderStatistics.ps1 script doesn’t work in Microsoft Exchange Server 2019, and you receive an error message that resembles the following:

2222.png

Resolution

To fix this issue, install the Cumulative Update 5 for Exchange Server 2019 or a later cumulative update for Exchange Server 2019.​

References

Learn about the  terminology that Microsoft uses to describe software updates.

Workaround

To work around this issue, update the script with below changes:

$script:Exchange16MajorVersion = 15;

$script:Exchange16MinorVersion = 1;

$script:Exchange16CUBuild = 669;

$script:Exchange17MajorVersion = 15;

$script:Exchange17MinorVersion = 2;

$script:Exchange17CUBuild = 196;


And

$hasMinE16Version = (($version.Major -eq $script:Exchange16MajorVersion) -and

($version.Minor -eq $script:Exchange16MinorVersion) -and

($version.Build -ge $script:Exchange16CUBuild));

$hasMinE17Version = (($version.Major -eq $script:Exchange17MajorVersion) -and

($version.Minor -eq $script:Exchange17MinorVersion) -and

($version.Build -ge $script:Exchange17CUBuild));

if (!$hasMinE15Version -and !$hasMinE16Version -and !$hasMinE17Version)

{

$failedServers += $server.Fqdn;
}

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Any additional feedback? (Optional)

Thank you for your feedback!

×