Applies ToBizTalk Server Branch 2010 BizTalk Server Standard 2010 BizTalk Server Developer 2010 BizTalk Server Enterprise 2010 BizTalk Server 2009 Branch BizTalk Server 2009 Developer BizTalk Server 2009 Enterprise BizTalk Server 2009 Standard BizTalk Server 2013 Branch BizTalk Server 2013 Developer BizTalk Server 2013 Enterprise BizTalk Server 2013 Standard

Symptoms

When you use Microsoft System Center Operations Manager to monitor a computer that is running Microsoft BizTalk Server 2009 and BizTalk Server 2010, BizTalk Server experiences slow performance.Note When this issue occurs, you may experience the following issues:

  • You cannot log on to the computer.

  • You cannot start BizTalk Administration Console.

  • A Service Host process (Svchost.exe) consumes a large amount of memory.

Cause

This issue occurs because of deadlocks that occur when BizTalk threads run BizTalk Windows Management Instrumentation (WMI) queries. Therefore, the Svchost.exe process that hosts the WMI service (Winmgmt) may eventually create thousands of threads.

Resolution

Cumulative update information

BizTalk Server 2009

The hotfix that resolves this issue is included in cumulative update package 7 for BizTalk Server 2009.For more information about how to obtain the cumulative update package, see Cumulative update package 7 for BizTalk Server 2009.

BizTalk Server 2010

The fix that resolves this issue is included in cumulative update package 6 for BizTalk Server 2010.For more information about how to obtain the cumulative update package, see Cumulative update package 6 for BizTalk Server 2010.

BizTalk Server 2013

The fix that resolves this issue is included in cumulative update package 3 for BizTalk Server 2013.For more information about how to obtain the cumulative update package, see Cumulative Update 3 (CU3) for BizTalk Server 2013.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Workaround

To work around the issue, restart the server periodically.

References

For more information about a similar issue that is fixed in cumulative update package 5 for BizTalk 2009, see FIX: Applications stop responding or crash when System Center Operations Manager monitors BizTalk Server applications.For information about the service packs and cumulative update list for BizTalk Server, see Service pack and cumulative update list for BizTalk Server.For more information about BizTalk hotfixes and service packs support, see Information about BizTalk hotfixes and service pack support.

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