Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You open a Windows Form solution in Microsoft Visual Studio 2010 by using the Visual C# language. A project in the solution has the following features:

    • The project contains a Windows Form. The Windows Form is declared in a namespace that has four levels. For example, the Windows Form is declared in namespace A.B.C.D.

    • The project references an assembly that contains the same namespace together with a child namespace. The child namespace includes only inaccessible types. For example, the child namespace includes inaccessible type A.B.C.D.X.ClassX.

    • The project references another assembly that exposes a public control. For example, the project references public control A.B.C.X.Control1.

  • You perform one of the following actions:

    • You drag public control A.B.C.X.Control1 to the Windows Form.

    • You remove the public control, and then drag it to the Windows Form again.

  • You save the project, and then try to build the solution.

In this scenario, the build process fails and you receive the following error message:

The type or namespace name 'ClassName' does not exist in the namespace 'Namespace' (are you missing an assembly reference?)

Note In this error message, ClassName is a placeholder that represents the actual name of the class and Namespace is a placeholder that represents the actual namespace.

Cause

This issue occurs because an incorrect minimally qualified name for the public control is generated in the source code. For example, the public control is represented as "X.Control1" instead of "C.X.Control1." The minimally qualified name generation process in Visual Studio ignores the inaccessible types in the child namespace. However, the Visual C# compiler does not ignore inaccessible types. Therefore, this issue occurs.  

Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Visual Studio 2010 installed.

Restart requirement

You must restart the computer after you apply the hotfix if the affected file is being used.

We recommended that you close any instance of Visual Studio before you apply the hotfix.

Hotfix replacement information


This hotfix does not replace any other hotfix.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported versions of Visual Studio 2010

File name

File version

File size

Date

Time

Platform

Cslangsvc.dll

10.0.30319.422

5,763,920

28-Jan-2010

07:47

x86


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×