Summary

This article describes the issues that are fixed in the Microsoft SharePoint Foundation 2010 hotfix package that is dated June 10, 2014.

Introduction

Issues that this hotfix package fixes

  • Consider the following scenario:

    • You configure a workflow to start automatically for a SharePoint list on a SharePoint 2010 site.

    • You save the site as a template, and then you create a new site based on the template.

    • You deactivate the solution for the template in the Solutions Gallery.

    In this scenario, the workflow event receivers are removed from the list in the site created from the template. Therefore, workflows no longer start automatically.

  • The SPBackupResotoreConsole.Run method may fail on a SharePoint 2010 Foundation environment that uses Remote BLOB Storage (RBS).

  • Assume that you open an Office document from a SharePoint library, and you edit it, and then you leave it unattended. After several minutes, you access the same document without opening it in any Office applications (for example, you click the document on a mapped network drive that is mapped to the SharePoint library), and then you try to save the opened document. In this situation, the save operation fails. Additionally, you receive the following error message:

    Unable to save the document.


  • Assume that you upload an Office document that is signed with a digital signature to a SharePoint library. When you add a new content type to the library, the digital signature of the document becomes invalid.

  • Assume that you create a SharePoint list that contains a content type that contains a lookup column. When you update a lookup column in the Site Column Gallery, the lookup column in the list is not updated.

  • Assume that you create a SharePoint site based on the "FAB 40" template. When you try to save the site as a site template, the save operation fails. Additionally, you receive an error message that resembles the following:

    Error exporting the site field named "Properties". Correlation ID: daa956d6-b152-4d9e-9754-fe0825358703


  • After you install SharePoint Foundation 2010 Service Pack 2 (SP2), when you browse the SharePoint site by using Windows Internet Explorer 8, some SharePoint pages may not be displayed correctly.

  • Alert email messages are not sent to all subscribers if the alert is based on a filtered view.

  • Assume that you browse to a SharePoint 2010 site by using Internet Explorer 11. If you enter a user’s email address in the People Picker text box and then click Check Names, the user cannot be resolved. Additionally, you receive the following error message:

    No exact match was found


  • Assume that you create a SharePoint workflow that starts automatically when an item is edited. In this situation, the WorkflowChangePath property may experience unbounded growth. 

More Information

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problems that are described in this article. Apply this hotfix only to systems that are experiencing the problems described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have either SharePoint Foundation 2010 Service Pack 1 (SP1) or Service Pack 2 (SP2) installed.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2510766 List of all SharePoint 2010 and Office Server 2010 SP1 packages

2687522 List of all SharePoint 2010 and Office Server 2010 SP2 packages

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

This hotfix may not contain all the files that you must have to fully update a product to the latest build. This hotfix contains only the files that you must have to resolve the issues that are listed in this article.

The global version of this hotfix package uses a Microsoft Windows Installer package to install the hotfix package. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Any additional feedback? (Optional)

Thank you for your feedback!

×