Symptoms
When creating a connection to run my desktop flow on a machine, I am not able to see my machine in the machines list.
Verifying issue
1- Check by opening Power Automate Desktop that your machine is registered.
2- Check by going to the Power Automate Portal that you're in the same environment as your machine was in Power Automate Desktop.
3- Check that your machine is not inside a group
Cause
If the machine was shared it could have been deleted or renamed by the users that were able to access it. If the machine is inside a group, you can only create a connection with the machine group.
Resolution
If the machine was not appearing in the machine list in the targeted environment, you can register the machine again in this environment, follow this documentation for more details.
If the machine was inside a group you can either select the group instead of the machine to create the connection or make the machine leave the group to select only the machine.