Symptoms
Consider the following scenario in a Microsoft Skype for Business Server 2019 or Skype for Business Server 2015 environment:
-
You have a Skype for Business Front End pool that has several Front End servers.
-
You have a Unified Communications Managed API (UCMA) application that's used for conferencing call, chat, subscribes, and so on. In addition, it's running against the Front End pool.
-
One Skype for Business Front End server in the pool goes down.
-
You make a call by using the UCMA application.
In this scenario, the call fails.
Cause
This issue occurs because the connection from the UCMA application is still established with the offline Front End server instead of other available Front End servers in the pool.
Resolution
To fix this issue, install the following updates:
-
The July 2019 cumulative update 7.0.2046.123 for Skype for Business Server 2019 and Unified Communications Managed API 5.0 Runtime.
-
The May 2019 cumulative update 6.0.9319.548 for Skype for Business Server 2015 and Unified Communications Managed API 5.0 Runtime.