Applies ToWindows Vista Business Windows Vista Enterprise Windows Vista Home Premium Windows Vista Ultimate Windows 7 Enterprise Windows 7 Home Premium Windows 7 Professional Windows 7 Ultimate

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Symptoms

There is no reaction of language switch key in language bar, or the language bar disappears and unable to switch the input language from Korean to English in Windows 7 and Windows Vista.

Cause

Following issues can cause problems.

  • There is an error in registering the library module relating to language bar.

  • task scheduler service is stopped or MSCtfMonitordid not run.

How do I fix

Method 1: reregister the library module relating to language bar

  1. Click [Start] and enter cmdIn the search window.

  2. Right-click [cmd] in the list of program lists, and click [Run as Administrator].

    When the user account control message appears, type the administrator password, or click [Yes].

  3. Type egsvr32.exe msimtf.dll at the command prompt screen, and then press Enter.

    "When you receive the message "DllRegisterServer in msimtf.dll is successful.", click [OK].

  4. Type regsvr32.exe msctf.dll and then press Enter.

    "When you receive the message "DllRegisterServer in the msctf.dll is successful." click [OK].

  5. Type exitand then press Enter to close the command prompt.

  6. Restart your computer and check if the problem is solved.

Method 2: start the task scheduler service, and then run MSCtfMonitor.

Please see the following technical article to solve the problem.

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