WSD scan fails when you scan many pages in Windows

Symptoms

Assume that you create a Web Service on Device (WSD) scan environment that has Windows 8.1-based, Windows 8-based, or Windows 7-based computers and a WSD scanner. Then, you try to scan multiple pages of paper through the WSD scanner in one tray. In this situation, the scan fails.

Cause

This issue occurs because WSD does not process the scanned data correctly in some cases.

Resolution

To resolve this issue for Windows 8.1 and Windows Server 2012 R2, install the hotfix that is described in this article.

To resolve this issue for Windows 8 or Windows Server 2012, install update rollup 2928678, or install the hotfix that is described in this article.

To resolve this issue for Windows 7 or Windows Server 2008 R2, install the hotfix that is described in this article.

Update information for Windows 8 and Windows Server 2012

For more information about how to obtain update rollup 2928678, click the following article number to view the article in the Microsoft Knowledge Base:
2928678 Windows RT, Windows 8, and Windows Server 2012 update rollup: March 2014

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 8.1
  • Windows Server 2012 R2
  • Windows 8
  • Windows Server 2012
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2 SP1
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may be prompted to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information
Properties

Article ID: 2930287 - Last Review: 23 Jun 2014 - Revision: 1

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