KB3205937 - FIX: An assertion occurs when you restore a clone database that has Query Store enabled in SQL Server 2014

Applies To
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptoms

Assume that you create a clone database that has Query Store enabled in an instance of SQL Server 2014. When you restore the clone database to another instance of SQL Server, the restore fails, and you receive the following error message:

Note

Restore of database database_name failed. (Microsoft.SqlServer.Management.RelationalEngineTasks)
System.Data.SqlClient.SqlError: RESTORE DATABASE is terminating abnormally. (Microsoft.SqlServer.SmoExtended)

Additionally, a system assertion is logged in SQL Server error log.

Resolution

This issue is fixed in the following cumulative update for SQL Server:

Cumulative Update 3 for SQL Server 2014 Service Pack 2
      

About cumulative updates for SQL Server

Each new cumulative update for SQL Server contains all the hotfixes and all the security fixes that were included with the previous cumulative update. Check out the latest cumulative updates for SQL Server:

Latest cumulative update for SQL Server 2014
      

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

Learn about the terminology Microsoft uses to describe software updates.