Applies ToDynamics 365 Customer Engagement Online

Symptom

After Testing and Enabling a mailbox for Appointments, Contacts, and Task (ACT) synchronization, the following warning message appears in the mailbox alerts:

“Appointments, contacts, and tasks can't be synchronized because there are too many connections to the mailbox”

Cause

This error is most commonly encountered when Server-Side Synchronization attempts to establish an initial synchronization state with the Exchange Server. In order to establish the initial synchronization state, Dynamics must retrieve each item in each of the ACT folders and sub-folders. However, if one or more folders contains thousands of items, this can cause Server-Side Sync to issue many requests in a short period of time to onboard the folder. When this occurs, Exchange Server may throttle these requests, which results in the error found in the mailbox alert.

Resolution

Review the Calendar, Contacts, and Task folders (and sub-folders) in the affected mailbox and archive or remove any items that are no longer required.

Please see the below link for more information about Outlook archiving:

https://support.microsoft.com/en-us/office/archive-items-manually-ecf54f37-14d7-4ee3-a830-46a5c33274f6

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