Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

User sees the following errors while using Desktop flows -

1. While visiting the Desktop flows tab, user sees this error -

You need permissions to use Microsoft Dataverse. Verify if a Dataverse license has been assigned to the user and assign one if not already. Once a license is assigned, it may take some time for the license change to sync to the Dataverse environment.

2. While saving the desktop flows, user sees this error - 

Verify if a Dataverse license has been assigned to the user and assign one if not already. Once a license is assigned, it may take some time for the license change to sync to the Dataverse environment.

Cause

  • User does not have a Dataverse license (or)

  • User does not belong to the Dataverse organization

Resolution

Reach out to a tenant admin and follow this article to resolve the issue.

Note: Updates to licenses and apps may take a couple minutes to take effect in Power Automate.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×