Symptom
Users are not able to open reports.
"Something has gone wrong. Check technical details for more details."
Cause
Reports are failing to load in UCI with error "Form descriptor is null or not defined"
Reports in UCI still require legacy dialogs, so the customer system needs to have allowlegacydialogsembedding enabled.
Mitigation
Go to Settings >Administration > System Settings > General tab
Set "Enable embedding of certain legacy dialogs in Unified Interface browser client" to be "Yes"