Symptoms
When you try to share a calendar by using Microsoft Outlook, Outlook on the web, or Exchange Online PowerShell, you receive one or more of the following errors messages.
Outlook for Windows
This calendar can't be shared by one or more people.
Outlook on the web
You don't have permission to share your calendar with <email address>.
Exchange Online PowerShell
Your request can't be completed. You don't have permission to share this calendar.
Cause
This issue occurs if the calendar that you're sharing is listed two times in the Calendar pane in Outlook. The duplicate calendar name appears the same as <Mailbox Owner>.
Workaround
To work around this issue, use one of the following methods to remove the duplicate calendar in the Calendar pane.
Method 1: Use the Outlook for Windows client to delete the calendar
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In Outlook for Windows, open the Calendar pane, and then locate the calendar name that is the same as <Mailbox Owner>.
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Right-click the calendar, and then select Delete Calendar.
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Restart Outlook.
Method 2: Use Outlook on the web to delete the calendar
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In Outlook on the web, open the Calendar pane, and then locate the calendar name that is the same as <Mailbox Owner>.
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Right-click the calendar, and then select Delete.
Method 3: Use MFCMapi to delete the calendar
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Exit Outlook, and then close Outlook on the web on all computers that are connected to the user mailbox.
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Follow these steps in MFCMapi to delete the duplicate calendar name.
Note To be able to do these steps, you have to use a Windows client to log on to the calendar owner's computer, or have the calendar owner's Outlook profile configured on a Windows client.-
Download MFCMapi from GitHub.
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Run Mfcmapi.exe.
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Select the Tools menu, and then select Options.
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Select the following check box: Use MDB_ONLINE when calling OpenMsgStore.
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Select OK.
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On the Session menu, select Logon.
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If you are prompted for a profile, select your profile name, and then select OK.
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In the top pane, locate and double-click the line that corresponds to your mailbox.
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In the left pane, expand Root Container.
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Right-click Common Views, and then select Open Associated Contents table.
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In the Subject column, locate and select the calendar name that is the same as <Mailbox Owner>.
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Open the Actions menu, and then select Delete Message.
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Close the window.
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On the Session menu, select LogOff to log out of MFCMapi.
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Status
The Microsoft 365 service incident EX249095 that tracked this issue was resolved as fixed on May 31, 2021.