Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When Microsoft Lync Server 2013 or Skype for Business Server 2015 Response Group Service (RGS) crashes one or two times a week with the announcement service, the affected RGS restarts automatically. However, no agents can receive calls that come through this RGS. You may see the following events in the Event Viewer:

Time: <Time>
ID: 32002
Level: Information
Source: LS Application Server
Machine: ComputerName.contoso.com
Message: The Application Host has stopped an application.
The Application Host has stopped application RTCRGS

Time: <Time>
ID: 32007
Level: Error
Source: LS Application Server
Machine: ComputerName.contoso.com
Message: The Application Host stopped due to an unhandled exception in the application.

The Application Host received an unhandled exception while running application urn:application:RGS. Exception information: Exception: System.Reflection.TargetInvocationException
> Message: Exception has been thrown by the target of an invocation.

Cause

After the RGS crashes, it will try to restart automatically. Unfortunately, the Match Making service that's a component of the RGS doesn't connect to any Front-End server and therefore no agents can receive calls coming through RGS. The only way to make RGS in a functional operation is to manually restart the RGS on each Front-End server.

Resolution

For Skype for Business Server 2015, install the July 2018 cumulative update 6.0.9319.534 for Skype for Business Server 2015, Response Group Service.

For Lync Server 2013, install the July 2018 cumulative update 5.0.8308.1001 for Lync Server 2013, Response Group service.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×