Symptoms

Consider the following scenario:

  • The Active Directory Domain Services role service is installed on a domain controller that is running Windows Server 2008 R2.

  • One or more teaming network interfaces are installed on the domain controller.

  • You run the Domain Controller Diagnostics tool (Dcdiag.exe) at the command prompt of a domain controller that is running Windows Server 2008 R2 or of a computer that is running Windows 7.

In this scenario, the connectivity test that is run by the Dcdiag.exe tool fails. Additionally, you receive the following error message in the Dcdiag.exe tool output:

Testing server: <site>\<DCNAME>Starting test: Connectivity * Active Directory LDAP Services Check Message 0x621 not found.Got error while checking LDAP and RPC connectivity. Please check your firewall settings.......................... <DC Name> failed test Connectivity

Note

  • In some scenarios, you receive the error message without the error code 0x621.

  • The issue only occurs if you run the Dcdiag.exe tool on a server that is running Windows Server 2008 R2 or on a computer that is running Windows 7.

  • The Dcdiag.exe tool outputs the error code 0x621 incorrectly as the following error message:

    Message 0x621 not found.

    The expected error message is as follows:

    Both IPV4 and IPV6 channels are disabled on all adapter cards of the local server. Hence no connectivity to the server.

Cause

This issue occurs because the Dcdiag.exe tool does not use a reliable method to check whether a network connection is a physical interface on a computer that is running in Windows Server 2008 R2. When the teaming network interface is installed, the tool incorrectly detects that the interface is not a physical network interface, and then the tool outputs error code 0x621.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of the following Windows operating systems:

  • Windows 7

  • Windows Server 2008 R2

Additionally, the computer must have the Dcdiag.exe tool installed

Restart information

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Dcdiag.exe

6.1.7600.20595

453,632

13-Dec-2009

08:55

x86

For all supported x64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Dcdiag.exe

6.1.7600.20595

674,304

13-Dec-2009

11:07

x64

Additional files for all supported x86-based versions of Windows 7

File name

Update.mum

File version

Not Applicable

File size

1,458

Date (UTC)

14-Dec-2009

Time (UTC)

09:31

Platform

Not Applicable

---

File name

X86_404b9100f2ed72b15e75ac4a0055a4d7_31bf3856ad364e35_6.1.7600.20595_none_0d0cf1de24ef6f82.manifest

File version

Not Applicable

File size

737

Date (UTC)

14-Dec-2009

Time (UTC)

09:31

Platform

Not Applicable

---

File name

X86_microsoft-windows-d..-commandline-dsdiag_31bf3856ad364e35_6.1.7600.20595_none_4c84297178826d74.manifest

File version

Not Applicable

File size

2,581

Date (UTC)

14-Dec-2009

Time (UTC)

05:33

Platform

Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008 R2

File name

Amd64_305ca61f4d2104e8beedf22ec0d1ff69_31bf3856ad364e35_6.1.7600.20595_none_70acb4e63dfdfa59.manifest

File version

Not Applicable

File size

741

Date (UTC)

14-Dec-2009

Time (UTC)

09:31

Platform

Not Applicable

---

File name

Amd64_microsoft-windows-d..-commandline-dsdiag_31bf3856ad364e35_6.1.7600.20595_none_a8a2c4f530dfdeaa.manifest

File version

Not Applicable

File size

2,585

Date (UTC)

14-Dec-2009

Time (UTC)

06:49

Platform

Not Applicable

---

File name

Update.mum

File version

Not Applicable

File size

2,998

Date (UTC)

14-Dec-2009

Time (UTC)

09:31

Platform

Not Applicable

Workaround

To work around this issue, run the Dcdiag.exe tool from the command prompt of a remote computer by using use the /s parameter to point to the domain controller that is running Windows Server 2008 R2.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about the Dcdiag.exe tool, visit the following Microsoft TechNet Web site:

http://technet.microsoft.com/en-us/library/cc731968(WS.10).aspx

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.