Symptoms
Issue 1
Consider the following scenario:
-
You use a user account to connect to Microsoft Team Foundation Server 2010 (TFS 2010) from Microsoft Visual Studio Team Explorer.
Note The user account was recently added to the security group. -
You try to open a work item in a team project collection.
In this scenario, you cannot access the work item, or a red X error icon appears on the node of the work item.
Issue 2
Consider the following scenario:
-
You use a user account to connect to TFS 2010 from Visual Studio Team Explorer.
-
A user account of the security group has a display_name value that contains more than 256 characters.
Note The values for the display_name field are stored in the tbl_security_identity_cache table of the Tfs_Configuration database. -
You try to open a work item in a team project collection.
In this scenario, you cannot access the work item, or a red X error icon appears on the node of the work item.
Cause
Cause 1
This issue occurs because the user identity re-sync logic is incorrectly triggered. Additionally, it takes a long time to finish the resynchronization process. Therefore, newly added users may not be synchronized immediately to the work item's tracking process.
Cause 2
This issue occurs because many user accounts, memberships, or Access Control Lists (ACLs) are deleted when a display_name value contains more than 256 characters.
Resolution
Hotfix information
A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.
To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
To apply this hotfix, you must have Microsoft Team Foundation Server 2010 (TFS 2010) Service Pack 1 (SP1) installed.
Restart requirement
You have to restart the computer after you apply this hotfix if the affected files are being used.
We recommend that you close all instances of Visual Studio before you install this hotfix.
File information
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Microsoft.teamfoundation.admin.dll |
10.0.40219.339 |
24,698,232 |
03-Aug- 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.server.deploy.tfcollection.dll |
10.0.40219.339 |
561,576 |
03-Aug- 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll |
10.0.40219.339 |
589,256 |
03-Aug- 2011 |
19:03 |
x86 |
Microsoft.teamfoundation.workitemtracking.server.dataservices.dll |
10.0.40219.339 |
142,784 |
03-Aug-2011 |
19:03 |
x86 |
Workaround
To work around this issue, revise the display_name value so that it contains fewer than 256 characters.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.