Symptoms
When you try to import a Microsoft Dynamics CRM Online database into a Microsoft Dynamics CRM 2013 on-premises deployment, you receive the following error message:
The organization database selected for import is a different version than the organizations database that is currently deployed
Cause
This problem occurs because the latest CRM on-premises update rollup has not been applied.
Resolution
To resolve this problem, apply the most recent update rollup to the Dynamics CRM server. To find the most recent updates, see the following Microsoft Knowledge Base article: