Aviso

Modificado el 08/06/2021

El 8 de junio de 2021, se publicó esta actualización con el fin de reemplazar una actualización anterior para solucionar un error de tipo "el servidor de revocación estaba sin conexión" que puede ocurrir durante la instalación. Si ya instaló la versión anterior de esta actualización, no tiene que hacer nada. Para obtener la versión más reciente de estas actualizaciones, consulte la sección "Obtener e instalar la actualización" del artículo de actualización individual.  Los vínculos a cada artículo se encuentran en la sección "Información adicional sobre esta actualización" de este artículo.

El 13 de abril de 2021, se publicó esta actualización con el fin de reemplazar una versión anterior de esta actualización.

Se aplica a:

Microsoft .NET Framework 3.5.1, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.6.1, Microsoft .NET Framework 4.6.2, Microsoft .NET Framework 4.7, Microsoft .NET Framework 4.7.1, Microsoft .NET Framework 4.7.2 y Microsoft .NET Framework 4.8

                IMPORTANTE Antes de instalar esta actualización, compruebe que instaló las actualizaciones necesarias que se enumeran en la sección Obtener esta actualización. 

                IMPORTANTEAlgunos de los clientes que usan Windows Server 2008 R2 SP1 y han activado su complemento de clave de activación múltiple (MAK) de ESU antes de instalar las actualizaciones del 14 de enero de 2020, puede que necesiten volver a activar su clave. La reactivación en los dispositivos afectados solo es necesaria una vez.  Para obtener información sobre la activación, consulte esta entrada de blog.

                IMPORTANTELos archivos .cab de análisis WSUS seguirán estando disponibles para Windows 7 SP1 y Windows Server 2008 R2 SP1. Si tiene un subconjunto de dispositivos que ejecutan estos sistemas operativos sin ESU, es posible que se muestren como no conformes en sus conjuntos de herramientas de administración y cumplimiento de revisiones.

                IMPORTANTE Los clientes que compraron la actualización de seguridad extendida (ESU) para versiones locales de estos sistemas operativos deben seguir los procedimientos de KB4522133 para seguir recibiendo las actualizaciones de seguridad después de que el 14 de enero de 2020 finalice el soporte extendido. Para obtener más información sobre la ESU y qué ediciones son compatibles, consulte KB4497181.

                IMPORTANTE A partir del 15 de enero de 2020 aparecerá una notificación en modo pantalla completa en la que se describe el riesgo de seguir usando Windows 7 Service Pack 1 después de que el 14 de enero de 2020 finalice el soporte La notificación permanecerá en la pantalla hasta que interactúe con ella. Esta notificación solo aparecerá en las siguientes ediciones de Windows 7 Service Pack 1:

                Nota La notificación no aparecerá en equipos unidos a un dominio o en pantalla completa.

                IMPORTANTE A partir de agosto de 2019, las actualizaciones para .NET Framework 4.6 y versiones posteriores, Windows Server 2008 R2 SP1 y Windows 7SP1 requieren compatibilidad con la firma de código SHA-2. Asegúrese de contar con todas las actualizaciones de Windows Update más recientes antes de aplicar esta. De este modo, evitará los problemas de instalación. Para obtener información más detallada sobre las actualizaciones de compatibilidad con las firmas de código SHA-2, consulte KB 4474419.

                IMPORTANTE Todas las actualizaciones de .NET Framework 4.7.2, 4.7.1, 4.7, 4.6.2, 4.6.1 y 4.6 requieren la instalación de la actualización d3dcompiler_47.dll. Es recomendable instalar el archivo d3dcompiler_47.dll incluido antes de aplicar esta actualización. Para obtener más información sobre d3dcompiler_47.dll, consulte el artículo KB 4019990.

                IMPORTANTE Si se instala un paquete de idioma después de esta actualización, habrá que volver a instalar la actualización. Por tanto, se recomienda instalar los paquetes de idioma necesarios antes de instalar esta actualización. Para obtener más información, consulte Add language packs to Windows.

Resumen

Existe una vulnerabilidad de divulgación de información cuando .NET Framework controla de manera incorrecta los objetos en la memoria. Un atacante que aprovechara esta vulnerabilidad podría divulgar el contenido de la memoria de un sistema afectado. Para aprovechar esta vulnerabilidad, un atacante tendría que ejecutar una aplicación especialmente diseñada. La actualización resuelve la vulnerabilidad al corregir cómo .NET Framework controla los objetos en la memoria.

Para obtener más información sobre las vulnerabilidades, consulte las siguientes vulnerabilidades y exposiciones comunes (CVE).

Problemas conocidos en algunas partes de esta actualización

Síntoma

Esta actualización no se instala y devuelve uno o ambos de los siguientes mensajes de error:

  • -2146762495

  • Un certificado necesario no se encuentra dentro del período de validez al comprobarlo con el reloj actual del sistema o con la marca de tiempo del archivo firmado.

  • La función de revocación no pudo comprobar la revocación porque el servidor de revocación estaba sin conexión.

Solución alternativa

Este problema se corrigió con la versión más reciente de las partes afectadas en esta actualización.

Si ya instaló una versión anterior de las partes afectadas, no es necesario realizar ninguna acción.

Información adicional acerca de esta actualización

En los siguientes artículos podrá encontrar información adicional sobre esta actualización relacionada con las versiones de productos individuales.

  • 4578980 Descripción de la actualización de solo seguridad de .NET Framework 3.5.1 para Windows 7 SP1 y Windows Server 2008 R2 SP1 (KB4578980)

  •                 4578983 Descripción de la actualización de solo seguridad de .NET Framework 4.5.2 para Windows 7 SP1, Windows Server 2008 R2 SP1 y Windows Server 2008 SP2 (KB4578983)

  •                 4578987 Descripción de la actualización de solo seguridad de .NET Framework 4.6, 4.6.1, 4.6.2, 4.7, 4.7.1 y 4.7.2 para Windows 7 SP1, Windows Server 2008 R2 SP1 y Windows Server 2008 SP2 (KB4578987)

  • 4578990 Descripción de la actualización de solo seguridad de .NET Framework 4.8 para Windows 7 SP1 y Windows Server 2008 R2 SP1 (KB4578990)

Información sobre protección y seguridad

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?

¿Qué ha afectado a tu experiencia?

¿Algún comentario adicional? (Opcional)

¡Gracias por sus comentarios!

×