Julkaistun lomakemallin siirtäminen uuteen SharePoint-kirjastoon

Käytetään kohteeseen
InfoPath 2010 InfoPath 2013

Tärkeää

Microsoft InfoPath 2013:n tuki päättyi 14. heinäkuuta 2026. Suosittelemme aiemmin luotujen InfoPath-lomakkeiden ja -työnkulkujen siirtämistä tuettuihin Microsoft 365 -ratkaisuihin. Lisätietoja InfoPathin käytöstä poistamisesta.

Tämän artikkelin sisältö

Yleiskatsaus

Kun olet julkaissut lomakemallin asiakirjakirjastoon käyttäjien täytettäväksi, sinun on ehkä siirrettävä lomakemalli toiseen tiedostokirjastoon. Sinun on esimerkiksi ehkä siirrettävä lomakemalli palvelimeen, jossa on enemmän kapasiteettia, jotta useammat käyttäjät voivat täyttää lomakkeita samanaikaisesti. Jotkut käyttäjät ovat ehkä jo täyttäneet alkuperäiseen tiedostokirjastoon tallennettuun lomakemalliisi perustuvia lomakkeita. Kun siirrät lomakemallin uuteen tiedostokirjastoon, haluat varmasti siirtää myös nämä aiemmin luodut lomakkeet. Varmista myös, että aiemmin luodut lomakkeet toimivat uudessa tiedostokirjastossa, ennen kuin arkistoit tai poistat vanhan tiedostokirjaston.

Vihje

Ennen kuin siirrät julkaistuja lomakemalleja uuteen tiedostokirjastoon, laadi suunnitelma, joka sisältää käyttäjille ilmoituksen lomakkeiden siirtämisestä uuteen tiedostokirjastoon. Haluat käyttäjien käyttävän uutta asiakirjakirjastoa uusien lomakkeiden tallentamiseen ja aiemmin luotujen lomakkeiden muokkaamiseen. Suunnitelmaan olisi sisällyttävä myös alkuperäisen tiedostokirjaston arkistointi tai poistaminen.

Jos haluat siirtää lomakemallin ja sen aiemmin luodut lomakkeet uuteen tiedostokirjastoon, sinun on ensin julkaistava lomakemallin toimiva kopio uudessa tiedostokirjastossa. Työkopio on tietokoneeseen tai versionhallintaohjelmaan, kuten Microsoft Visual SourceSafeen, tallennettu työkopio.

Vihje

Jos sinulla ei ole toimivaa kopiota lomakemallista, voit tallentaa lomakemallin kopion alkuperäisestä tiedostokirjastosta tietokoneeseen työkopiona käytettäväksi.

Kun olet julkaissut työversion uuteen tiedostokirjastoon, kaikki lomakkeet vanhasta tiedostokirjastosta on kopioitava uuteen tiedostokirjastoon ja uuden tiedostokirjaston lomakkeet on sitten linkitettävä uudelleen julkaistuun lomakemalliin.

Jos lomakemallin siirtämisen yhteydessä on tehtävä muutoksia, tee muutokset ennen lomakemallin julkaisemista. Esimerkiksi lomakemalliin perustuvien lomakkeiden käyttämien ulkoisten tietolähteiden sijainti voi myös muuttua lomakemallin siirtämisen seurauksena. Tässä tapauksessa sinun on muutettava lomakemallin tietoyhteys ulkoisten tietolähteiden uuteen sijaintiin ennen lomakemallin julkaisemista. Lisätietoja tietoyhteyksien muuttamisesta saat Katso myös - osan linkeistä.

Huomautus

Lomakemallin julkaiseminen ei tarkoita samaa kuin lomakemallin tallentaminen. Kun julkaiset lomakemallin, ohjattu julkaisutoiminto lisää lomakemallin julkaisusijainnin ja käsittelyohjeet siten, että käyttäjät voivat avata tähän lomakemalliin perustuvat lomakkeet. Kun tallennat lomakemallin, tallennat lomakemallin kopion samalla tavoin kuin jos tallentaisit tiedoston tietokoneeseen. Käytä ohjattua julkaisutoimintoa aina, kun haluat asettaa lomakemallin käyttäjien saataville täytettäväksi.

Sivun alkuun

Toimet ennen aloittamista

Ennen kuin siirrät lomakemallin ja siihen mahdollisesti perustuvat olemassa olevat lomakkeet uuteen asiakirjakirjastoon, tarvitset seuraavat asiat:

  • Lomakemallin työkopio Tämä on lomakemallin kopio, jota muokkaat ja julkaiset sitten uudelleen uudessa tiedostokirjastossa. Työkopio voidaan tallentaa tietokoneeseesi tai versionhallintaohjelmaan, kuten Visual SourceSafeen.
  • Uusien ulkoisten tietolähteiden sijainnit Jos lomakemalliin perustuvat lomakkeet käyttävät ulkoisia tietolähteitä, joita on muutettu, tarvitset ulkoisten tietolähteiden uudet sijainnit. Tarkista järjestelmänvalvojalta, että sinulla ja käyttäjillä on riittävät käyttöoikeudet ulkoisiin tietolähteisiin. Jos lomakemalli käyttää tietoyhteystiedoston asetuksia yhteyden muodostamiseksi ulkoiseen tietolähteeseen, varmista, että tietoyhteystiedosto on päivitetty ulkoisen tietolähteen uudella sijainnilla.
  • Tarvittavat oikeudet palvelimessa, jossa on käytössä Windows SharePoint Services 3.0 Tarvitset asianmukaiset oikeudet palvelimessa, jotta voit julkaista lomakemallin ja kopioida olemassa olevia lomakkeita vanhasta tiedostokirjastosta uuteen tiedostokirjastoon. Varmista palvelimen järjestelmänvalvojalta, että sinulla on nämä oikeudet.

Sivun alkuun

Toimivan kopion hankkiminen lomakemallista

Jos haluat muokata lomakemallia, joka on julkaistu asiakirjakirjastossa tai jaetussa verkkosijainnissa, eikä sinulla ole lomakemallin toimivaa kopiota, voit tallentaa lomakemallin toimivan kopion julkaisusijainnista tietokoneeseesi.

Vihje

Harkitse versionhallintaohjelman, kuten Microsoft Visual SourceSafen, käyttämistä lomakemallien toimivien kopioiden hallintaan.

Lomakemallin kopion tallentaminen tiedostokirjastosta tietokoneeseen

  1. Avaa selaimessa tiedostokirjasto, jossa lomakemalli julkaistiin.
  2. Valitse Asetukset-valikostaAsetukset ja valitse sitten Lomakekirjaston asetukset.
  3. Valitse Yleiset asetukset -kohdassa Lisäasetukset.
  4. Valitse Asiakirjamalli-osassaMuokkaa mallia.
    Lomakemalli avautuu Microsoft Office InfoPathissa.
  5. Valitse Microsoft Office InfoPath -valintaikkunassa Kyllä.
  6. Napsauta Tiedosto-valikosta Tallenna nimellä.
  7. Valitse Microsoft Office InfoPath -valintaikkunassa OK.
  8. Etsi Tallenna nimellä -valintaikkunassa sijainti, johon haluat tallentaa lomakemallin kopion, ja valitse sitten Tallenna.

Lomakemallin kopion tallentaminen jaetusta verkkokansiosta tietokoneeseen

  1. Valitse Tiedosto-valikostaSuunnittele lomakemalli.
  2. Valitse Avaa lomakemalli -kohdassa Omassa tietokoneessa.
  3. Selaa julkaistun lomakemallin jaettuun verkkokansioon, napsauta lomakemallia ja valitse sitten Avaa.
  4. Napsauta Tiedosto-valikosta Tallenna nimellä.
  5. Valitse Microsoft Office InfoPath -valintaikkunassa OK.
  6. Valitse Tallenna nimellä -valintaikkunassa muu sijainti kuin alkuperäinen julkaisusijainti, johon haluat tallentaa lomakemallin työkopion, ja valitse sitten Tallenna.

Sivun alkuun

Vaihe 1: Lomakemallin julkaiseminen uudessa tiedostokirjastossa

  1. Avaa lomakemallin työkopio suunnittelutilassa.

  2. Valitse Tiedosto-valikostaJulkaise.

  3. Valitse ohjatussa julkaisutoiminnossa SharePoint-palvelimeen, jossa on tai ei ole InfoPath Forms Services -ohjelmaa, ja valitse sitten Seuraava.

  4. Kirjoita Kirjoita Kirjoita SharePoint- tai InfoPath Forms Services -sivuston sijainti -ruutuun sen SharePoint-sivuston sijainti, joka sisältää sen uuden asiakirjakirjaston, johon haluat siirtää lomakemallin, ja valitse sitten Seuraava.

  5. Valitse ohjatun toiminnon seuraavalla sivulla Tiedostokirjasto ja valitse sitten Seuraava.

  6. Valitse Luo uusi tiedostokirjasto ja valitse sitten Seuraava.

  7. Kirjoita ohjatun toiminnon seuraavalle sivulle uuden tiedostokirjaston nimi ja kuvaus ja valitse sitten Seuraava.

  8. Valitse lomakemallin kentät, joiden haluat näkyvän asiakirjakirjaston oletusnäkymän sarakkeina.
    Toimintaohjeet

    1. Valitse Lisää.

    2. Valitse kenttä, jonka haluat lisätä tiedostokirjaston sarakkeeksi, ja tee sitten jompikumpi seuraavista:

      • Kirjoita sarakkeen nimi Sarakkeen nimi - ruutuun.

      • Valitse sivustosarake Sivustosarakeryhmä-luettelosta , valitse nimi Sarakkeen nimi -luettelosta ja valitse sitten OK.

        Huomautus

        Jos valitset toistuvan kentän tiedostokirjaston tietojen näyttämiseksi, voit määrittää, miten haluat näyttää kentän tiedostokirjastossa napsauttamalla arvoa Funktio-luettelossa . Voit valita, näytetäänkö kentän ensimmäinen arvo vai viimeinen arvo, lasketaanko kentän kaikkien esiintymien määrä yhteen vai yhdistetäänkö kaikki arvot.

    3. Valitse OK.

    Lisätietoja tietojen näyttämisestä sarakkeissa tiedostokirjastossa on Katso myös -osan linkeissä.

  9. Napsauta Seuraava.

  10. Varmista ohjatun toiminnon seuraavalla sivulla, että tiedot ovat oikein, ja valitse sitten Julkaise.

  11. Jos haluat avata asiakirjakirjaston ja testata tähän lomakemalliin perustuvan lomakkeen täyttöprosessia, valitse Avaa tämä tiedostokirjasto -valintaruutu ja valitse sitten Sulje.
    Tiedostokirjasto avautuu selaimessa. Kun valitset luettelotyökaluriviltä Uusi, tähän lomakemalliin perustuva lomake avautuu Microsoft Office InfoPathissa.

Kun olet julkaissut lomakemallin uuteen tiedostokirjastoon, voit kopioida aiemmin luodut lomakkeet, jotka perustuvat lomakemallin vanhaan versioon, vanhasta tiedostokirjastosta uuteen tiedostokirjastoon. Kun olet kopioinut aiemmin luodut lomakkeet, voit linkittää aiemmin luodut lomakkeet uudelleen lomakemallin uuteen versioon. Jos et linkitä aiemmin luotuja lomakkeita, käyttäjät eivät ehkä voi avata näitä aiemmin luotuja lomakkeita.

Sivun alkuun

Tässä prosessissa oletetaan, että molemmat tiedostokirjastot ovat palvelimessa, jossa on käytössä Windows SharePoint Services 3.0.

  1. Avaa vanha tiedostokirjasto selaimessa.
  2. Valitse Näytä-valikostaResurssienhallintanäkymä.
  3. Pidä CTRL-näppäintä alhaalla, valitse siirrettävät lomakkeet ja napsauta sitten yhtä lomakkeista hiiren kakkospainikkeella.
  4. Valitse Internet Explorer -valintaikkunassa Kyllä ja valitse sitten pikavalikosta Kopioi .
  5. Avaa uusi tiedostokirjasto.
  6. Valitse Valitse näkymä -kohdassa Resurssienhallintanäkymä.
  7. Napsauta kansioikkunan tyhjää aluetta hiiren kakkospainikkeella.
  8. Valitse Internet Explorer -valintaikkunassa Kyllä ja valitse sitten pikavalikosta Liitä .
  9. Valitse Näytä-valikostaLinkitä asiakirjat uudelleen.
  10. Valitse Linkitä uudelleen -sarakkeessa valintaruutu jokaiselle lomakkeelle, jonka haluat linkittää uuteen lomakemalliin.
  11. Valitse luettelotyökaluriviltä Linkitä valitut asiakirjat uudelleen.

Kun olet linkittänyt aiemmin luodut lomakkeet uuteen lomakemalliin, käyttäjät voivat muuttaa uuteen asiakirjakirjastoon kopioimiasi aiemmin luotuja lomakkeita tai täyttää uusia lomakkeita, jotka perustuvat juuri julkaistuun lomakemalliin.

Sivun alkuun