Kirjaudu sisään Microsoft-tilillä
Kirjaudu sisään tai luo tili.
Hei
Valitse toinen tili.
Sinulla on useita tilejä
Valitse tili, jolla haluat kirjautua sisään.

Jotkin Office, mallit tai apuohjelmat voivat vahingoittaa tietokonettasi. Kun olet asentanut Microsoft Office:n huhtikuun 2021 suojauspäivityksen, jotkin Office-tiedostot, mallit tai apuohjelmat (myös Microsoftilta alun perin hankitut) saattavat näyttää ilmoitusviestin ja makrot tai apuohjelmat, jotka kyseisissä tiedostoissa poistetaan käytöstä.

Jos suljet ilmoituksen tai valitset Poista käytöstä -painikkeen, voit tarkastella tai muokata tiedostoa normaalisti, mutta apuohjelmat tai makrot eivät toimi.

Huomautus: Jos sinulla on Word - tai Excel-tiedosto, jossa on makroja, mutta et enää tarvitse näitä makroja, voit tehdä tiedostotiedoston> Tallenna nimellä ja tallentaa tiedoston tavallisena Word-tiedostona (.DOCX) tai Excel (.XLSX) -tiedostona, joka ei tue makroja.

Miten makrot tai apuohjelmat otetaan uudelleen käyttöön?

Vaihe 1 – Tarkista päivitykset

Tämä ongelma vaikuttaa pääasiassa apuversioiden vanhempiin versioihin, joten varmista ensin, että käytössäsi on Microsoft Office päivitykset. Uusia, tuettuja apuversioiden vapautumista.

Lisätietoja päivityksen päivittämisestä on Office Asentaminen Office päivityksiin.

Kun olet asentanut uusimmat päivitykset, yritä avata tiedosto uudelleen. Jos ilmoituksessa näkyy nyt Ota käyttöön -painike, kaikki on kunnossa.

Vaihe 2 – (tarvittaessa) Rekisterin päivittäminen

Jos valintaikkuna tulee edelleen näkyviin viimeisimpien päivitysten asentamisen jälkeen, sinun on lisättävä yksi tai kaksi arvoa Windows rekisteriin kullekin tuotteelle, jonka haluat ottaa uudelleen käyttöön.

Varoitus:  Rekisterin virheellinen muuttaminen saattaa aiheuttaa vakavia vaurioita järjestelmään. Ennen kuin teet muutoksia rekisteriin, varmuuskopioi kaikki tietokoneessa olevat tärkeät tiedot.

1. Avaa Rekisterieditori 

Avaa Rekisterieditori napsauttamalla Aloita, valitsemalla Suorita, kirjoittamalla regeditja napsauttamalla lopuksi OK.

2. Varmuuskopioi rekisteri

Ennen kuin teet muutoksia rekisteriin, on aina parasta tehdä varmuuskopio nykyisestä rekisteristä. Valitse > vieminen ja luo rekisteristä vientitiedosto. Aseta vientialue arvoksi Kaikki ja anna sille nimi, joka on sinulle järkevää, kuten "Rekisterin varmuuskopiointi".

Lisätietoja on seuraavassa ohjeaiheessa: Rekisterin varmuuskopiointi ja palauttaminen Windows.

3. Siirry seuraavaan avaimeen:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\<version>\<appname>\Security

Korvaa <versio> käytössäsi Office versiolla:

  • 16.0, Office 2016, 2019 tai 365

  • 15.0 , Office 2013

Korvaa <appname> nimen päivitettävän sovelluksen nimellä:

  • Word

  • Excel

  • PowerPoint

  • MS Project

  • Visio

  • Publisher

  • Outlook

  • Access

3. Lisää uusi arvo

Valitse > uusi> DWORD (32-bittinen) -arvo ja luo arvo.

Avaimen nimeäminen: SkipSignatureCheckForUnsafeVBA

Valitse Muokkaa > Muokkaa ja määritä Arvon tiedot -kohdan arvoksi 1.

4. (Wordissa ja Excel) Lisää lisäarvo

Toista vaihe 3 ja lisää toinen arvo.

  • Wordissa tämän nimi on SkipSignatureCheckForUnsafeWLL

  • Jos Excel, se on SkipSignatureCheckForUnsafeXLL

Aseta jälleen Arvon tiedot -kohdan arvoksi 1. 

5. Sulje Rekisterieditori

6. Varmista, että tiedosto on luotetussa sijainnissa

Vain luotetun sijainnin tiedostot voivat ottaa sisällön uudelleen käyttöön. Tämä kannattaa tehdä vain, jos luotat tiedoston lähteeseen.

Jos haluat tarkastella, muokata tai lisätä luotettujen sijaintien luetteloa tietokoneessasi, siirry kohtaan Tiedosto> Asetukset > Luottamuskeskus >Luottamuskeskuksen asetukset > Luotetut sijainnit.

Kun seuraavan kerran avaat tiedoston, johon VBA-makro tai apuohjelma vaikuttaa, sinun pitäisi nähdä, että ilmoituskehotteessa on Ota käyttöön -painike. Valitse tämä, jos haluat ottaa aktiivisen sisällön käyttöön ja muokata tiedostoa.

Vaihe 1 – Tarkista päivitykset

Tämä ongelma vaikuttaa pääasiassa apuversioiden vanhempiin versioihin, joten varmista ensin, että käytössäsi on Microsoft Office päivitykset. Uusia, tuettuja apuversioiden vapautumista.

Lisätietoja päivityksen päivittämisestä on Office Asentaminen Office päivityksiin.

Kun olet asentanut uusimmat päivitykset, yritä avata tiedosto uudelleen. Jos ilmoituksessa näkyy nyt Ota käyttöön -painike, kaikki on kunnossa.

Vaihe 2 – (tarvittaessa) Rekisterin päivittäminen

Kun apuohjelman uudempi versio on asennettuna, sinun on lisättävä yksi tai kaksi arvoa Windows jokaista tuotetta varten, jonka haluat ottaa uudelleen.

Varoitus:  Rekisterin virheellinen muuttaminen saattaa aiheuttaa vakavia vaurioita järjestelmään. Ennen kuin teet muutoksia rekisteriin, varmuuskopioi kaikki tietokoneessa olevat tärkeät tiedot.

1. Avaa Rekisterieditori 

Avaa Rekisterieditori napsauttamalla Aloita, valitsemalla Suorita, kirjoittamalla regeditja napsauttamalla lopuksi OK.

2. Varmuuskopioi rekisteri

Ennen kuin teet muutoksia rekisteriin, on aina parasta tehdä varmuuskopio nykyisestä rekisteristä. Valitse > vieminen ja luo rekisteristä vientitiedosto. Aseta vientialue arvoksi Kaikki ja anna sille nimi, joka on sinulle järkevää, kuten "Rekisterin varmuuskopiointi".

Lisätietoja on seuraavassa ohjeaiheessa: Rekisterin varmuuskopiointi ja palauttaminen Windows.

3. Siirry seuraavaan avaimeen:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\14.0\<appname>\Security

Korvaa <appname> nimen päivitettävän sovelluksen nimellä:

  • Word

  • Excel

  • PowerPoint

  • MS Project

  • Visio

  • Publisher

  • Outlook

  • Access

3. Lisää uusi arvo

Valitse > uusi> DWORD (32-bittinen) -arvo ja luo arvo.

Avaimen nimeäminen: SkipSignatureCheckForUnsafeVBA

Valitse Muokkaa> muokkaa ja

  • Jos haluat ottaa käyttöön päivitetyt VBA-makrot, jotka on saatu Microsoftilta, määritä Arvon tiedot -kohdan arvoksi 1.

  • Jos haluat ottaa käyttöön päivitetyt VBA-makrot kaikista lähteistä (ei suositella), aseta Arvon tiedot -kohdan arvoksi 2.

4. (Wordissa ja Excel) Lisää lisäarvo

Toista vaihe 3 ja lisää toinen arvo.

  • Wordissa tämän nimi on SkipSignatureCheckForUnsafeWLL

  • Jos Excel, se on SkipSignatureCheckForUnsafeXLL

Valitse jälleen Muokkaa> ja  

  • Jos haluat ottaa käyttöön päivitetyt apuohjelmat, jotka on saatu Microsoftilta, määritä Arvon tiedot -kohdan arvoksi 1.

  • Jos haluat ottaa päivitetyt apuohjelmat käyttöön kaikista lähteistä (ei suositella), aseta Arvo-tietojen arvoksi 2.

5. Sulje Rekisterieditori

6. Varmista, että tiedosto on luotetussa sijainnissa

Vain luotetun sijainnin tiedostot voivat ottaa sisällön uudelleen käyttöön. Tämä kannattaa tehdä vain, jos luotat tiedoston lähteeseen.

Jos haluat tarkastella, muokata tai lisätä luotettujen sijaintien luetteloa tietokoneessasi, siirry kohtaan Tiedosto> Asetukset > Luottamuskeskus >Luottamuskeskuksen asetukset > Luotetut sijainnit.

Kun seuraavan kerran avaat tiedoston, johon VBA-makro tai apuohjelma vaikuttaa, sinun pitäisi nähdä, että ilmoituskehotteessa on Ota käyttöön -painike. Valitse tämä, jos haluat ottaa aktiivisen sisällön käyttöön ja muokata tiedostoa.

Voinko estää ilmoituksen?

Kun olet päivittänyt ja tarvittaessa lisännyt rekisterimerkinnät, saat edelleen suojausilmoituksen, jossa sinua pyydetään vahvistamaan aktiivinen sisältö.  Ero on siinä, että nyt siinä on Ota käyttöön - painike.

Jos luotat niiden tiedostojen lähteeseen, jotka yrität ottaa käyttöön ja haluat estää ilmoituksen kokonaan, voit lisätä rekisteriavaimen, joka piilottaa kehotteen.

1. Avaa Rekisterieditori 

Avaa Rekisterieditori napsauttamalla Aloita, valitsemalla Suorita, kirjoittamalla regeditja napsauttamalla lopuksi OK.

Varoitus:  Rekisterin virheellinen muuttaminen saattaa aiheuttaa vakavia vaurioita järjestelmään. Ennen kuin teet muutoksia rekisteriin, varmuuskopioi kaikki tietokoneessa olevat tärkeät tiedot.

2. Varmuuskopioi rekisteri

Ennen kuin teet muutoksia rekisteriin, on aina parasta tehdä varmuuskopio nykyisestä rekisteristä. Valitse > vieminen ja luo rekisteristä vientitiedosto. Aseta vientialue arvoksi Kaikki ja anna sille nimi, joka on sinulle järkevää, kuten "Rekisterin varmuuskopiointi".

Lisätietoja on seuraavassa ohjeaiheessa: Rekisterin varmuuskopiointi ja palauttaminen Windows.

3. Siirry seuraavaan avaimeen:

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\<version>\Common\Security

Korvaa <versio> käytössäsi Office versiolla:

  • 16.0, Office 2016, 2019 tai 365

  • 15.0 , Office 2013

  • 14.0 , Office 2010

4. Lisää uusi arvo

Valitse > uusi> DWORD (32-bittinen) -arvo ja luo arvo.

Avaimen nimeäminen: AutoConsentSkipSignatureCheckForUnsafeContent

Valitse Muokkaa > Muokkaa ja määritä Arvon tiedot -kohdan arvoksi 1.

Sulje Rekisterieditori, niin sinun pitäisi olla valmiina.

Katso myös

Luotetun sijainnin lisääminen, poistaminen tai muuttaminen

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×