Kun käsittelet levittyneet matriisifunktiot, kuten JONO,on mahdollista viitata koko levittymisen alueeseen sijoittamalla levittynyt alueoperaattori (#) alueen jälkeen. Seuraavassa esimerkissä solussa A2 on =JONO(10), joka levityttää soluun A2:A11. Solussa C2 on kaava =SUMMA(A2#), joka vastaa kaavaa =SUMMA(A2:A11), koska A2:A11 on solun A2 kaavan levittumaalue. Tämä palauttaa arvon 55, joka on levittyneet matriisialueen kaikkien arvojen summa.

Jos levittyvät alueet kasvavat tai sopimuksia esimerkiksi muuttamalla solussa A2 kaava =JONO(20), SUMMA-kaava näyttää tämän automaattisesti. Jos alue on normaali, kirjoita =SUMMA(A2:A11) ja päivitä se manuaalisesti, jos levittyvät alueet muuttuvat. Usein et ehkä tiedä, onko alue muuttunut, joten tämä voi poistaa paljon arvaustyötä.

Levittynyt alue -operaattori, jonka avulla voit viitata kokonaisiin levittynyttä matriisialuetta kaavalla =SUMMA(A2#).

Tässä on toinen esimerkki levittyneiden solualueen operaattorien käyttämisestä useissa kaavoissa, joissa luodaan yksilöllinen luettelo nimiluettelosta, lajitellaan luettelo ja suodatetaan sitten yli kolmen merkin pituiset nimet. Solussa E2 on kaava =LAJITTELE(C2#) ja solussa G2 =SUODATA(C2#,PITUUS(C2#)>3).

Levittynyt alueoperaattori (#) viittaamaan koko levittynyttä matriisialuetta kaavalla =FILTER(C2#,LEN(C2#)>3)

Tunnetut rajoitukset

Levittynyt alue -operaattori ei tue viittauksia suljettuihin työkirjoihin. Sen sijaan se palauttaa #REF! -virhearvon. Ongelma ratkeaa avaamalla viitattu työkirja.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

SUODATA-funktio

SATUNN.MATRIISI-funktio

JONO-funktio

LAJITTELE-funktio

LAJITTELE.ARVOJEN.PERUSTEELLA-funktio

AINUTKERTAISET.ARVOT-funktio

#SPILL! -virheet Excelissä

Dynaamiset matriisit ja levittyneiden matriisien erityispiirteet

Implisiittisen leikkauskohdan operaattori: @

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×