Kun avaat Microsoft Dynamics NAV 4.x -tietokannan Microsoft Dynamics NAV 5.x:ssä, näyttöön tulee virhesanoma: "Sinulla ei ole [TableName]-taulukon muokkausoikeutta"

Käytetään kohteeseen
Microsoft Dynamics NAV 5.0

Tämä artikkeli koskee Microsoft Dynamics NAV 5.0:aa kaikissa maissa ja kaikilla kielialueilla.

Ongelman ilmenemistapa

Kun avaat Microsoft Dynamics NAV 4.x -tietokannan Microsoft Dynamics NAV 5.x:ssä, näyttöön tulee seuraavankaltaista virhesanomaa muistuttava virhesanoma:

Huomautus

Sinulla ei ole TableName-taulukon muokkausoikeutta.

Huomautus TableName-paikkamerkki edustaa taulukon nimeä.

Tämä ongelma ilmenee, jos seuraavat ehdot täyttyvät:

  • Perusavaimen yhdistelmäominaisuus muutetaan kyllä-arvoksi kaikissa taulukoissa.
  • Tietokanta päivitetään Microsoft Dynamics NAV 5.0:aan.

Syy

Tämä ongelma ilmenee, koska tietokanta sisältää objekteja, joihin nykyisellä käyttöoikeudella ei ole käyttöoikeuksia.

Vaihtoehtoinen menetelmä

Voit kiertää ongelman seuraavasti:

  1. Varmuuskopioi Microsoft Dynamics NAV 4.x -tietokanta.
  2. Luo uusi tietokanta Microsoft Dynamics NAV 5.x:ssä.
  3. Palauta varmuuskopio.

Ratkaisu

Tuettu hotfix-korjaus on nyt saatavilla Microsoftilta. Hotfix korjaa tässä artikkelissa kuvatun ongelman. Käytä hotfix-korjausta vain järjestelmissä, joissa on tämä ongelma.

Voit ratkaista ongelman heti ottamalla yhteyttä Microsoft Dynamicsin ja siihen liittyvien tuotteiden tekniseen tukeen saadaksesi hotfix-korjauksen. Voit kirjautua Microsoft Dynamics -sivustoon ja luoda uuden tukipyynnön. Voit tehdä tämän seuraavasta Microsoftin verkkosivustosta:

https://mbs.microsoft.com/support/newstart.aspx Voit myös ottaa yhteyttä Microsoft Dynamicsin ja siihen liittyvien tuotteiden tekniseen tukeen puhelimitse numeroon (888) 477-7877.

Huomautus Erityistapauksissa tukipuheluista tavallisesti aiheutuvat maksut voidaan peruuttaa, jos Microsoft Dynamicsin ja siihen liittyvien tuotteiden teknisen tuen asiantuntija määrittää, että tietty päivitys ratkaisee ongelmasi. Tavanomaiset tukikustannukset koskevat muita tukikysymyksiä ja -ongelmia, jotka eivät ole oikeutettuja kyseiseen päivitykseen.

Edellytykset

Tämän hotfix-korjauksen ottaminen käyttöön edellyttää Microsoft Dynamics NAV 4.0:aa.

Poistotiedot

Et voi poistaa tätä hotfix-korjausta.

Uudelleenkäynnistystarve

Tietokonetta ei tarvitse käynnistää uudelleen tämän hotfix-korjauksen jälkeen.

Microsoft Dynamics NAV -hotfix-korjauksen hankkiminen tai tiedostojen päivittäminen

Kun olet pyytänyt Microsoft Dynamics NAV -hotfix-korjausta tai päivitystiedostoa Microsoft Dynamicsin teknisestä tuesta, sinulle lähetetään sähköpostiviesti hyperlinkki.

Sähköposti sisältää hyperlinkin ja salasanan. Hyperlinkin avulla voit ladata Microsoft Dynamics NAV -hotfix-korjauksen tai päivitystiedostot. Kun napsautat hyperlinkkiä, Näyttöön avautuu Tiedostojen lataaminen – suojausvaroitus -valintaikkuna. Sinua pyydetään sitten suorittamaan, tallentamaan tai peruuttamaan lataus.

Jos valitset Suorita, tiedostot aloittavat latauksen ja purkuprosessin. Sinun on määritettävä kansio uusille tiedostoille ja annettava sitten salasana.

Jos valitset Tallenna, sinun on määritettävä polku pakatun tiedoston tallentamista varten. Kun avaat tallentamasi tiedoston, sinua pyydetään määrittämään tiedostoille polku. Tämän jälkeen sinun on annettava sähköpostiviestissä annettu salasana.

Jos valitset Peruuta, latausprosessi pysähtyy.

Microsoft Dynamics NAV -hotfix-korjauksen tai päivitystiedoston asentaminen

  Microsoft Dynamics NAV -ympäristön hotfix-korjaukset ja päivitykset ovat käytettävissä yksittäisinä tiedostoina. Jos haluat asentaa Microsoft Dynamics NAV -hotfix-korjauksen tai päivityksen, sinun on korvattava olemassa olevat Microsoft Dynamics NAV -asennustiedostot hotfix-korjauksella tai päivitystiedostoilla. Voit tehdä tämän seuraavasti.

  Jos sinulla on Microsoft Dynamics NAV -sovelluspalvelin asennettuna, sinun on korvattava seuraavat tiedostot Microsoft Dynamics NAV -sovelluspalvelimen asennuksessa.

Tiedoston nimi Tiedostoversio Tiedoston koko Päivämäärä Aika Käyttöympäristö
Fin.exe 5.0.24632.0 10,737,104 23. toukokuuta 2007 01:30 x86
Finsql.exe 5.0.24632.0 10,794,448 23. toukokuuta 2007 01:30 x86

Voit korvata tiedostot seuraavasti:

  1. Lopeta kaikki Microsoft Dynamics NAV -toiminta.
  2. Etsi Microsoft Dynamics NAV Open Database Connectivity (ODBC) -ohjaimen asennushakemisto. Microsoft Dynamics NAV ODBC -ohjain asennetaan yleensä seuraavaan hakemistoon:
    C:\Program Files\Common Files\Navision\NODBC\
  3. Kopioi lataamasi tiedostot.
  4. Liitä lataamasi tiedostot Microsoft Dynamics NAV ODBC -ohjainten asennushakemistoon.
  5. Korvaa hakemiston tiedostot valitsemalla Kyllä .

Tila

Microsoft on vahvistanut, että tämä on virhe Microsoft-tuotteissa, jotka on lueteltu "Koskee seuraavia" -osiossa.

Lisätietoja

Saat lisätietoja napsauttamalla seuraavaa artikkelin numeroa, jotta voit tarkastella artikkelia Microsoft Knowledge Base -tietokanta -tietokannassa:

824684 Microsoftin kuvaamiseen käytettävän vakioterminologian kuvaus