Oireet

Jos yrität viedä tai tuoda postilaatikon käyttämällä New-MailboxExportRequest tai New-MailboxImportRequest Exchange Server 2010 Service Pack 1:ssä tai uudemmassa versiossa, pyyntö saattaa aikakatkoa, ja näyttöön voi tulla seuraava virhesanoma:

[PS] New-MailboxExportRequest -Postilaatikko "<mailbox_name>" -FilePath \\<server_name>\<share>\<file_name>.pst

Puhelu osoitteeseen "net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService <server_name> (14.1.218.11 caps:07)" aikakatkattiin. Virhetiedot: Tämä pyyntötoiminto, joka lähetettiin osoitteeseen net.tcp://<server_name>/Microsoft.Exchange.MailboxReplicationService, ei saanut vastausta määritetyssä aikakatkaisussa (00:01:00). Tälle toiminnolle varattu aika on saattanut olla osa pidempää aikakatkoa. Tämä voi johtua siitä, että palvelu käsittelee edelleen toimintoa tai koska palvelu ei pystynyt lähettämään vastausviestiä. Harkitse toiminnon aikakatkaisun lisäämistä (määrittämällä kanava/välityspalvelin IContextChanneliin ja määrittämällä OperationTimeout-ominaisuus) ja varmista, että palvelu voi muodostaa yhteyden asiakkaaseen. + CategoryInfo : NotSpecified: (0:Int32) [New-MailboxExportRequest], TimeoutErrorTransientException + FullyQualifiedErrorId : 59EDFA88,Microsoft.Exchange.Management.RecipientTasks.NewMailboxExportRequest

Syy

Tämä ongelma voi ilmetä, jos asiakaskäyttötaulukko on määritetty ja kuormituksen tasapainotus on käytössä. Kun Exchange-palvelin yrittää kirjautua postilaatikkoon, jonka tuontia tai vientiä pyydettiin, palvelin muodostaa yhteyden tietokannan MoMT-päätepisteeseen (RPC-asiakaskäyttöpalvelin), joka on useimmissa tapauksissa CAS-matriisin nimi. Jos kuormituksen tasapainotus on määritetty virheellisesti ottamaan käyttöön yhteydet Exchange-palvelimista VIP-palvelimeen, johon CAS-matriisi ratkaisee, tämä johtaa kuormituksen tasapainottajan antamiin oletusasetusten palauttamiseen, mikä aiheuttaa "Oireet"-kohdassa luetellut aikakatkaisuvirheet.

Ratkaisu

Varmista, että Exchange-palvelimet voivat muodostaa yhteyden kuormituksen tasapainottajaan asiakkaina.Lisäksi on dokumentoitu seuraavat vaihtoehtoiset menetelmät, joiden avulla siirtopyyntö voidaan lähettää. Nämä vaihtoehtoiset menetelmät voidaan ottaa käyttöön, jos asiakasyhteyttä Exchange-palvelimista kuormituksen tasapainottajaan ei ole otettu käyttöön tai se ei ole mahdollista.

  • Voit muuttaa tuotavan tai vietävän postilaatikon sisältävän tietokannan RPCClientAccessServer-arvon osoittamaan tiettyyn CAS-palvelimeen sen sijaan, että osoittaisit kuormituksen tasaajaa käyttävään CAS-matriisiin. Tämä on dynaaminen asetus, jota voi muuttaa tarpeen mukaan.

  • Voit käyttää -MRSServer-valitsinta New-MailboxExportRequest tai New-MailboxImportRequest cmdlet-komennossa ja määrittää CAS-palvelimen, joka ei kuulu CAS-matriisiin.

  • Voit lisätä Hosts-tiedostoon merkinnän yhdessä tai useammassa CAS-palvelimessa, joka ratkaisee CAS-matriisin nimen localhostiin.

Lisätietoja

Kun postilaatikon tuonti- tai vientipyyntö lähetetään, prosessissa on useita vaiheita. Kaiken kaikkiaan se on hyvin samankaltainen kuin Siirtopyyntö-prosessi. Perusprosessi sisältää seuraavat vaiheet:

  1. Exchange-palvelin, johon Etä-Powershell-istunto on yhdistetty, luo vienti- ja tuontipyynnön. Osana luontivaiheessa suoritettavaa vahvistusta Tämä Exchange-palvelin muodostaa yhteyden MoMT-päätepisteeseen ja yrittää kirjautua (MAPI.Net kautta) postilaatikkoon, johon yrität viedä tai tuoda. Jos vahvistus onnistuu, vietävän tai tuotavan postilaatikon sisältävän tietokannan Järjestelmän postilaatikkoon lisätään erityinen FAI-viesti. Pyyntö siirtyy Jonossa-tilaan.Huomautus Tämä on vaihe, joka epäonnistuu edellä kuvatulla virheellä, joten pyyntöä ei koskaan luoda eikä koskaan sijoita Järjestelmän postilaatikkoon.

  2. Kaikki saman Active Directory -sivuston MRS-esiintymät tarkistavat kyseisen postilaatikon säännöllisesti. Jos komennossa ei ole määritetty MRSServer-komentoa, se valitaan satunnaisesti. Jos komennossa on määritetty tietty MRSServer, käytetään kyseistä MRS-esiintymää.

  3. MRS aloittaa viennin (tai tuonnin) ja muuttaa pyynnön tilaksi Valmis, kun se on valmis.

  4. Järjestelmänvalvoja voi halutessaan poistaa vienti- tai tuontipyynnön.

Lisätietoja tuonti- ja vientipyynnöistä on seuraavassa TechNet-artikkelissa:

http://technet.microsoft.com/en-us/library/ee633455.aspx

Tarvitsetko lisäohjeita?

Haluatko lisää vaihtoehtoja?

Tutustu tilausetuihin, selaa harjoituskursseja, opi suojaamaan laitteesi ja paljon muuta.