Applies ToWindows 7

Windows 7:n tuki päättyi 14. tammikuuta 2020.

Suosittelemme, että siirryt Windows 11 -tietokoneeseen, jotta saat jatkossakin suojauspäivityksiä Microsoftilta.

Lisätietoja

Microsoft Security Essentials toimii automaattisesti Microsoft Updaten kanssa ja varmistaa, että virus- ja vakoiluohjelmamäärityksesi ovat ajan tasalla.

Ongelman ilmenemistapa 

Seuraavassa on joitakin yleisiä automaattisiin päivityksiin liittyviä ongelmia:

  • Näyttöön tulee virhesanomia, jotka ilmoittavat päivitysten epäonnistuneen.

  • Kun etsit päivityksiä, näyttöön tulee virhesanoma, joka ilmoittaa, ettei virus- ja vakoiluohjelmamäärityksiä voi tarkistaa, ladata tai asentaa.

  • Päivitykset epäonnistuvat, vaikka Internet-yhteys on muodostettu.

  • Päivitykset eivät asennu automaattisesti aikataulun mukaisesti.

Syy 

Yleisin syy päivitysongelmiin on ongelma Internet-yhteydessä. Jos olet online-tilassa, ongelma saattaa johtua ristiriidoista Windows Internet Explorerin asetuksissa.  

Ratkaisu 

Huomautus: Sinun täytyy sulkea Internet Explorer, jotta voit tehdä nämä toimet. Tulosta nämä ohjeet, kirjoita ne muistiin tai kopioi ne toiseen tiedostoon ja merkitse sitten tämä ohjeaihe kirjanmerkillä, jotta löydät sen myöhemmin helposti uudelleen.

Vaihe 1: Palauta Internet Explorerin oletusasetukset

  1. Sulje kaikki avoimet ohjelmat Internet Explorer mukaan lukien.

    Huomautus: Internet Explorerin asetusten palauttaminen poistaa tilapäiset tiedostot, evästeet, selaushistoria ja verkkosalasanasi. Se ei kuitenkaan poista suosikkejasi.

  2. Napsauta Käynnistä-painiketta, kirjoita Aloita haku -ruutuun inetcpl.cpl ja paina sitten Enter-näppäintä.

  3. Valitse Internet-asetukset-valintaikkunan Lisäasetukset-välilehti.

  4. Valitse Internet Explorerin asetusten palauttaminen -kohdassa Palauta ja valitse sitten uudelleen Palauta.

  5. Odota, että Internet Explorer saa asetusten palautuksen valmiiksi, ja valitse sitten OK.

  6. Avaa Internet Explorer.

  7. Avaa Microsoft Security Essentials, valitse Päivitys-välilehti ja valitse sitten Päivitä. Jos ongelma ei poistu, jatka seuraavaan vaiheeseen.

Vaihe 2. Aseta Internet Explorer oletusselaimeksi

  1. Sulje kaikki avoimet ohjelmat Internet Explorer mukaan lukien.

  2. Napsauta Käynnistä-painiketta, kirjoita Aloita haku -ruutuun inetcpl.cpl ja paina sitten Enter-näppäintä.

  3. Valitse Internet-asetukset-valintaikkunan Ohjelmat-välilehti.

  4. Valitse Oletusselain-kohdassa Aseta oletukseksi. Valitse OK.

  5. Avaa Microsoft Security Essentials. Valitse Päivitä-välilehti ja valitse sitten Päivitä. Jos ongelma ei poistu, jatka seuraavaan vaiheeseen.

Vaihe 3: Varmista, että tietokoneen päivämäärä ja kellonaika on asetettu oikein

  1. Avaa Microsoft Security Essentials.

  2. Jos näyttöön tuleva virhesanoma sisältää koodin 0x80072f8f, ongelma johtuu todennäköisesti virheellisestä tietokoneen päivämäärä- tai kellonaika-asetuksesta.

  3. Voit palauttaa tietokoneen päivämäärä- tai kellonaika-asetuksen noudattamalla artikkelin Viallisia työpöydän pikanäppäimiä ja yleisiä järjestelmän ylläpitotehtäviä ohjeita.

Vaihe 4: Nimeä tietokoneen Software Distribution -kansio uudelleen

  1. Pysäytä Automaattiset päivitykset -palvelu.

    1. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita services.msc ja valitse sitten OK.

    2. Napsauta hiiren kakkospainikkeella Automaattiset päivitykset -palvelua ja valitse Pysäytä.

    3. Pienennä Palvelut-laajennus.

  2. Jos näyttöön tuleva virhesanoma sisältää koodin 0x80072f8f, ongelma johtuu todennäköisesti virheellisestä tietokoneen päivämäärä- tai kellonaika-asetuksesta.

  3. Nimeä SoftwareDistribution-hakemisto uudelleen seuraavasti:

    1. Napsauta Käynnistä-painiketta, valitse Suorita, kirjoita cmd ja valitse sitten OK.

    2. Kirjoita cd %windir% ja paina sitten Enter-näppäintä.

    3. Kirjoita ren SoftwareDistribution SDTemp ja paina sitten Enter-näppäintä.

    4. Kirjoita Exit ja paina sitten Enter.

  4. Käynnistä Automaattiset päivitykset -palvelu seuraavasti:

    1. Suurenna Palvelut-laajennus.

    2. Napsauta hiiren kakkospainikkeella Automaattiset päivitykset -palvelua ja valitse Käynnistä.

    3. Sulje Palvelut-laajennuksen ikkuna.

Vaihe 5: Palauta tietokoneen Microsoft-virustentorjunnan päivitysohjelman oletusasetukset

  1. Napsauta Käynnistä-painiketta, valitse Kaikki ohjelmat ja Apuohjelmat, napsauta hiiren kakkospainikkeella Komentokehote-vaihtoehtoa ja valitse sitten Suorita järjestelmänvalvojana.

  2. Kirjoita Komentokehote-ikkunaan seuraavat komennot ja paina jokaisen komennon jälkeen Enter-näppäintä:

    • CD\

    • Cd program files\microsoft security essentials

    • Mpcmdrun –removedefinitions –all

    • Lopeta

  3. Käynnistä tietokone uudelleen.

  4. Avaa Microsoft Security Essentials, valitse Päivitys-välilehti ja valitse sitten Päivitä. Jos ongelma ei poistu, jatka seuraavaan vaiheeseen.

Vaihe 6: Asenna virus- ja vakoiluohjelmamääritysten päivitykset manuaalisesti

Napsauta Suorita. Uusimmat päivitykset asentuvat tietokoneeseen.

Vaihe 7: Ota yhteyttä tukeen

Jos näissä ohjeissa kuvatut toimet eivät ratkaisseet ongelmaa, ota yhteyttä tukeen. Lisätietoja on kohdassa Asiakastuki.

Tarvitsetko lisäohjeita?

Haluatko lisää vaihtoehtoja?

Tutustu tilausetuihin, selaa harjoituskursseja, opi suojaamaan laitteesi ja paljon muuta.

Osallistumalla yhteisöihin voit kysyä kysymyksiä ja vastata niihin, antaa palautetta sekä kuulla lisää asiantuntijoilta, joilla on runsaasti tietoa.

Etsi ratkaisuja yleisiin ongelmiin tai hanki apua tukihenkilöltä.