Comment faire pour créer une lettre type à l'aide du publipostage dans Word 2000

Pour vous procurer une version Microsoft Word 2002 de cet article, reportez-vous à l'article 294683 .
Pour vous procurer une version Microsoft Word 97 de cet article, reportez-vous à l'article 141922 .

Résumé

Cet article décrit étape par étape la procédure de publipostage et explique comment effectuer un publipostage de base pour créer une lettre type dans Microsoft Word.


Pour plus d'informations sur les autres types de publipostage, la fusion avec d'autres types de données et la résolution des problèmes, reportez-vous à la liste d'articles répertoriés dans la section Articles connexes de cet article.

Pour une description des termes utilisés dans cet article, reportez-vous à la section Glossaire de cet article.

Qu'est-ce que le publipostage ?

Le publipostage est une fonctionnalité de Word qui vous permet de fusionner des informations réutilisables (telles qu'une lettre type) avec des informations variables (telles qu'une base de données de noms et d'adresses de clients). Cela vous permet de créer des documents pratiquement identiques : la substance est identique pour chaque client, mais chaque document est personnalisé pour le destinataire spécifique figurant dans votre base de données.

Le publipostage comprend trois composants principaux :
  • le document principal qui contient les informations réutilisables : texte et graphismes. Ce document principal détermine également la mise en forme du document fusionné qui en résulte, par exemple une lettre type, des enveloppes ou des étiquettes ;
  • la source de données contenant les informations variables : par exemple, une liste de noms et d'adresses ;
  • le document fusionné, qui comprend la combinaison de texte réutilisable et d'informations variables.
Le document principal comprend le texte et les graphismes réutilisables que vous souhaitez utiliser dans chaque version du document fusionné. Dans le document principal, vous insérez des instructions spéciales, nommées champs de fusion, pour indiquer où les informations variables doivent apparaître. Lorsque vous fusionnez les informations de la source de données avec le document principal, les informations variables remplacent les champs de fusion par des informations individuelles. Le résultat est le document fusionné, qui contient à la fois le texte réutilisable et les informations variables.


La source de données contient les informations (telles que des noms, adresses et numéros de téléphone) qui diffèrent dans chaque version du document. Vous pouvez la plupart du temps stocker vos données dans un document Word ; toutefois, Word reconnaît également d'autres formats. Par exemple, la source de données peut être une feuille de calcul Microsoft Excel, une base de données Microsoft Access ou un fichier au format .csv (séparé par des virgules).


La source de données contient une ligne d'en-tête (également nommée enregistrement d'en-tête) ainsi que des enregistrements de données. La ligne d'en-tête est le premier élément de la source de données. Elle contient les noms des champs qui identifient les informations variables. Les enregistrements de données contiennent les informations individuelles. Chaque enregistrement de données comprend un ou plusieurs champs, selon la quantité d'informations dont vous disposez pour chaque personne. Ce jeu d'informations constitue un enregistrement de données.

Le processus de publipostage se décompose en quatre étapes principales :
  1. ouverture ou création du document principal ;
  2. ouverture ou création de la source de données ;
  3. modification du document principal ;
  4. lancement du publipostage.
La procédure suivante montre comment créer une lettre type, la lier à une source de données, la mettre en forme et comment fusionner les documents. La procédure pour créer des enveloppes ou des étiquettes fusionnées est similaire. Pour plus d'informations, reportez-vous à l'article correspondant répertorié dans la section « Articles connexes » de cet article.

Étape 1 : Ouverture ou création du document principal

  1. Si vous possédez déjà un document contenant le texte réutilisable souhaité, ouvrez-le. Ou bien, si vous souhaitez créer une nouvelle lettre type et qu'aucun document vierge n'est affiché à l'écran, cliquez sur Nouveau dans la barre d'outils Standard.
  2. Dans le menu Outils, cliquez sur Fusion et publipostage.
  3. Dans la zone Document principal de la boîte de dialogue Aide au publipostage, cliquez sur Créer.
  4. Cliquez sur Lettres types.

    Word vous demande si vous souhaitez utiliser la fenêtre active pour le document principal ou créer un nouveau document principal. Cliquez sur Fenêtre active. Le document en cours devient votre document principal de publipostage.


    Word vous renvoie à la boîte de dialogue Aide au publipostage.
  5. Passez à l'Étape 2 : Ouverture ou création de la source de données.

Étape 2 : Ouverture ou création de la source de données

Lorsque vous ouvrez ou créez une source de données à l'aide de la fonctionnalité Aide au publipostage, vous indiquez à Word l'ensemble d'informations variables spécifiques à utiliser pour effectuer la fusion. Appliquez l'une des méthodes suivantes pour lier le document principal à la source de données.

Méthode 1 : Si vous saisissez des noms et des adresses pour la première fois

Pour créer une base de données, procédez comme suit :
  1. Dans la zone Source de données de la boîte de dialogue Aide au publipostage, cliquez sur Obtenir les données.
  2. Cliquez sur Créer une source de données.

    La boîte de dialogue Créer une source de données s'affiche. Cette boîte de dialogue vous permet de spécifier les noms des champs à inclure dans la source de données. La zone Champs de la ligne d'en-tête répertorie les noms de champs utilisés le plus fréquemment dans les lettres types, les étiquettes de publipostage et les enveloppes. Vous pouvez supprimer les champs dont vous n'avez pas besoin en les sélectionnant un par un et en cliquant sur Supprimer un champ. Si vous souhaitez créer de nouveaux champs, tapez le nom du champ dans la zone Nom du champ, puis cliquez sur Ajouter un champ.

    Lorsque vous avez fini de créer de nouveaux champs et de supprimer les champs dont vous n'avez pas besoin, cliquez sur OK.
  3. La boîte de dialogue Enregistrer sous apparaît. Dans la zone Nom du fichier, donnez un nom à votre source de données, puis cliquez sur Enregistrer.
  4. Lorsque Word vous demande si vous souhaitez modifier la source de données ou configurer le document principal, cliquez sur Modifier la source de données.
  5. Lorsque la boîte de dialogue Saisie de données de fusion s'affiche, tapez les informations souhaitées dans le formulaire. S'il n'y a pas d'informations pour un champ particulier, laissez la zone vide. Par défaut, Word ignore les champs vides, et le publipostage ne sera donc pas affecté par la présence d'entrées vides dans le formulaire de données. Les informations contenues dans chaque formulaire constituent un enregistrement de données.
  6. Après avoir saisi les informations correspondant à un enregistrement, cliquez sur Ajouter pour passer à l'enregistrement suivant.
  7. Après avoir ajouté toutes vos données, cliquez sur OK pour retourner au document principal.

    Remarquez la barre d'outils Fusion et publipostage.
  8. Enregistrez le document principal.

    Lorsque vous enregistrez le document principal à ce stade, vous enregistrez également la source de données et sa liaison au document principal.
  9. Passez à l'Étape 3 : Modification du document principal.

Méthode 2 : Si vous utilisez une source de données existante

Pour utiliser une source de données existante, procédez comme suit :
  1. Dans la boîte de dialogue Aide au publipostage, cliquez sur Obtenir les données.
  2. Cliquez sur Ouvrir la source de données.
  3. Dans la boîte de dialogue Ouvrir la source de données, sélectionnez le fichier qui contient les informations variables à utiliser, puis cliquez sur Ouvrir.

    REMARQUE : si la source de données n'est pas disponible dans la liste des fichiers qui apparaît à l'écran, sélectionnez le lecteur et le dossier appropriés. Si nécessaire, sélectionnez l'option appropriée dans la zone Type de fichier. Sélectionnez le fichier, puis cliquez sur Ouvrir.

    Word affiche le message suivant :
    Word n'a trouvé aucun champ de fusion dans le document principal. Choisissez « Modifier document principal » pour insérer des champs de fusion dans le document principal.
  4. Cliquez sur Modifier le document principal pour revenir au document principal.

    Remarquez la barre d'outils Fusion et publipostage.
  5. Enregistrez le document principal. Lorsque vous enregistrez le document principal à ce stade, vous enregistrez également la source de données et sa liaison au document principal.
  6. Passez à l'Étape 3 : Modification du document principal.

Étape 3 : Modification du document principal

À l'étape 1, vous choisissez soit d'ouvrir un document existant, soit d'en créer un nouveau. Appliquez l'une des méthodes suivantes selon le choix effectué à l'étape 1.

Méthode 1 : Si vous utilisez un document existant

  1. Cliquez sur l'emplacement auquel vous souhaitez insérer les informations de votre source de données.
  2. Dans la barre d'outils Fusion et publipostage, cliquez sur Insérer un champ de fusion, puis sur le champ de fusion à utiliser.

    REMARQUE : veillez à taper les espaces ou la ponctuation souhaités entre deux champs de fusion ou après un champ de fusion. Vous pouvez également mettre en forme les champs de fusion (en appliquant une mise en forme en gras ou en italique), comme vous le feriez pour du texte normal.
  3. Répétez les étapes 1 et 2 pour chaque champ de fusion que vous souhaitez ajouter à votre document.
  4. Une fois le document principal modifié, cliquez sur Enregistrer ou Enregistrer sous dans le menu Fichier. Nommez le fichier, puis cliquez sur Enregistrer.
  5. Passez à l'Étape 4 : Lancement du publipostage.

Méthode 2 : Si vous utilisez un nouveau document principal

  1. Tapez ou ajoutez les textes et images que vous souhaitez inclure dans votre lettre.
  2. À chaque emplacement auquel vous souhaitez insérer des informations de la source de données, cliquez sur Insérer un champ de fusion dans la barre d'outils Fusion et publipostage, puis cliquez sur le champ de fusion à utiliser.


    REMARQUE : veillez à taper les espaces ou la ponctuation souhaités entre deux champs de fusion ou après un champ de fusion. Vous pouvez également mettre en forme les champs de fusion (en appliquant une mise en forme en gras ou en italique), comme vous le feriez pour du texte normal.
  3. Une fois le document principal modifié, cliquez sur Enregistrer ou Enregistrer sous dans le menu Fichier. Nommez le fichier, puis cliquez sur Enregistrer.
  4. Passez à l'Étape 4 : Lancement du publipostage.

Étape 4 : Lancement du publipostage

  1. Dans le menu Outils, cliquez sur Fusion et publipostage.
  2. Sous Fusionner les données avec le document, cliquez sur Fusionner.
  3. Dans la boîte de dialogue Fusionner, cliquez sur Fusionner vers, puis sélectionnez Nouveau document pour afficher le document fusionné à l'écran. Pour imprimer le document fusionné, cliquez sur Imprimer dans le menu Fichier.

    REMARQUE : dans la zone Fusionner vers, sélectionnez Imprimante si vous souhaitez envoyer le document fusionné à l'imprimante sans l'afficher au préalable sur votre écran.
  4. Cliquez sur Fusionner.

Glossaire

Informations réutilisables Informations génériques répétées dans chaque lettre type, étiquette de publipostage, enveloppe ou catalogue.

Champ de données Catégorie d'informations dans une source de données. Un champ de données correspond à une colonne d'informations dans la source de données. Le nom de chaque champ de données figure sur la première ligne (ligne d'en-tête) de la source de données. « Code_Postal » et « Nom » sont des exemples de noms de champs de données.

Enregistrement de données Jeu complet d'informations dans une source de données. Un enregistrement de données correspond à une ligne d'informations dans la source de données. L'ensemble des informations relatives à un client dans une liste de publipostage client est un exemple d'enregistrement de données.

Source de données Une source de données est un fichier contenant les données qui varient dans chaque copie d'un document fusionné. Par exemple, une source de données peut inclure le nom et l'adresse de chaque destinataire d'une lettre type.

Délimité Fichier texte dont les champs de données sont séparés (délimités) par des tabulations ou des virgules, et les enregistrements de données par des marques de paragraphe.

Ligne d'en-tête Première ligne (ou premier enregistrement) dans une source de données de publipostage. La ligne d'en-tête contient les noms des champs correspondant aux catégories d'informations de la source de données ; par exemple, « Nom » et « Ville ». Cette ligne peut également être stockée dans un document distinct nommé source d'en-tête.

Document principal Dans une opération de publipostage, document contenant le texte et les images qui restent identiques pour chaque version du document fusionné ; par exemple, l'adresse de l'expéditeur et le corps d'une lettre type.

Champ de fusion Il s'agit d'un espace réservé que vous insérez dans le document principal. Les champs de fusion indiquent à Microsoft Word où insérer les informations spécifiques issues de la source de données. Par exemple, insérez le champ de fusion « Ville » pour que Word insère un nom de ville (par exemple « Paris ») stocké dans le champ de données Ville.

Document fusionné Document créé par la fusion des données de la source de données dans le document principal.

Références

Autres ressources (en anglais)

Ressources de support pour le publipostage Word :

Pour plus d'informations sur la fusion et le publipostage, cliquez sur Aide sur Microsoft Word dans le menu ? (Aide), tapez publipostage dans le Compagnon Office ou l'Aide intuitive, puis cliquez sur Rechercher pour consulter les rubriques correspondantes.

Articles connexes

Pour plus d'informations sur le publipostage, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
212322 COMMENT FAIRE : Concevoir et préparer une fusion et un publipostage de données dans Microsoft Word 2000

212017 COMMENT FAIRE : Créer des enveloppes à l'aide de la fonctionnalité Fusion et publipostage dans Word 2000

212034 COMMENT FAIRE : Créer des étiquettes de publipostage à l'aide de la fonctionnalité de publipostage dans Word 2000

212029 COMMENT FAIRE : Créer une étiquette personnalisée ou modifier une étiquette existante dans Word 2000

212012 WD2000 : Comment faire pour forcer le démarrage du texte sur la même ligne dans des lettres fusionnées
211363 WD : Comment spécifier plusieurs conditions avec un champ IF imbriqué dans Word
212314 COMMENT FAIRE : Utiliser une source de données Excel pour le publipostage dans Word 2000

214183 COMMENT FAIRE : Utiliser le publipostage avec une requête de paramètre Access dans Word 2000

211190 COMMENT FAIRE : Utiliser des données de Microsoft Access 2000 dans Word 2000

211206 COMMENT FAIRE : Utiliser le carnet d'adresses d'Outlook Express dans un publipostage dans Word

212379 WD2000 : Comment faire pour convertir des fichiers de données et carnets d'adresses WordPerfect 6.x

212334 WD2000 : Comment faire pour convertir des données en une colonne ou une table
211702 WD2000 : Comment faire pour convertir des données de fusion WordPerfect
214827 WD : Comment faire pour utiliser des champs IF imbriqués dans un document de publipostage
264722 WD2000 : Comment faire pour supprimer des lignes vierges lors d'un publipostage
211303 Comment faire pour créer une liste triée par catégorie à l'aide de la fonctionnalité Fusion et publipostage dans Word 2000
211293 COMMENT FAIRE : Modifier la mise en forme de l'adresse du destinataire ou de l'expéditeur dans Word 2000

212078 COMMENT FAIRE : Insérer une image ou un logo sur chaque étiquette dans Word 2000

212358 WD2000 : Échec de la liaison ou de la fusion de la source de données de fusion
212263 WD2000 : Message d'erreur : Impossible d'ouvrir <nom+fichier.doc> comme source de données ou d'en-têtes car il s'agit du document principal de fusion de fichiers actif
212125 WD2000 : Message d'erreur : 'Erreur ! Source du renvoi introuvable' avec un champ Remplir ou Demander vierge
211729 WD2000 : Message d'erreur : « Impossible de fusionner le document principal avec la source de données : les enregistrements étaient tous vides ou aucun enregistrement ne correspondait à vos options de requête. »

242339 WD2000 : Faute d'orthographe non indiquée lors de la vérification de l'orthographe d'un document fusionné

211437 WD2000 : Le document principal et de données de publipostage ne sont pas enregistrés en arrière-plan
240854 WD2000 : Limites de la conversion de documents WordPerfect 5.x
211727 WD2000 : Restauration du document principal de fusion vers un document Word normal

189196 WD2000 : Message d'erreur : « <nom_fichier_document_principal> est un document princpal de fusion » lors de l'utilisation d'Outlook 97 ou de Schedule+

212354 WD2000 : La mise en forme des caractères d'une source de données n'est pas conservée après la fusion

212068 WD2000 : La fonctionnalité Modifier la casse n'applique pas la mise en forme aux champs de fusion
220250 WD2000 : Message d'erreur : « Les champs sont trop imbriqués » dans Fusion et publipostage
211322 WD2000 : Impossible de modifier les noms de champs par défaut dans l'Aide au publipostage
214157 WD2000 : Impossible de remplacer toutes les occurrences de champs MERGEFIELD non valides

211651 WD2000 : Un espace vide apparaît si le champ est vierge dans un publipostage
264892 WD2000 : La ligne vide n'est pas supprimée dans un publipostage conditionnel
270623 OLEXP : Comment faire pour utiliser le Carnet d'adresses d'Outlook Express dans une opération de fusion et publipostage

192258 Comment faire pour effectuer une procédure de fusion et de publipostage avec des contacts dans Outlook 2000

Propriétés

ID d'article : 212329 - Dernière mise à jour : 19 oct. 2006 - Révision : 1

Commentaires