Présentation des états dans Access

S’applique à
Access pour Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Les états offrent un moyen d’afficher, de mettre en forme et de synthétiser les informations de votre base de données Microsoft Access. Vous pouvez par exemple créer un simple état de numéros de téléphone de tous vos contacts ou un état récapitulatif du total des ventes dans différentes régions à des périodes différentes.

Cet article vous permet d’obtenir une vue d’ensemble des états dans Access. Vous apprendrez également les principes de base de la création d’un rapport, de l’utilisation d’options telles que le tri, le regroupement et la synthèse des données, ainsi que la manière d’afficher un aperçu et d’imprimer le rapport.

Vue d’ensemble des états dans Access

Que pouvez-vous faire avec un état ?

Un état est un objet de base de données qui s’avère utile quand vous voulez présenter les informations dans votre base de données dans l’un des cas suivants :

  • Afficher ou distribuer une synthèse des données.
  • Archiver des instantanés des données.
  • Fournir des détails relatifs à des enregistrements individuels.
  • Créer des étiquettes.

Sections d’un état

Bien que vous puissiez créer des rapports « non liés » qui n’affichent pas de données, cet article part du principe qu’un rapport est lié à une source de données telle qu’une table ou une requête. La structure d’un état est divisée en sections que vous pouvez afficher en mode Création. Comprendre le fonctionnement de chaque section peut vous aider à créer de meilleurs rapports. Par exemple, la section dans laquelle vous choisissez de placer un contrôle calculé détermine la façon dont les résultats sont calculés dans Access. La liste suivante résume les types de section et leurs utilisations :

Section Comment s’affiche la section à l’impression Où la section peut être utilisée
En-tête d’état Dans la partie supérieure de l’état. En règle générale, l’en-tête d’un état regroupe les informations habituelles d’une page de garde, telles que logo, titre ou date. Lorsque vous placez un contrôle calculé qui utilise la fonction de regroupement Somme dans l’en-tête d’état, la somme est calculée pour l’état entier. L’en-tête d’état est imprimé avant l’en-tête de page.
En-tête de page En haut de chaque page. Un en-tête de page est utile, par exemple, pour répéter le titre de l’état dans chaque page.
En-tête de groupe Au début de chaque nouveau groupe d’enregistrements. Vous pouvez utiliser l’en-tête de groupe pour imprimer le nom du groupe. Par exemple, dans un état regroupé par produit, utilisez l’en-tête de groupe pour imprimer le nom du produit. Lorsque vous placez un contrôle calculé qui utilise la fonction d’agrégation Somme dans l’en-tête de groupe, la somme est calculée pour le groupe actuel. Selon le nombre de niveaux de regroupement que vous ajoutez, vous pouvez avoir plusieurs sections d’en-tête de groupe sur un rapport. Pour plus d’informations sur la création d’en-têtes et de pieds de groupe, reportez-vous à la section Appliquer un regroupement, un tri ou ajouter des totaux.
Détail Apparaît une fois pour chaque ligne de la source d’enregistrement. C’est l’endroit où vous placez les contrôles qui constituent le corps principal de l’état.
Pied de groupe À la fin de chaque groupe d’enregistrements. Vous pouvez utiliser un pied de groupe pour imprimer des informations de synthèse sur un groupe. Un rapport peut comporter plusieurs sections de pied de groupe en fonction du nombre de niveaux de regroupement que vous ajoutez.
Pied de page À la fin de chaque page. Vous pouvez utiliser un pied de page pour imprimer les numéros de page ou des informations spécifiques pour chaque page.
Pied d’état Au bas de l’état.
Remarque : En mode Création, le pied d’état apparaît sous le pied de page. Toutefois, dans tous les autres modes (le mode Page, par exemple, ou lorsque l’état est en cours d’impression ou en mode Aperçu avant impression), le pied d’état se trouve au-dessus du pied de page, juste après le dernier pied de groupe ou la ligne de détail de la dernière page.
Vous pouvez utiliser le pied d’état pour imprimer les totaux de l’état ou d’autres informations de synthèse pour l’ensemble de l’état.

Vous constatez qu’il est beaucoup plus facile de créer des rapports significatifs lorsque votre base de données comporte une structure de tables et des relations bien conçues. Pour obtenir des informations sur la planification et la conception d’une base de données, voir l’article Concepts de base sur la conception d’une base de données.

Créer un état dans Access

Vous pouvez créer des rapports pour votre base de données Access de bureau en suivant les étapes de cette section.

Étape 1 : choisir une source d’enregistrement

La source d’enregistrement d’un état peut être une table, une requête nommée ou une requête incorporée. La source d’enregistrement doit contenir toutes les lignes et colonnes de données que vous souhaitez afficher dans le rapport.

  • Si les données proviennent d’une table ou d’une requête existante, sélectionnez-la dans le volet de navigation, puis passez à l’étape 2.

  • Si la source d’enregistrement n’existe pas encore, effectuez l’une des opérations suivantes :

    • Passez à l’étape 2 et utilisez l’outil Rapport en blanc , ou
    • Créez la table ou la requête contenant les données requises. Sélectionnez la requête ou la table dans le volet de navigation, puis passez à l’Étape 2.

Étape 2 : choisir un outil d’état

Recherchez les outils de rapport sous l’onglet Créer du ruban, dans le groupe Rapports . Le tableau suivant décrit les options :

Outil Description
État Permet de créer un état simple sous forme de tableau contenant tous les champs de la source d’enregistrement que vous avez sélectionnée dans le volet de navigation.
Création d’état Permet d’ouvrir un état vierge en mode Création auquel vous pouvez ajouter les champs et contrôles nécessaires.
État vide Permet d’ouvrir un état vierge en mode Page et d’afficher la Liste de champs à partir de laquelle vous pouvez ajouter des champs à l’état.
Assistant État Affiche un Assistant en plusieurs étapes qui vous permet de spécifier des champs, des niveaux de regroupement et de tri et des options de mise en page.
Étiquettes Permet d’afficher un Assistant dans lequel vous pouvez sélectionner des tailles d’étiquette standard ou personnalisées. Vous avez également la possibilité de sélectionner les champs à afficher et le mode de tri de ces derniers.

Étape 3 : créer l’état

  1. Sélectionnez le bouton de l’outil que vous souhaitez utiliser. Si un Assistant apparaît, suivez les étapes décrites dans l’Assistant et sélectionnez Terminer sur la dernière page. Access affiche l’état en mode Page.

  2. Formatez le rapport pour obtenir l’apparence souhaitée :

    • Redimensionnez les champs et les étiquettes en les sélectionnant, puis en faisant glisser les bords jusqu’à ce qu’ils aient la taille souhaitée.
    • Déplacez un champ en le sélectionnant (avec son étiquette, le cas échéant), puis en le faisant glisser jusqu’au nouvel emplacement.
    • Cliquez avec le bouton droit sur un champ, puis utilisez les commandes du menu contextuel pour fusionner ou fractionner des cellules, supprimer ou sélectionner des champs et effectuer d’autres tâches de mise en forme.
      En outre, utilisez les fonctionnalités décrites dans les sections suivantes pour rendre votre rapport plus attrayant et lisible.

Remarque

À partir d’Access pour Microsoft 365 version 2609 (build 16.0.20430.20146), un rapport peut avoir une largeur maximale de 2 000 pouces (5 080 cm) et chaque section de rapport peut avoir une hauteur maximale de 2 000 pouces. La hauteur combinée de toutes les sections et des en-têtes de section peut atteindre 2 100 pouces (5 334 cm). Les versions antérieures d’Access conservent les limites précédentes de 22,75 pouces (57,79 cm) pour la largeur du rapport et la hauteur de section individuelle, et de 200 pouces (508 cm) pour la hauteur de section combinée. Les rapports qui utilisent des dimensions plus grandes peuvent ne pas être compatibles avec les versions antérieures. Vérifiez donc les versions Access utilisées par toute personne qui ouvre la base de données.

L’augmentation de la zone de conception du rapport n’augmente pas la zone d’impression du format de papier sélectionné. Utilisez les options Aperçu avant impression et Mise en page pour confirmer la façon dont le rapport sera divisé en pages. Pour plus d’informations, voir Afficher l’aperçu d’un état et l’imprimer.

Appliquer un regroupement, un tri ou ajouter des totaux

La méthode la plus rapide pour ajouter un regroupement, un tri ou des totaux à un rapport de base de données de bureau consiste à cliquer avec le bouton droit sur le champ auquel vous souhaitez appliquer le groupe, le tri ou le total, puis à sélectionner la commande souhaitée dans le menu contextuel.

Vous pouvez également ajouter des regroupements, des tris ou des totaux à l’aide du volet Regrouper, trier et total lorsque l’état est ouvert en mode Page ou Création :

  1. Si le volet Regroupe, tri et total n’est pas ouvert, sous l’onglet Création d’état , dans le groupe Regroupement et totaux , sélectionnez Grouper & Trier.
  2. Sélectionnez Ajouter un groupe ou Ajouter un tri, puis choisissez le champ dans lequel vous souhaitez regrouper ou trier.
  3. Sélectionnez Plus sur une ligne de regroupement ou de tri pour définir d’autres options et ajouter des totaux.

Pour plus d’informations sur le regroupement, le tri et les totaux, voir Créer un état groupé ou de synthèse.

Faire ressortir des données à l’aide d’une mise en forme conditionnelle

Access contient des outils pour faire ressortir des données sur un état. Vous pouvez ajouter des règles de mise en forme conditionnelle pour chaque contrôle ou groupe de contrôles, et dans les rapports clients, vous pouvez également ajouter des barres de données pour comparer les données.

Pour ajouter une mise en forme conditionnelle aux contrôles :

  1. Cliquez avec le bouton droit sur l’état dans le volet de navigation, puis cliquez sur Mode Page.

  2. Sélectionnez les commandes souhaitées. Sous l’onglet Format, dans le groupe Contrôler la mise en forme, cliquez sur Mise en forme conditionnelle.

    Conseil

    Pour sélectionner plusieurs contrôles, maintenez la touche Maj ou Ctrl enfoncée et cliquez sur les contrôles.

  3. Dans la boîte de dialogue Gestionnaire des règles de mise en forme conditionnelle, cliquez sur Nouvelle règle.

  4. Dans la boîte de dialogue Nouvelle règle de mise en forme, sélectionnez une valeur sous Sélectionnez un type de règle :

    • Pour créer une règle qui évalue chaque enregistrement individuellement, sélectionnez Vérifier les valeurs dans l’enregistrement actif ou utilisez une expression.
    • Pour créer une règle qui permet de comparer les enregistrements entre eux à l’aide de barres de données, cliquez sur Comparaison aux autres enregistrements.
  5. Sous Modifier la description de la règle, spécifiez la règle d’application et la mise en forme à appliquer, puis cliquez sur OK.

  6. Pour créer une autre règle pour le même contrôle ou ensemble de contrôles, répétez les étapes de cette procédure à partir de l’étape 4.

Personnalisation des couleurs et des polices

Essayez une option de thème d’application pour personnaliser la couleur et les polices.

  1. Ouvrez un rapport en mode Page en cliquant dessus avec le bouton droit dans le volet de navigation, puis en cliquant sur Mode Page.
  2. Dans l’onglet Création de mise en page du rapport , cliquez sur Thèmes et pointez le curseur sur les différents thèmes de la galerie pour prévisualiser les effets. Cliquez sur un thème pour le sélectionner, puis enregistrez votre rapport.
  3. Utilisez les galeries Couleurs ou Polices pour définir les couleurs ou les polices indépendamment.

Ajouter un logo ou une image d’arrière-plan

Vous pouvez ajouter un logo ou une image d’arrière-plan à un rapport. Si vous mettez à jour l’image, Access met automatiquement à jour l’image partout où elle est utilisée dans la base de données.

Pour ajouter ou supprimer une image de logo :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur l’état, puis cliquez sur Mode Page.
  2. Dans le rapport, cliquez sur l’emplacement où vous souhaitez ajouter l’image. Sous l’onglet Création de la mise en page du rapport , dans le groupe En-tête/Pied de page , cliquez sur Logo.
  3. Accédez à l’image, puis cliquez sur Ouvrir. Access l’ajoute à l’état.
  4. Pour supprimer l’image, cliquez dessus avec le bouton droit, puis cliquez sur Supprimer dans le menu contextuel.

Pour ajouter une image d’arrière-plan :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur l’état, puis cliquez sur Mode Page.
  2. Sous l’onglet Format, dans le groupe Arrière-plan, cliquez sur Image d’arrière-plan.
  3. Sélectionnez une image dans la liste Galerie d’images ou cliquez sur Parcourir, sélectionnez une image, puis cliquez sur OK.

Afficher l’aperçu d’un état et l’imprimer

Afficher l’aperçu d’un état

  1. Cliquez avec le bouton droit sur le rapport dans le volet de navigation, puis sélectionnez Aperçu avant impression. Utilisez les commandes de l’onglet Aperçu avant impression pour :

    • Imprimer l’état
    • ajuster la taille de la page ou la disposition ;
    • effectuer un zoom avant ou arrière ou afficher plusieurs pages à la fois ;
    • Actualiser les données de l’état
    • Exporter le rapport dans un autre format de fichier
  2. Sélectionnez Fermer l’aperçu avant impression.

Pour imprimer un état sans en afficher l’aperçu :

  • Cliquez avec le bouton droit sur le rapport dans le volet de navigation, puis sélectionnez Imprimer. L’état est envoyé sur votre imprimante par défaut.

    Remarque

    Si vous sélectionnez l’état dans le volet de navigation et Imprimer dans l’onglet Fichier , vous pouvez sélectionner d’autres options d’impression, telles que le nombre de pages et de copies, et spécifier une imprimante.

    • Pour ouvrir une boîte de dialogue dans laquelle vous pouvez sélectionner une imprimante, spécifier le nombre de copies, etc., sélectionnez Imprimer.