CORRIGER : Forefront Unified Access Gateway 2010 entre alors dans une boucle de nouvelle tentative de demande /

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La version anglaise de cet article est la suivante: 2811103
Symptômes
Envisagez le scénario suivant :
  • Un serveur web est publié à l'aide de Microsoft Forefront Unified Access Gateway (UAG) 2010.
  • Forefront UAG 2010 utilise des tickets Kerberos Constrained délégation (KCD) pour déléguer les informations d'identification de l'utilisateur au serveur web publié.
  • Le serveur web publié rejette le ticket KCD qui est fourni par Forefront UAG 2010 et renvoie une erreur 401.
Dans ce scénario, Forefront UAG 2010 entre dans une boucle de nouvelle tentative de demande /. En outre, les conditions suivantes peuvent se produire pour le processus de travail w3wp.exe Forefront UAG lors de la boucle de demande/retry :
  • Une augmentation rapide de la consommation de mémoire
  • Utilisation élevée du processeur
Cause
Ce problème est généralement causé par un problème qui concerne le programme d'installation KCD ou un problème qui existe sur le serveur web publié.

Si Forefront UAG a authentifié l'utilisateur et a obtenu avec succès un ticket KCD au serveur publié, le programme n'attend pas de recevoir une erreur 401 à partir du serveur web publié lors de la négociation de KCD avec le serveur publié. Dans ces conditions, Forefront UAG tente de gérer l'erreur 401 en obtenant un nouveau ticket KCD, puis soumettre la demande au serveur web publié. Cette activité entraîne une boucle de nouvelle tentative de demande/de se produire.

Important : Nouvelle tentative de demande/boucle est corrigé dans Forefront Unified Access Gateway 2010 Service Pack 3 (SP3). Forefront UAG 2010 SP3 ne résout pas le problème d'authentification sous-jacent, car que le problème ne se produit pas dans Forefront UAG. Si Forefront UAG reçoit l'erreur 401 inattendue à partir du serveur web publié, car l'échec de la négociation de KCD avec le serveur web publié, l'erreur 401 est renvoyé au client. Le client reçoit ensuite une invite d'authentification. Toutefois, le client ne pourra pas effectuer l'authentification en raison du problème sous-jacent.

Remarque Consultez la section « Plus informations » pour plus d'informations sur les causes de l'échec d'authentification au serveur web publié.
Résolution
Pour résoudre ce problème, installez le service pack qui est décrite dans l'article suivant de la Base de connaissances Microsoft :

2744025 Description de Forefront Unified Access Gateway 2010 Service Pack 3
Statut
Microsoft a confirmé qu'il s'agit d'un problème pour les produits Microsoft répertoriés dans la section « S'applique à ».
Plus d'informations
Support technique Microsoft a enregistré plusieurs occurrences de ce problème dans les scénarios de publication Outlook Anywhere. Dans ces cas, le problème a provoqué l'authentification KCD pour le serveur d'accès Client (CAS) basculer pour RPC sur le trafic HTTP. Pour plus d'informations sur un problème semblable, cliquez sur le numéro ci-dessous pour accéder à l'article correspondant dans la Base de connaissances Microsoft :

2545850 Les utilisateurs ne peut pas accéder à un site Web hébergé par IIS après avoir modifié le mot de passe pour le serveur dans Windows 7 ou Windows Server 2008 R2
Remarques
  • Le correctif qui est décrite dans la base de connaissances 2545850 doit être installé sur les autorités de certification, pas sur le serveur Forefront UAG.
  • Pour contourner ce problème sans installer le correctif 2545850, redémarrez les autorités de certification. Cette solution de contournement restera en vigueur jusqu'à la prochaine fois que vous rencontrez ce problème.
Le web server peut également renvoyer une erreur 401 en raison d'un problème d'autorisations ou si KCD n'est pas configuré correctement. Par exemple, le Service nom Principal (SPN) qui délègue Forefront UAG ne peuvent pas être inscrits sur le compte de serveur web cible ou le compte de service de processus. Pour plus d'informations sur le programme d'installation de la délégation contrainte Kerberos, accédez au site Web Microsoft TechNet suivant :

Références
Pour plus d'informations sur la terminologie de mise à jour de logiciels, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

824684 Description de la terminologie standard utilisée pour définir les mises à jour logicielles de Microsoft

Propriétés

ID d'article : 2811103 - Dernière mise à jour : 02/21/2013 15:55:00 - Révision : 3.0

Microsoft Forefront Unified Access Gateway 2010, Microsoft Forefront Unified Access Gateway 2010 Service Pack 1, Microsoft Forefront Unified Access Gateway 2010 Service Pack 2

  • kbqfe kbfix kbexpertiseinter kbsurveynew kbbug kbmt KB2811103 KbMtfr
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