Des interruptions de service intermittentes se produisent après l'installation d'une version de SQL Server 2008 ou SQL Server 2008 R2 à partir de KB3135244

Symptômes
Des interruptions de service intermittentes peuvent se produire après l'installation d'une mise à jour de la prise en charge de TLS 1.2 pour Microsoft SQL Server 2008 et Microsoft SQL Server 2008 R2 décrite dans l'article 3135244.
Plus d'informations
Le 29 janvier 2016, Microsoft a publié la mise à jour de TLS 1.2 pour SQL Server 2008 et SQL Server 2008 R2. Nous avons identifié un problème dans la mise à jour, qui entraîne des interruptions de service intermittentes lorsque vous tentez de vous connecter à une instance de SQL Server.

Lorsque ce problème se produit, un message d'erreur semblable à l'un des messages suivants est consigné dans le journal des erreurs SQL Server :

Date et heure spid1s ***Stack Dump being sent to C:\Program Files\Microsoft SQL Server\MSSQL10.DEV08\MSSQL\LOG\SQLDump0002.txt
Date et heure spid1s * *******************************************************************************
Date et heure spid1s *
Date et heure spid1s * BEGIN STACK DUMP:
Date et heure spid1s * Date et heure spid 1
Date et heure spid1s *
Date et heure spid1s * Location: sosmemobj.cpp:2760
Date et heure spid1s * Expression: pvb->FInUse ()
Date et heure spid1s * SPID: 1
Date et heure spid1s * Process ID: 1164

Date et heure Server ***Stack Dump being sent to C:\Program Files\Microsoft SQL Server\MSSQL10.DEV08\MSSQL\LOG\SQLDump0001.txt
Date et heure Server * *******************************************************************************
Date et heure Server *
Date et heure Server * BEGIN STACK DUMP:
Date et heure Server * Date et heure spid 2076
Date et heure Server *
Date et heure Server * ex_terminator - Last chance exception handling

Versions concernées

Les versions commerciales de SQL Server suivantes sont concernées par ce problème.
Version de SQL ServerVersion concernée
SQL Server 2008 R2 SP3 (x86 et x64)10.50.6537.0
SQL Server 2008 R2 SP2 GDR (IA-64 uniquement)10.50.4046.0
SQL Server 2008 R2 SP2 (IA-64 uniquement)10.50.4343.0
SQL Server 2008 SP4 (x86 et x64)10.0.6543.0
SQL Server 2008 SP3 GDR (IA-64 uniquement)10.0.5544.0
SQL Server 2008 SP3 (IA-64 uniquement)10.0.5894.0
Résolution
Pour que les clients puissent se protéger du problème d'interruption de service, nous leur recommandons d'installer les mises à jour de la prise en charge de TLS 1.2 pour Microsoft SQL Server décrites dans l'article 3135244 de la Base de connaissances si leur version de SQL Server est répertoriée dans le tableau « Versions concernées » de la section précédente.

Nous avons publié des versions mises à jour de SQL Server 2008 R2 et SQL Server 2008 qui résolvent le problème identifié dans la mise à jour de TLS 1.2. Nous vous recommandons d'utiliser cette nouvelle version pour mettre à jour toutes les instances de SQL Server auxquelles la mise à jour de TLS 1.2 a été appliquée.

Pour plus d'informations sur l'emplacement de téléchargement des versions mises à jour, consultez l'article suivant de la Base de connaissances Microsoft :
3135244 Prise en charge de TLS 1.2 pour Microsoft SQL Server
Plus d'informations

Forum aux questions

Cette mise à jour comporte-t-elle d'autres modifications de sécurité affectant les fonctionnalités ? 

Outre les modifications décrites dans l'article 3135244 de la Base de connaissances, cette mise à jour inclut des mises à jour de défense en profondeur afin d'améliorer les fonctionnalités de sécurité.
Statut
Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.
Propriétés

ID d'article : 3146034 - Dernière mise à jour : 03/04/2016 13:57:00 - Révision : 2.0

Microsoft SQL Server 2008 R2 Developer, Microsoft SQL Server 2008 R2 Enterprise, Microsoft SQL Server 2008 R2 Standard, Microsoft SQL Server 2008 R2 Express, Microsoft SQL Server 2008 Developer, Microsoft SQL Server 2008 Enterprise, Microsoft SQL Server 2008 Standard, Microsoft SQL Server 2008 Express

  • kbbug kbexpertiseinter kbsecurity kbsecvulnerability KB3146034
Commentaires