Cet article contient des conseils pour améliorer les performances d’Microsoft Office base de données Access. En suivant ces conseils, vous pouvez accélérer de nombreuses opérations de base de données, telles que l’exécution d’états ou l’ouverture de formulaires basés sur des requêtes complexes.

L’une des meilleures méthodes pour améliorer les performances d’une base de données consiste à créer des index pour les champs fréquemment utilisés. La création d’index vous permet d’améliorer les performances plus que vous ne le pouvez en suivant les conseils de cet article. Access crée automatiquement certains index pour vous, mais vous devez réfléchir soigneusement à l’opportunité d’améliorer les performances des index supplémentaires.

Cet article n’explique pas comment optimiser les performances d’objets de base de données spécifiques (par exemple, en créant un index). Pour plus d’informations, voir l’article Créer et utiliser un index pour améliorer les performances.

Contenu de cet article

Contribuer à améliorer les performances d’une base de données locale

Les instructions suivantes peuvent vous aider à optimiser les performances d’une base de données Access locale (une base de données stockée sur un disque dur local, plutôt que sur un réseau).

Désactiver la fonction Decorrect automatique de nom

La fonctionnalité Decorrection automatique de nom garantit que la fonctionnalité des objets de base de données reste intacte lorsque d’autres objets de base de données dont ils dépendent sont renommés. Par exemple, si vous renommez une table et que des requêtes utilisent cette table, la fonction De nom automatique s’assure que ces requêtes ne sont pas en rupture en raison de la modification. Cette fonctionnalité peut être utile, mais elle ralentit certains résultats.

Si votre conception de base de données est stable et que ses objets ne seront pas renommés, vous pouvez désactiver la fonction De nom automatique pour améliorer les performances.

  1. Ouvrez la base de données à optimiser.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche de la boîte de dialogue Options Access, cliquez sur Base de données active.

  4. Dans le volet droit, sous Options de la fonction Decorrect automatiquede nom, décocher toutes les cases.

Définir le compactage et la réparation automatiques de la base de données

Au fil du temps, les performances d’un fichier de base de données peuvent devenir ralenties en raison de l’espace qui reste alloué à des objets supprimés ou temporaires. La commande Compacter et réparer supprime cette perte d’espace et peut aider une base de données à s’exécuter plus rapidement et plus efficacement. Vous pouvez définir une option pour exécuter automatiquement la commande Compacter et réparer à la fermeture d’une base de données.

  1. Ouvrez la base de données à optimiser.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche de la boîte de dialogue Options Access, cliquez sur Base de données active.

  4. Dans le volet droit, sous Options de l’application,cochez la case Compacter lors de la fermeture.

Ouvrir la base de données en mode exclusif

Si vous êtes la seule personne à utiliser une base de données, l’ouverture en mode exclusif empêche les autres utilisateurs d’utiliser la base de données en même temps et peut contribuer à améliorer les performances.

  1. Démarrez Access, mais n’ouvrez pas de base de données. Si vous avez déjà une base de données ouverte, fermez-la.

  2. Cliquez sur Ouvrir, puis sur Parcourir.

  3. Dans la boîte de dialogue Ouvrir, sélectionnez le fichier de base de données à ouvrir. Si vous avez besoin de rechercher le fichier de base de données, vous pouvez utiliser la liste Rechercher dans.

  4. Cliquez sur la flèche du bouton Ouvrir, puis sur Ouvrir en exclusif.

Désactiver les options de la fonction decorrec automatique

Par défaut, Access corrige l’orthographe lors de la taper. Vous pouvez désactiver la fonctionnalité Decorrect automatique pour améliorer les performances.

  1. Ouvrez la base de données à optimiser.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche de la boîte de dialogue Options Access, cliquez sur Preuve.

  4. Dans le volet droit, sous Options de la fonction Decorrect automatique,cliquez sur Options de la fonction Decorrect automatique.

  5. Dans la boîte de dialogue Options decorrect automatique, décocher les cases des options que vous ne souhaitez pas.

    Remarque : Il n’est pas nécessaire de désactiver toutes les options de la fonction Decorrect automatique pour voir un avantage, mais plus vous la désactiverez, plus l’avantage sera important.

Haut de la page

Contribuer à améliorer les performances dans un environnement multi-environnement

Les instructions suivantes peuvent vous aider à optimiser les performances d’une base de données Access utilisée dans un environnement multi-utilisateur.

Fractionner la base de données

Lorsque vous fractionnez une base de données, vous placez les tables de données dans un fichier de base de données sur un serveur réseau, dans ce qu’on appelle une base de données principale. Vous placez les autres objets de base de données, tels que les requêtes, formulaires et états, dans un autre fichier de base de données appelé base de données frontale. Les utilisateurs conservent leur propre copie de la base de données frontale sur leur ordinateur. Les performances seront améliorées, car seules les données sont envoyées sur le réseau.

Vous fractionner une base de données à l’aide de l’Assistant Fractionnement de base de données.

  • Sous l’onglet Outils de base de données, dans le groupe Déplacer les données, cliquez sur Base de données Access.

Modifier le paramètre de verrouillage au niveau de la page ou au niveau de l’enregistrement

Access verrouille une certaine quantité de données pendant que vous modifiez des enregistrements. La quantité de données verrouillée dépend du paramètre de verrouillage que vous choisissez. Vous pouvez contribuer à améliorer les performances en choisissant le verrouillage au niveau de la page. Toutefois, le verrouillage au niveau de la page peut diminuer la disponibilité des données, car plus de données sont verrouillées qu’avec un verrouillage au niveau de l’enregistrement.

  • Verrouillage au niveau de la page    Access verrouille la page qui contient l’enregistrement (la page est la zone de mémoire où se trouve l’enregistrement). La modification d’un enregistrement avec le verrouillage au niveau de la page activé peut également entraîner le verrouillage d’autres enregistrements stockés à proximité en mémoire. Toutefois, les performances sont généralement plus rapides lorsque vous utilisez le verrouillage au niveau de la page au lieu de verrouillage au niveau de l’enregistrement.

  • Verrouillage au niveau de l’enregistrement    Access verrouille uniquement l’enregistrement en cours de modification. Les autres enregistrements ne sont pas affectés.

Modifier le paramètre de verrouillage au niveau de la page ou au niveau de l’enregistrement    

  1. Ouvrez la base de données à ajuster.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche, cliquez sur Paramètres du client.

  4. Dans le volet droit, dans la section Avancé, cochez ou non la case Ouvrir les bases de données à l’aide de la case à cocher verrouillage au niveau de l’enregistrement.

Choisir un paramètre approprié de verrouillage d’enregistrement

Access verrouille les enregistrements pendant que vous les modifiez. Le nombre d’enregistrements verrouillés par Access et la durée de verrouillage dépendent du paramètre de verrouillage d’enregistrement de votre choix.

  • Aucun verrouillage     Access ne verrouille pas un enregistrement ou une page tant qu’un utilisateur n’y a pas enregistré des modifications, ce qui a pour effet que les données sont plus facilement disponibles. Toutefois, des conflits de données (modifications simultanées apportées au même enregistrement) peuvent se produire si vous utilisez ce paramètre. Lorsqu’un conflit de données se produit, l’utilisateur doit décider de la version des données à conserver. Il s’agit généralement de l’option la plus rapide, mais les conflits de données risquent d’avoir un effet sur les performances.

  • Enregistrement modifié     Access verrouille un enregistrement dès qu’un utilisateur commence à le modifier. Par conséquent, les enregistrements sont verrouillés pendant de longues périodes, mais les conflits de données sont moins probables.

  • Tous les enregistrements     Access verrouille tous les enregistrements d’une table lorsque tout formulaire ou feuille de données qui utilise cette table est ouvert. Cela peut améliorer les performances pour l’utilisateur qui modifie les données du tableau, mais limite la capacité des autres utilisateurs à modifier les données plus que les autres options.

Modifier le paramètre de verrouillage d’enregistrement    

  1. Ouvrez la base de données à ajuster.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche, cliquez sur Paramètres du client.

  4. Dans le volet droit, dans la section Avancé, sous Verrouillaged’enregistrement par défaut, cliquez sur l’option de votre choix.

Ajuster les paramètres d’actualisation et de mise à jour du réseau

Essayez d’ajuster, le cas échéant, l’intervalle d’actualisation d’actualisation (s),l’intervalle de nouvelle tentative de mise à jour (msec),le nombre de restaurations de la mise à jour et les paramètres d’intervalle d’actualisation ODBC (s).

Utilisez l’intervalle de nouvelle tentative de mise à jour et le nombre de paramètres de réessayer de mise à jour pour spécifier la fréquence et le nombre de tentatives d’Access d’enregistrer un enregistrement lorsqu’il est verrouillé par un autre utilisateur.

Vous utilisez les paramètres Intervalle d’actualisation ODBC et Intervalle d’actualisation pour contrôler la fréquence d’actualisation de vos données par Access. L’actualisation met uniquement à jour les données qui existent déjà dans votre feuille de données ou formulaire. L’actualisation n’a pas pour effet de réorder les enregistrements, d’afficher de nouveaux enregistrements ou de supprimer des enregistrements supprimés des résultats de requête qui ne répondent plus aux critères spécifiés. Pour afficher de telles modifications, vous devez ré-réquerr les enregistrements sous-jacents de la feuille de données ou du formulaire.

Modifier les paramètres d’actualisation et de mise à jour du réseau    

  1. Ouvrez la base de données dont vous voulez accélérer l’exécutez.

  2. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  3. Dans le volet gauche, cliquez sur Paramètres du client.

  4. Dans le volet droit, dans la section Avancé, modifiez les paramètres de votre côté.

Conseil : Pour réesquer, appuyez sur Shift+F9.

Haut de la page

Contribuer à améliorer les performances d’Access sur votre ordinateur

Les instructions suivantes peuvent vous aider à améliorer les performances d’Access, que la base de données avec laquelle vous travaillez soit stockée sur votre ordinateur ou sur un réseau.

Désactiver les animations d’interface utilisateur

L’interface utilisateur d’Access inclut des animations, telles que l’ouverture des menus. Bien que ces animations facilitent l’utilisation de l’interface, elles peuvent toutefois ralentir quelque peu l’interface. Vous pouvez les désactiver pour améliorer les performances.

  1. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  2. Dans le volet gauche, cliquez sur Paramètres du client.

  3. Dans le volet droit, sous Affichage,cochez la case Afficher les animations.

Désactiver les balises d’action

Si vous n’utilisez pas de balises d’action, vous pouvez les désactiver pour améliorer les performances.

  1. Cliquez sur Fichier > Options pour ouvrir la boîte de dialogue Options Access.

  2. Dans le volet gauche, cliquez sur Paramètres du client.

  3. Dans le volet droit, sous Affichage,effacer les cases à cocher Afficher les balises d’action dans les feuilles de données et Afficher les balises d’action sur les formulaires et rapports.

Fermer les autres programmes non utilisés

La fermeture d’autres programmes rend plus de mémoire disponible pour Access, ce qui permet de minimiser l’utilisation du disque et d’améliorer les performances.

Remarque : Vous pouvez également quitter certains programmes qui continuent de s’exécutent en arrière-plan une fois que vous les avez fermés. Recherchez un programme de ce type dans votre zone de notification. Faites attention lorsque vous quittez ces programmes, car certains programmes peuvent être nécessaires pour que votre ordinateur fonctionne comme prévu. Si vous avez des doutes, vous ne devez probablement pas quitter ces programmes.

Ajouter de la RAM à votre ordinateur

L’ajout de ram à votre ordinateur peut vous aider à exécuter les requêtes de grande taille plus rapidement et vous permettre d’ouvrir plusieurs objets de base de données en même temps. En outre, la mémoire RAM est beaucoup plus rapide que la mémoire virtuelle sur un lecteur de disque dur. Lorsque vous ajoutez de la RAM, vous contribuez à minimiser l’utilisation du disque et à améliorer les performances.

Nettoyer vos disques durs

Effectuez régulièrement cet ensemble d’étapes :

  1. Supprimez les fichiers dont vous n’avez plus besoin de votre ordinateur.

  2. Supprimez vos fichiers Internet temporaires.

  3. Vider la Corbeille.

  4. Exécutez des opérations de compactage et réparation sur vos bases de données.

  5. Défragmentez vos disques durs.

Désactiver les services Windows dont vous n’avez pas besoin

Par exemple, si vous avez une bonne solution de sauvegarde de bureau, vous devez désactiver le service Restaurer le système. La désactivation des services Microsoft Windows que vous n’utilisez pas rend la ram plus disponible pour Access.

Important : Si vous décidez de désactiver les services Windows, suivez ce que vous désactivez afin de pouvoir facilement réactiver les services Windows dont vous avez besoin.

Ajuster vos paramètres de mémoire virtuelle

Dans la plupart des cas, le paramètre de mémoire virtuelle par défaut utilisé par Windows doit être optimal. Toutefois, dans certains cas, le réglage des paramètres de mémoire virtuelle peut améliorer les performances d’Access. Envisagez d’ajuster les paramètres de mémoire virtuelle par défaut dans les cas suivants :

  • Vous n’avez pas beaucoup d’espace disque disponible sur le lecteur actuellement utilisé pour la mémoire virtuelle, et un autre lecteur local dispose d’espace.

  • Un autre lecteur local plus rapide que le lecteur actuel dispose d’espace disponible et n’est pas largement utilisé.

Dans ce cas, il est possible que vous obtenez de meilleures performances en spécifiant un autre lecteur pour la mémoire virtuelle.

Vous pouvez également obtenir de meilleures performances en spécifiant une quantité fixe d’espace disque pour la mémoire virtuelle. Vous pouvez spécifier 1,5 fois la quantité de mémoire vive (RAM) installée sur votre ordinateur. Par exemple, si vous avez 1 024 mégaoctets (Mo) de RAM, spécifiez 1 536 Mo pour la mémoire virtuelle.

Remarque : Vous pouvez spécifier davantage de mémoire virtuelle si vous exécutez souvent plusieurs applications de grande taille simultanément.

Pour obtenir de l’aide sur la modification des paramètres de mémoire virtuelle, recherchez « modifier la mémoire virtuelle » dans l’aide de Windows.

N’utilisez pas d’écran de sauvegarde

Les captures d’écran utilisent la mémoire et démarrent automatiquement. Grâce aux améliorations de la conception des moniteurs, les écran de veille ne sont plus nécessaires pour protéger votre moniteur contre le « burn-in ». Vous pouvez améliorer légèrement les performances et faciliter le fonctionnement de votre ordinateur à l’aide d’un économiseur d’écran.

Conseil : N’appuyez pas sur un économiseur d’écran pour protéger votre ordinateur contre tout accès non autorisé. Pour protéger votre ordinateur lorsque vous vous éloignez, appuyez sur la touche de logo Windows+L.

N’utilisez pas d’arrière-plan du Bureau

Vous pouvez améliorer quelque peu la configuration de l’arrière-plan du bureau sur (Aucun).

Haut de la page

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×