Comment corriger une erreur #REF! erreur

L’erreur #REF! s’affiche quand une formule fait référence à une cellule non valide. Cela se produit le plus souvent quand des cellules référencées par des formules sont supprimées ou remplacées.

Exemple - Erreur #REF! causée par la suppression d’une colonne

L’exemple suivant utilise la formule =SOMME(B2;C2;D2) dans la colonne E.

Une formule utilisant des références de cellule explicites, telle que =SOMME(B2;C2;D2), peut générer une erreur #REF! en cas de suppression d’une colonne.

Si vous supprimiez les colonnes B, C ou D, cela entraînerait une #REF ! erreur. Dans ce cas, nous supprimons la colonne C (ventes de 2007). La formule affiche à présent =SOMME(B2;#REF!;C2). Lorsque vous utilisez des références de cellules explicites comme cela (quand vous référencez chaque cellule individuellement, en la séparant par une virgule), puis supprimez une ligne ou une colonne référencées, Excel ne peut pas résoudre les références et renvoie l’erreur #REF! erreur. Il s’agit de la raison principale pour laquelle l’utilisation de références de cellules explicites dans des fonctions n’est pas recommandé.

Exemple d’erreur #REF! causée par la suppression d’une colonne.

Solution

  • Si vous avez supprimé par mégarde des lignes ou des colonnes, vous pouvez immédiatement cliquer sur le bouton Annuler dans la barre d’outils Accès rapide (ou appuyer sur CTRL+Z) pour les restaurer.

  • Ajustez la formule afin qu’elle utilise une référence de plage plutôt que des cellules individuelles, par exemple =SOMME(B2:D2). Vous pouvez à présent supprimer toute colonne dans la plage de somme. Excel ajuste automatiquement la formule. Vous pouvez aussi utiliser la formule =SOMME(B2:B5) pour additionner des lignes.

Exemple : RECHERCHEV avec des références de plage incorrectes

Dans l’exemple suivant, =RECHERCHEV(A8,A2:D5,5,FALSE) retourne une #REF! erreur, car il recherche une valeur à retourner à partir de la colonne 5, mais la plage de référence est A:D, qui est uniquement de 4 colonnes.

Exemple de formule RECHERCHEV avec une plage incorrecte.  La formule est =RECHERCHEV(A8;A2:D5;5;FAUX).  Il n’y a pas de cinquième colonne dans la plage RECHERCHEV. Par conséquent, 5 provoque une erreur #REF! erreur.

Solution

Ajustez la plage pour l’agrandir, ou réduisez la valeur de recherche de colonne pour qu’elle corresponde à la plage de référence. =RECHERCHEV(A8;A2:E5;5;FAUX) serait une plage de référence valide, tout comme =RECHERCHEV(A8;A2:D5;4;FALSE).

Exemple : INDEX avec une référence de ligne ou de colonne incorrecte

Dans cet exemple, la formule =INDEX(B2:E5;5;5) renvoie une erreur #REF! parce que la plage INDEX comprend 4 lignes sur 4 colonnes, alors que la formule demande le renvoi du contenu de la 5ème ligne de la 5ème colonne.

Exemple de formule INDEX avec une référence de plage non valide.  La formule est =INDEX(B2:E5;5;5), mais la plage n’est que de 4 lignes sur 4 colonnes.

Solution

Ajustez les références de ligne ou de colonne afin qu’elles s’inscrivent à l’intérieur de la plage de recherche INDEX. =INDEX(B2:E5;4;4) renvoie un résultat valide.

Exemple : référence à un classeur fermé avec la fonction INDIRECT

Dans l’exemple suivant, une fonction INDIRECT tente de référencer un classeur fermé, ce qui’ provoque une #REF! erreur.

Exemple d’erreur #REF! causée par une fonction INDIRECT faisant référence à un classeur fermé.

Solution

Ouvrez le classeur référencé. Vous rencontrerez la même erreur si vous référencez un classeur fermé avec unefonction de tableau dynamique.

Problèmes OLE

Si vous avez utilisé un lien OLE (Object Linking and Embedding) qui retourne un #REF! , puis démarrez le programme que le lien appelle.

Note: OLE est une technologie permettant de partager des informations entre des programmes.

Problèmes DDE

Si vous avez utilisé une rubrique échange dynamique de données (DDE) qui retourne un #REF ! erreur, vérifiez d’abord que vous référencez la rubrique appropriée. Si vous recevez toujours un #REF ! Vérifiez les Paramètres de votre centre de confiance pour le contenu externe, comme indiqué dans la section Bloquer ou débloquer le contenu externe dans les documents Office.

Remarque : Échange dynamique de données (DDE)est un protocole établi pour échanger des données entre des programmes Microsoft Windows.

Problèmes de macro

Si une macro entre une fonction dans la feuille de calcul qui fait référence à une cellule au-dessus de la fonction et que la cellule qui contient la fonction se trouve à la ligne 1, la fonction retourne #REF! car il n’y a aucune cellule au-dessus de la ligne 1. Vérifiez la fonction pour voir si un argument référence une cellule ou une plage de cellules non valides. La prise en compte de cette situation peut nécessiter une modification de la macro dans Visual Basic Editor (VBE).

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Fonctions Excel (par ordre alphabétique)

Fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×