Lorsque vous commencez à créer des formules, gardez à l’esprit les meilleures pratiques suivantes. Il est également bon de connaître les erreurs courantes que vous pouvez faire lorsque vous créez des formules.

Meilleures pratiques pour la création de formules

Le tableau suivant résume les meilleures pratiques pour la saisie de formules.

Suivez cette pratique pratique

Comme suit :

Modifier facilement le type de référence        

Remarque : Cela ne s’applique pas Excel pour le web.

Pour basculer entre les références relatives, absolues et mixtes :.

  1. Sélectionnez la cellule qui contient la formule.

  2. Dans la barre de formule Image du bouton, sélectionnez la référence à modifier.

  3. Appuyez sur F4 pour passer au type de référence suivant.

Copier rapidement des formules   

Pour entrer rapidement la même formule dans une plage de cellules, sélectionnez la plage à calculer, tapez la formule, puis appuyez sur Ctrl+Entrée. Par exemple, si vous tapez =SOMME(A1:B1) dans la plage C1:C5, puis appuyez sur Ctrl+Entrée, Excel entre la formule dans chaque cellule de la plage, en utilisant A1 comme référence relative.

Utiliser la fonction de recomplet automatique de formule    

Pour faciliter la création et la modification des formules, et pour limiter les erreurs de syntaxe et de frappe, utilisez la saisie automatique de formule. Après avoir tapé un = (signe égal) et les premières lettres (les premières lettres agissent comme un déclencheur d’affichage), Excel affiche une liste dynamique de fonctions et de noms valides sous la cellule. Après avoir inséré la fonction ou le nom dans la formule à l’aide d’un déclencheur d’insertion (en appuyant sur tab ou en double-cliquant sur l’élément dans la liste), Excel affiche tous les arguments appropriés. Lorsque vous remplissez la formule, la saisie d’une virgule peut également faire agir en tant que déclencheur d’affichage Excel peut afficher des arguments supplémentaires. Vous pouvez insérer d’autres fonctions ou noms dans votre formule et, lorsque vous tapez leurs premières lettres, Excel affiche une liste dynamique dans laquelle vous pouvez faire votre choix.

Utiliser les screentips de fonction   

Si vous n’êtes pas familiarisé avec les arguments d’une fonction, vous pouvez utiliser l’bulle de la fonction qui apparaît après avoir tapé le nom de la fonction et une parenthèse ouvrante. Cliquez sur le nom de la fonction pour afficher la rubrique d’aide sur la fonction, ou cliquez sur le nom d’un argument pour sélectionner l’argument correspondant dans votre formule.

Détecter les erreurs dans les formules

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×