Important : Dans Excel 2016, Excel Mobile et Excel pour le web, CONCATENER a été supersedée par la fonction CONCAT. Si CONCATENER est toujours disponible à des fins de compatibilité descendante, il est préférable d’utiliser la fonction CONCAT car elle est plus robuste.

L’erreur #VALEUR! liée à CONCATENER survient généralement lorsque vous tentez de créer une chaîne contenant une référence de cellule qui comporte une erreur, par exemple #VALEUR!.

Dans l’exemple suivant, nous souhaitons concaténer D2, E2 et F2, où E2 a une #VALUE ! erreur.

Erreur #VALEUR! dans la fonction CONCATENER

L’erreur dans la E2 entraîne l’affichage du #VALUE! erreur. Pour qu’elle fonctionne correctement, vous devez remplacer l’erreur par une valeur autre que l’erreur. Vous pouvez créer une formule qui recherche une erreur dans la référence de cellule et, si c’est le cas, afficher la chaîne de texte dans laquelle un 0 apparaît à la place de l’erreur (ou vous pouvez remplacer votre propre texte par 0, mais vous devez l’entourer de guillemets – « Votre texte »).

La formule suivante fonctionnera :

=SI(ESTERREUR(E2),CONCATENER(D2," ",0," ",F2))

Fonctions SI et ESTERREUR utilisées comme solution de contournement pour concaténer une chaîne avec la #VALUE! erreur

Comment cela fonctionne-t-il ? La fonction SI utilise la fonction SIERREUR pour déterminer s’il existe une erreur dans E2 et, si tel est le cas, la fonction CONCATENER combine les valeurs des fonctions D2, E2 et F2 (la fonction remplace l’erreur par un 0) et affiche la chaîne de texte résultante. Notez que la formule utilise également des espaces (« ») pour séparer les valeurs.

Corriger l’erreur #VALEUR! avec la fonction CONCATENER dans Excel 2003 et versions antérieures

Si vous rencontrez l’erreur #VALEUR! dans Office Excel 2003 ou versions antérieures, vous devez désactiver l’option Autre interprétation des formules dans Excel. Suivez les étapes décrites dans #VALUE erreur ! lors de la concatenation de cellules .

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Corriger une erreur #VALEUR! erreur

fonction CONCATENER

Fonction CONCAT

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Toutes les fonctions Excel (par ordre alphabétique)

Toutes les fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×