SI est l’une des fonctions les plus polyvalentes et populaires d’Excel, et elle est souvent utilisée plusieurs fois dans la même formule ainsi que dans les combinaisons avec d’autres fonctions. Malheureusement, en raison de la complexité de certaines instructions SI, une erreur #VALEUR! peut facilement être générée. Vous pouvez généralement supprimer l’erreur en ajoutant des fonctions spécifiques de gestion des erreurs, comme ESTERREUR, ESTERR ou SIERREUR, à votre formule.

Problème : L’argument fait référence à des valeurs d’erreur

Lorsqu’une cellule fait référence à une valeur d’erreur, SI affiche le #VALUE! erreur.

Solution: vous pouvez utiliser n’importe quelle formule de gestion des erreurs, telle que ESTERREUR, ESTERR ou SIERREUR, avec SI. Les rubriques suivantes expliquent comment utiliser SI, ESTERREUR et ESTERR ou SIERREUR dans une formule lorsque votre argument fait référence à des valeurs d’erreur.

Remarques : 

  • La fonction SIERREUR a été introduite dans Excel 2007 et elle est nettement préférable à ESTERREUR ou ESTERR, car elle n’exige pas que la formule soit créée de manière redondante. Avec les fonctions ESTERREUR et ESTERR, la formule doit être calculée deux fois, d’abord pour voir si elle génère une erreur, puis pour renvoyer son résultat. SIERREUR n’effectue qu’un seul calcul.

  • =SIERREUR(Formule,0) est préférable à =SI(ESTERREUR(Formule,0,Formule))

Problème : la syntaxe est incorrecte

Si la syntaxe d’une fonction est mal construite, elle peut renvoyer la #VALUE! erreur.

Solution: Assurez-vous que vous êtes en train de créer la syntaxe correctement. Voici un exemple de formule bien construite qui imbrouille une fonction SI dans une autre fonction SI pour calculer des déductions sur la base d’un niveau de revenu.

=SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%))

Exemple d’instruction SI bien construite

Autrement dit : SI la valeur de la cellule A5 est inférieure à 31 500, alors multiplier la valeur par 15%. Mais SI ce n’est pas le cas, vérifier que la valeur est inférieure à 72 500. SI c’est le cas, multiplier par 25%, sinon multiplier par 28%.

Pour utiliser SIERREUR avec une formule existante, il vous suffit de l’ajouter à cette formule :

=SIERREUR(SI(E2<31500,E2*15%,SI(E2<72500,E2*25%,E2*28%)),0)

Autrement dit, SI une partie quelconque de la formule d’origine génère une erreur, afficher 0, sinon renvoyer le résultat de l’instruction SI. Certaines personnes rédigent leurs formules en commençant par une fonction de gestion des erreurs, ce qui n’est pas recommandé car le Gestionnaire d’erreurs supprimera les erreurs potentielles, et vous ne saurez pas nécessairement si votre formule fonctionne correctement ou non. Si vous tenez à ajouter une fonction de gestion des erreurs, mieux vaut l’ajouter après vous être assuré que votre formule fonctionne correctement.

Remarque : Les valeurs d’évaluation des formules ne comportent pas de virgules. Si vous en ajoutez, la fonction SI tente de les utiliser en tant qu’arguments et Excel vous renvoie des erreurs. En revanche, les multiplicateurs de type pourcentage comportent le symbole %. Cela indique à Excel que vous souhaitez afficher ces valeurs sous forme de pourcentages. Sinon, vous devriez les entrer en tant que pourcentages réels, par exemple « E2*0,25 ».

Message Excel généré lors de l’ajout d’une virgule à une valeur

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Corriger une erreur #VALEUR! erreur

SI

SIERREUR

EST

Fonction SI.MICROSOFT 365 ou Excel 2016 ultérieure)

Fonction SI – Utiliser des formules imbriquées et éviter les pièges

Vidéo : Fonctions SI imbriquées

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Toutes les fonctions Excel (par ordre alphabétique)

Toutes les fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×