Créer une fusion de catalogue

Publisher offre la possibilité de se connecter à une source de données, telle qu’une base de données, une feuille de calcul ou même un fichier texte, et d’utiliser les données pour créer facilement un catalogue de vos produits ou services. Vous pouvez également utiliser la fusion de catalogue pour créer des répertoires, des albums photo ou tout autre type de composition qui affiche un ou plusieurs éléments sur chaque page.

Fonctionnement de la fusion de catalogue

La fusion de catalogue est similaire au publipostage. Lorsque vous utilisez la fusion de catalogue, vous créez une composition de modèle de fusion de catalogue, puis vous combinez le modèle avec les informations d’une source de données pour générer des pages fusionnées.

Source de données combinée à un modèle de fusion pour générer des pages du catalogue

1 Source de données avec des informations d’enregistrement, telles que des noms d’éléments et des descriptions.

2 Composition de modèle de fusion de catalogue avec zone de fusion de catalogue et champs de fusion qui sont des espaces réservé pour les informations d’enregistrement.

3 Pages fusionnées résultantes affichant plusieurs enregistrements par page.

Vous pouvez enregistrer la fusion de catalogue en tant que nouvelle composition ou l’ajouter à la fin d’une composition existante. Vous pouvez également enregistrer votre modèle de fusion de catalogue et le ré-utiliser, chaque fois que vous mettez à jour les informations dans votre source de données, pour créer d’autres ensembles de pages fusionnées.

Avant de commencer

Les conseils suivants vous aideront à créer une fusion de catalogue réussie :

  • Lancez la fusion du catalogue dans une nouvelle composition.

  • En plus des pages telles qu’une couverture, une table des matières et des formulaires de commande, vous devez avoir une page pour vos champs de fusion, même via votre catalogue, qui aura probablement plusieurs pages une fois que vous aurez créé le document de fusion.

  • Configurer le modèle de fusion de catalogue avec les dimensions de page que vous souhaitez pour vos pages fusionnées finales.

  • Si vous envisagez d’ajouter les pages fusionnées que vous créez à la fin d’une composition existante, assurez-vous que votre modèle de fusion de catalogue correspond à la composition existante des façons suivantes :

    • Taille de page (hauteur et largeur)

    • Affichage de page (page double ou double page)

    • Type de composition (web ou impression)

    • Ordre des pages (de gauche à droite ou de droite à gauche)

Haut de la page

Planifier votre catalogue

Avant de commencer la fusion de catalogue, réfléchissez au type d’informations que vous voulez répertorier dans les pages fusionnées finales.

  • Voulez-vous lister les noms et les prix des éléments ?

  • Voulez-vous inclure une description de chaque élément ?

  • Voulez-vous inclure une image de chaque élément ?

Planifier votre source de données

Après avoir choisi le type d’informations à inclure dans votre catalogue, vous pouvez créer la source de données à utiliser pour la fusion de catalogue. Si vous avez déjà une source de données, vous pouvez vous assurer qu’elle contient toutes les informations que vous voulez inclure dans la fusion.

La fusion de catalogue de Publisher peut utiliser divers formats de source de données. Si vous n’avez pas encore de source de données à utiliser pour votre fusion, vous pouvez en générer une dans Publisher. Vous pouvez également créer une source de données dans une feuille Microsoft Office Excel ou dans un Microsoft Office Word.

Les champs de données que vous incluez dans votre source de données correspondent aux champs de fusion que vous insérez dans votre modèle de fusion de catalogue.

Lorsque vous définissez votre source de données, créez une colonne pour chaque type d’informations, telle que le nom de l’article, le numéro de titre et le prix. Chaque ligne, ou enregistrement, correspond aux informations d’un élément.

Important  Assurez-vous que votre source de données inclut un champ de données ou une colonne pour chaque type d’informations que vous fusionnerez. Selon le type de votre source de données, vous pourrez peut-être apporter des modifications aux données après vous être connecté à ces données dans Publisher, mais il est préférable de finaliser les informations avant de commencer.

Si vous envisagez de fusionner des photos dans les pages de votre catalogue, vous devez inclure une colonne pour la chemin de chaque fichier image que vous prévoyez d’utiliser. N’incluez pas les images réelles dans votre source de données.

Si vous envisagez de créer votre source de données dans Publisher, vous pouvez le faire après avoir créé le modèle de composition.

Haut de la page

Créer une composition de modèle

Vous pouvez désormais créer votre composition de modèle de fusion de catalogue dans laquelle vous concevez la mise en page de vos pages fusionnées finales. Une fois la fusion terminée, vous utilisez ce modèle de fusion de catalogue pour générer des pages fusionnées que vous pouvez enregistrer en tant que nouvelle composition ou ajouter à la fin d’une composition existante.

Votre modèle de fusion de catalogue doit avoir la même disposition (taille et orientation de page) que celle que vous souhaitez pour vos pages fusionnées finales. Il doit également contenir le texte ou les graphismes que vous voulez voir apparaître sur chaque page de votre composition finale, par exemple, une image d’arrière-plan ou le nom et le numéro de téléphone de votre société. Il est préférable d’utiliser une page maître pour ces éléments du modèle de fusion.

Si vous envisagez d’ajouter vos pages fusionnées à la fin d’une composition existante, assurez-vous que votre modèle de fusion de catalogue correspond à la composition existante des façons suivantes :

  • Taille de page (hauteur et largeur)

  • Affichage de page (page double ou double page)

  • Type de composition (web ou impression)

  • Ordre des pages (de gauche à droite ou de droite à gauche)

Créer le modèle de fusion de catalogue

  1. Choisissez un modèle de composition approprié à votre catalogue.

  2. Sous l’onglet Insertion, cliquez sur Pages du catalogue.
    Démarrer la fusion des pages du catalogue

  3. Les pages de catalogue sont créées avec une zone de fusion de catalogue par défaut et l’onglet Outils de catalogue apparaît dans le ruban. Pour le moment,vous pouvez positionner la zone de fusion de catalogue comme vous le souhaitez sur la page et ajouter le texte ou les images que vous voulez voir apparaître sur chaque page de votre catalogue. Plus la zone de fusion est petite, plus les éléments du catalogue peuvent être fusionnés dans la page. Par exemple, une zone de fusion de 2"x2 » se répète plusieurs fois qu’une zone de fusion de 4"x4 ». Ne vous souciez pas trop de l’obtenir exactement comme vous pouvez revenir en arrière et modifier ces éléments à tout moment.

    Conseil  Ne configurez pas la zone de fusion de catalogue pour le moment, attendez qu’il soit temps d’insérer les champs de fusion et d’utiliser l’une des conceptions précontgurés de la galerie de dispositions.

Haut de la page

Se connecter à votre source de données

Après avoir formaté votre page de modèle de fusion de catalogue, l’étape suivante consiste à créer ou à localiser votre source de données et à la connecter. L’option que vous choisissez ensuite dépend du fait que vous avez déjà une source de données ou si vous souhaitez créer une liste dans Publisher.

  1. Dans l’onglet Outils de catalogue, cliquez sur Ajouter une liste, puis :

    • Sélectionnez Taper une nouvelle liste si vous avez besoin de créer la source de données pour votre fusion.

    • Cliquez sur Utiliser une liste existante si vous avez déjà une source de données que vous souhaitez utiliser.

    • Cliquez sur Sélectionner dans les contacts Outlook si vous voulez créer un annuaire de vos contacts.

Taper une nouvelle liste

  1. Dans la boîte de dialogue Nouvelle liste de produits, tapez les informations du premier élément ou enregistrement que vous voulez inclure dans votre catalogue.

    Si vous voulez ajouter ou supprimer des colonnes (par exemple, si vous n’avez pas inclus d’images), cliquez sur Personnaliser les colonnes, puis a apporter les modifications de votre souhaitez.

  2. Après avoir tapé toutes les informations de votre premier enregistrement, cliquez sur Nouvelle entrée, puis tapez les informations de l’enregistrement suivant. Continuez jusqu’à ce que vous avez tapé des informations pour tous les enregistrements que vous voulez inclure.

  3. Une fois votre nouvelle liste terminée, cliquez sur OK.

  4. Dans la boîte de dialogue Enregistrer la liste d’adresses, tapez un nom pour votre nouvelle liste, puis cliquez sur Enregistrer.

Utiliser une liste existante

  1. Dans la boîte de dialogue Sélectionner la source de données, recherchez la source de données de votre choix et cliquez dessus.

    Par défaut, Publisher enregistre les sources de données dans le dossier Mes sources de données. Vous devrez peut-être parcourir le dossier Mes sources de données pour localiser votre source de données.

  2. Cliquez sur Ouvrir.

    Selon le type de source de données que vous sélectionnez, d’autres boîtes de dialogue peuvent apparaître pour demander des informations spécifiques. Par exemple, si votre source de données est une feuille de calcul Excel contenant des informations sur plusieurs onglets, vous devez sélectionner l’onglet qui contient les informations que vous voulez, puis cliquer sur OK.

Faire une sélection dans les contacts Outlook

  1. Effectuez l’une des actions suivantes :

    • Dans la boîte de dialogue Sélectionner des contacts, cliquez sur la liste de contacts que vous voulez utiliser.

    • Dans la boîte de dialogue Choisir un profil, sélectionnez le profil correct pour les contacts que vous voulez utiliser.

  2. Cliquez sur OK.

Ajouter d’autres listes

Si vous voulez utiliser plusieurs listes dans la fusion de catalogue, vous pouvez ajouter des listes.

  1. Cliquez sur Modifier la liste, puis dans la liste des produits de fusion de catalogue, sous Ajouter à la liste de produits, cliquez sur Sélectionner une listeexistante, Sélectionner dans les contacts Outlook ou Taper une nouvelle liste.
    Publisher vous invite à corriger les différences entre les champs des différentes listes sources en ouvrant la boîte de dialogue Ajouter à la liste de produits.

  2. Dans la boîte de dialogue Ajouter à la liste de produits, sélectionnez un champ qui n’est pas coché dans la colonne Correspondance, sélectionnez le champ auquel vous souhaitez qu’il corresponde dans les champs de la liste de produits avec la liste des champs correspondants, puis cliquez sur Correspondance.

  3. Dans la boîte de dialogue Correspondance, vérifiez que le champ que vous avez sélectionné apparaît sous Faire correspondre un champ de liste de produits ou sélectionnez-en un autre, puis cliquez sur OK.

  4. Si vous avez besoin d’ajouter un nouveau champ à votre liste de destinataires pour faire une correspondance, sélectionnez le champ que vous voulez ajouter à la nouvelle liste (la liste de gauche dans la boîte de dialogue Ajouter à la liste de destinataires), cliquez sur Ajouter, puis sur OK.
    Les champs ajoutés s’afficheront sous Champs nouveaux à ajouter à la liste de destinataires

Sélectionnez les enregistrements à inclure

  1. Cliquez sur Modifier la liste.

  2. Dans la boîte de dialogue Liste des produits de fusion de catalogue, faites l’une des choses suivantes :

    • Cochez les cases en regard des enregistrements que vous voulez inclure, puis cochez les cases en regard des enregistrements que vous voulez exclure.

      Conseil  Si vous ne voulez inclure qu’un petit nombre d’enregistrements dans la liste, cliquez sur Effacer tout, puis sélectionnez les enregistrements de votre choix.

    • Filtrez votre liste sur la base d’un critère spécifique en cliquant sur la flèche en dessous de l’en-tête de colonne de l’élément sur qui vous souhaitez filtrer, puis en cliquant sur la valeur à utiliser comme filtre.

      • (Vides) affiche tous les enregistrements dans lesquels le champ correspondant est vide.

      • (Non-éléments) affiche tous les enregistrements dans lesquels le champ correspondant contient des informations.

        Remarque  Si votre source de données contient des enregistrements qui partagent les mêmes informations et qu’il y a au moins dix valeurs uniques dans la colonne, vous pouvez filtrer sur la base d’informations spécifiques. Par exemple, si votre source de données est une liste de propriétés à vendre et qu’il existe plusieurs enregistrements de propriétés qui indiquent Buffalo comme ville/emplacement, vous pouvez filtrer sur Buffalo.

        La boîte de dialogue Liste des produits de fusion de catalogue affiche uniquement les enregistrements désignés. Pour afficher de nouveau tous les enregistrements, cliquez sur (Tous).

    • Tiez les éléments de la liste en cliquant sur l’en-tête de colonne de l’élément par qui vous voulez trier. Par exemple, si vous voulez afficher la liste par ordre alphabétique par ville/emplacement, cliquez sur l’en-tête de colonne Ville/Emplacement.

  3. Cliquez sur OK.

Haut de la page

Insérer des champs de fusion

À présent, il est temps d’organiser les informations que vous voulez afficher dans votre composition. Pour mettre en page la page, vous devez ajouter des champs de fusion à la zone de fusion du catalogue. Chaque champ de fusion représente une colonne dans votre source de données, et la zone de fusion de catalogue affiche la façon dont les informations d’un enregistrement sont affichées.

Vous organisez la zone de fusion de catalogue comme vous le souhaitez, puis vous spécifiez le nombre de répétitions de la zone de fusion sur chaque page. Par exemple, vous pouvez afficher quatre éléments sur chaque page. Chaque élément s’affiche de la même façon, en fonction de la façon dont vous organisez la zone de fusion de catalogue. Vous pouvez ajuster la taille de chaque élément, ainsi que modifier la taille de la zone de fusion de catalogue.

Important   Si vous insérez des champs de fusion en dehors de la zone de fusion de catalogue, ils ne se répèteront pas lorsque vous terminerez votre fusion.

Sélectionner la disposition de la zone de fusion

  1. Dans le groupe Disposition, faites l’une des choses suivantes :

    • Faites votre choix parmi l’une des galeries de conception précont choisies.
      Options de disposition de la fusion de catalogue

    • Sélectionnez le nombre de lignes et de colonnes sur chaque page dans la série de colonnes et lignes.
      Lignes et colonnes de la disposition de page du catalogue

Insérer des champs de fusion de texte dans la zone de fusion du catalogue

  1. Cliquez sur le bouton Champ de texte, puis sur le premier champ de fusion à insérer.
    Insérer des champs de texte dans une fusion de catalogue

  2. Dans la zone de fusion du catalogue, sélectionnez le champ de fusion, puis déplacez et reizez le champ de fusion comme suit :

    • Pour déplacer le champ de fusion, positionnez le pointeur de la souris sur le champ de fusion jusqu’à ce qu’il se transforme en Pointeur de déplacement de pointeur de déplacement, puis faites glisser le champ de fusion vers une nouvelle position.

    • Pour recadrage du champ de fusion, positionnez le pointeur de la souris sur l’une des poignées de re dimensionnement de la zone de texte ou du cadre de l’image jusqu’à ce que le pointeur se transforme en Déplacer les pointeurs de règle , puis faites glisser la souris jusqu’à ce que la zone de texte ou le cadre de l’image soit de la taille que vous souhaitez.

  3. Cliquez en dehors du champ de fusion afin qu’il ne soit plus sélectionné.

  4. Répétez les étapes 1 à 3 jusqu’à ce que tous les champs de votre source de données soient insérés.

Important   Les champs sont insérés au point d’insertion actuel (curseur clignotant le point d’insertion). S’il n’y a pas de point d’insertion, une nouvelle zone de texte est créée et le champ de fusion placé dans cette nouvelle zone de texte.

Mise en forme des champs de fusion de texte

Vous pouvez formater les données de catalogue fusionnées en formatant les champs de fusion dans votre modèle de fusion de catalogue. Ces champs peuvent être traités comme n’importe quelle zone de texte, et vous pouvez inclure du texte et une mise en forme non fusionnés, ainsi que les éléments fusionnés.

  1. Dans le modèle de fusion de catalogue, sélectionnez le champ contenant les informations que vous voulez mettre en forme, y compris les caractères de champ de fusion environnants (« ».

  2. Sous l’onglet Outils de zone de texte, sélectionnez les options de votre choix.

Insérer des champs de fusion d’images dans la zone de fusion du catalogue

  1. Cliquez sur le bouton Champ image, puis sur le premier champ de fusion à insérer.

  2. Dans la zone de fusion du catalogue, sélectionnez le champ de fusion, puis déplacez et reizez le champ de fusion comme suit :

    • Pour déplacer le champ de fusion, positionnez le pointeur de la souris sur le champ de fusion jusqu’à ce qu’il se transforme en Curseur de déplacement de pointeur de déplacement, puis faites glisser le champ de fusion vers une nouvelle position.

    • Pour recadrage du champ de fusion, positionnez le pointeur de la souris sur l’une des poignées de la zone de texte ou du cadre de l’image jusqu’à ce que le pointeur se transforme en Curseur de redimensionnement , puis faites glisser la souris jusqu’à ce que la zone de texte ou le cadre de l’image soit de la taille que vous souhaitez.

  3. Cliquez en dehors du champ de fusion afin qu’il ne soit plus sélectionné.

  4. Répétez les étapes 1 à 3 jusqu’à ce que tous les champs de votre source de données soient insérés.

Important   Les champs sont insérés au point d’insertion actuel (curseur clignotant le point d’insertion). S’il n’y a aucun point d’insertion, une nouvelle zone de texte est créée et le champ de fusion placé dans cette nouvelle zone de texte.

Déplacer ou reorganiser la zone de fusion de catalogue

Si vos champs de fusion formatés ne s’intègrent plus dans la zone de fusion du catalogue, vous pouvez les resizer.

Remarque  Si vous augmentez la taille, vous devrez peut-être ajuster moins d’éléments ou d’enregistrements à chaque page.

  1. Cliquez sur la zone de fusion de catalogue pour la sélectionner.

  2. Positionnons le pointeur de la souris sur l’une des poignées de la zone de fusion de catalogue, puis faites glisser la souris.

  3. Spécifiez le nombre d’éléments qui doivent apparaître sur chaque page en tapant les nombres voulus pour les éléments dans la page et sur la barre d’outils Fusion de catalogue.

Terminer et afficher un aperçu du modèle

  1. Cliquez sur Aperçu des résultats.

  2. Cliquez sur les flèches pour afficher chaque page de données fusionnées.
    Groupe d’aperçu du catalogue

    Si vous décidez de ne pas inclure un élément, cliquez sur l’élément prévisualisation, puis cliquez sur Exclure l’entrée dans le groupe Page d’aperçu.

Haut de la page

Terminer, imprimer et enregistrer la composition de votre catalogue

Pour terminer la fusion, trois options s’offrent à vous :

  • Vous pouvez imprimer votre composition fusionnée directement.

  • Vous pouvez créer et imprimer une composition qui contient le contenu fusionné. Vous pouvez apporter des modifications au contenu de cette composition comme vous le feriez pour toute autre composition dans Publisher.

Conseil  Si vous voulez inclure plusieurs fusions de catalogue dans une composition, vous devez créer une nouvelle composition pour les pages fusionnées car il ne peut y avoir qu’un seul ensemble de pages de catalogue par composition.

  • Vous pouvez ajouter le contenu fusionné à une composition existante.

Si vous voulez ajouter une couverture avant et arrière à votre composition, ou si vous voulez ajouter d’autres pages, vous devez créer une composition ou ajouter votre contenu à une composition existante.

Fusionner vers une nouvelle composition

Si vous souhaitez modifier vos pages fusionnées, les enregistrer pour une utilisation ultérieure ou les imprimer ultérieurement, vous pouvez collecter et enregistrer toutes vos pages fusionnées en tant que nouvelle composition fusionnée qui contient les données réelles (par exemple, les noms et les prix des produits) au lieu des champs de fusion.

  1. Dans le groupe Fusionner, cliquez sur Fusionner vers Nouveau.
    Fusion de catalogue vers nouvelle composition Publisher
    crée une composition que vous pouvez enregistrer et modifier. Vous pouvez même ajouter des pages de couverture avant et arrière.
    Remarque Si vous envisagez d’imprimer votre catalogue sous forme de livret, assurez-vous que le nombre total de pages est un multiple de quatre.

  2. Dans le volet Tâches de fusion de catalogues, cliquez sur Enregistrer cette composition.

  3. Dans la zone Nom de fichier, tapez un nom pour votre nouvelle composition, puis cliquez sur Enregistrer.

  4. Si nécessaire, enregistrez également les modifications apportées à votre modèle de fusion de catalogue. Vous pouvez utiliser ce modèle de fusion de catalogue à nouveau pour créer des pages fusionnées supplémentaires chaque fois que vous mettez à jour les informations dans votre source de données.

Ajouter à une composition existante

Si vous avez déjà vos couvertures dans une composition distincte, ou si vous souhaitez que le catalogue soit placé à la fin d’une composition plus longue, vous pouvez ajouter votre contenu fusionné directement.

Avant d’ajouter vos pages fusionnées à la fin d’une composition existante, assurez-vous que votre modèle de fusion de catalogue correspond à la composition existante des façons suivantes :

  • Taille de page (hauteur et largeur)

  • Affichage de page (page double ou double page)

  • Type de composition (web ou impression)

  • Ordre des pages (de gauche à droite ou de droite à gauche)

Remarque  Publisher ne peut pas ajouter de pages fusionnées à une composition ouverte. Si vous travaillez sur la composition dans laquelle vous voulez fusionner, veillez à enregistrer et à fermer celle-ci avant de terminer la fusion.

  1. Dans le groupe Fusionner, cliquez sur Ajouter à existant.
    Fusion de catalogue vers composition existante

  2. Dans la boîte de dialogue Ouvrir la composition, recherchez et sélectionnez la composition à laquelle vous voulez ajouter les pages fusionnées, puis cliquez sur Ouvrir.

    Publisher ajoute les pages fusionnées à la fin de la composition existante.

    Conseil  Pour réorganiser les pages de votre composition mise à jour, cliquez sur une page que vous voulez déplacer dans le volet de navigation de page, puis faites-la glisser vers l’emplacement de votre choix.

  3. Dans la composition existante, cliquez sur Enregistrer pour enregistrer vos mises à jour.

  4. Si nécessaire, enregistrez également les modifications apportées à votre modèle de fusion de catalogue. Vous pouvez utiliser ce modèle de fusion de catalogue à nouveau pour créer des pages fusionnées supplémentaires chaque fois que vous mettez à jour les informations dans votre source de données.

Imprimer votre composition fusionnée

  • Dans le groupe Fusionner, cliquez sur Imprimer.
    Fusion de catalogue vers l’imprimante

    Publisher ouvre la page d’impression en affichage Arrière-page.

Haut de la page

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×