Conseil : Essayez d’utiliser la nouvelle fonction XLOOKUP, une version améliorée de RECHERCHEV qui fonctionne dans n’importe quelle direction et renvoie des correspondances exactes par défaut, ce qui rend plus pratique et facilite son utilisation par rapport à son prédécesseur.

Utilisez la fonction RECHERCHEV lorsque vous devez rechercher des éléments dans une table ou une plage par ligne. Par exemple, recherchez le prix d'une pièce automobile via le numéro de pièce ou recherchez le nom d'un employé en fonction de son identification d'employé.

Dans sa forme la plus simple, la fonction RECHERCHEV a la signification suivante :

=RECHERCHEV(Ce que vous voulez rechercher, où vous voulez le rechercher, le numéro de colonne dans la plage contenant la valeur à renvoyer, renvoyer une correspondance approximative ou exacte, indiquée comme 1/VRAI ou 0/FAUX).

Votre navigateur ne prend pas en charge la vidéo. Installez Microsoft Silverlight, Adobe Flash Player ou Internet Explorer 9.

Conseil : Pour tirer le meilleur parti de la fonction RECHERCHEV, il convient d’organiser vos données afin que la valeur que vous recherchez (numéro de référence) se trouve à gauche de la valeur de retour à rechercher (prix de la pièce).

Utilisez la fonction RECHERCHEV pour rechercher une valeur dans une table.

Syntaxe 

RECHERCHEV(valeur_cherchée;table_matrice;no_index_col;[valeur_proche])

Par exemple :

  • =RECHERCHEV(A2,A10:C20,2,VRAI)

  • =RECHERCHEV("Fontana";B2:E7;2;FAUX)

  • =RECHERCHEV(A2,'Détails du client'! A:F,3,VRAI)

Argument

Description

valeur_cherchée    (obligatoire)

Valeur que vous voulez rechercher. La valeur que vous voulez rechercher doit apparaître dans la première colonne de la plage de cellules que vous spécifiez dans l’argument table_matrice.

Par exemple, si l’argument table_matrice englobe les cellules de la plage B2:D7, l’argument valeur_recherchée doit se trouver dans la colonne B.

L’argument valeur_cherchée peut être une valeur ou une référence à une cellule.

table_matrice    (obligatoire)

Plage de cellules dans laquelle la fonction RECHERCHEV recherche l’argument valeur_cherchée et la valeur de retour. Vous pouvez utiliser une plage nommée ou une table, et vous pouvez utiliser des noms dans l’argument au lieu de références de cellule. 

La première colonne de la plage de cellules doit contenir l’argument valeur_recherchée. La plage de cellules doit également contenir la valeur de renvoi que vous recherchez.

Découvrez comment sélectionner des plages dans une feuille de calcul.

no_index_col    (obligatoire)

Numéro de colonne (la colonne la plus à gauche du table_matrice correspondant à 1) qui contient la valeur de renvoi.

valeur_proche   (facultatif)

Représente une valeur logique indiquant si vous souhaitez que la fonction RECHERCHEV recherche une correspondance exacte ou approximative :

  • Correspondance approximative : 1/VRAI suppose que la première colonne de la table est triée par ordre alphabétique ou numérique et recherche dès lors la valeur la plus proche. Cette méthode est appliquée par défaut si vous n’en spécifiez pas d’autre. Par exemple, =RECHERCHEV(90,A1:B100,2,VRAI).

  • Correspondance exacte : 0/FAUX recherche la valeur exacte dans la première colonne. Par exemple, =RECHERCHEV(« Smith »,A1:B100,2,FAUX).

Prise en main

Quatre types d’informations sont nécessaires pour définir la syntaxe de la fonction RECHERCHEV :

  1. La valeur que vous voulez rechercher (également appelée valeur de recherche).

  2. La plage dans laquelle se trouve la valeur recherchée. N’oubliez pas que la valeur recherchée doit toujours apparaître dans la première colonne de la plage pour que RECHERCHEV fonctionne correctement. Par exemple, si la valeur recherchée est dans la cellule C2, votre plage doit commencer par C.

  3. Le numéro de colonne dans la plage qui contient la valeur de retour. Par exemple, si vous spécifiez la plage B2: D11, vous devez compter B comme la première colonne, C comme la deuxième, etc.

  4. Vous pouvez aussi spécifier VRAI pour obtenir une correspondance approximative ou FAUX pour obtenir une correspondance exacte de la valeur de retour. Si vous n’indiquez rien, la valeur par défaut sera toujours VRAI ou une correspondance approximative.

Vous devez à présent définir tous les éléments ci-dessus comme suit :

=RECHERCHEV(valeur recherchée; plage contenant la valeur recherchée; numéro de colonne dans la plage contenant la valeur de renvoi; correspondance approximative (VRAI) ou correspondance exacte (FAUX)).

Exemples

Voici quelques exemples supplémentaires d’utilisation de le fonction RECHERCHEV :

Exemple 1

=RECHERCHEV (B3,B2:E7,2,FAUX)

RECHERCHEV recherche Fontana dans la première colonne (colonne B) de la table_matrice B2:E7 et renvoie Olivier à partir de la deuxième colonne (colonne C) de la table_matrice.  FAUX retourne une correspondance exacte.

Exemple 2

=RECHERCHEV (102,A2:C7,2,FAUX)

RECHERCHEV recherche une correspondance exacte (FAUX) du nom de famille pour 102 (valeur_recherche) dans la deuxième colonne (colonne B) dans la plage A2:C7, et retourne Fontana.

Exemple 3

=SI(RECHERCHEV(103,A1:E7,2,FAUX)="Sousa","Localisé »,"Introuvable")

SI vérifie si RECHERCHEV renvoie Sousa en tant que nom de famille de l’employé correspondant à 103 (valeur_recherche) dans A1:E7 (table_matrice). Étant donné que le nom correspondant à 103 est Leal, la condition SI est FAUX et « Introuvable » s’affiche.

Exemple 4

=ENT(FRACTION.ANNEE(DATE(2014,6,30),RECHERCHEV(105,A2:E7,5,FLASE),1))



RECHERCHEV recherche la date de naissance de l’employé correspondant à 109 (valeur_recherche) dans la plage A2:E7 (table_matrice) et retourne le 04/03/1955. Ensuite, FRACTION.ANNEE soustrait cette date de naissance de 2014/6/30 et retourne une valeur, qui est ensuite convertie par ENT en entier 59.

Exemple 5

SI(ESTNA(RECHERCHEV(105,A2:E7,2,FLASE))=VRAI,"Employé introuvable",RECHERCHEV(105,A2:E7,2,FAUX))



SI vérifie si RECHERCHEV renvoie une valeur pour le nom de la colonne B pour 105 (lvaleur_recherche). Si RECHERCHEV trouve un nom de famille, alors SI affiche le nom, sinon SI retourne « Employé introuvable ». ESTNA s’assure que si RECHERCHEV renvoie #N/A, l’erreur est remplacée par Employé introuvable, au lieu de #N/A.



Dans cet exemple, la valeur de retour est Burke, qui est le nom correspondant à 105.

Vous pouvez utiliser RECHERCHEV pour combiner plusieurs tables en une seule, tant que l’une des tables a des champs en commun avec toutes les autres. Cela peut être particulièrement utile si vous devez partager un classeur avec des personnes ayant des versions antérieures de Excel qui ne prennent pas en charge les fonctionnalités de données avec plusieurs tables en tant que sources de données. En combinant les sources dans une table et en remplaçant la source de données de la fonctionnalité de données par la nouvelle table, la fonctionnalité de données peut être utilisée dans les versions plus anciennes Excel (à condition que la fonctionnalité de données elle-même soit prise en charge par l’ancienne version).

Feuille de calcul avec des colonnes qui utilisent RECHERCHEV pour obtenir des données à partir d’autres tables

Ici, les colonnes A-F et H ont des valeurs ou des formules qui utilisent uniquement des valeurs dans la feuille de calcul, et les autres colonnes utilisent RECHERCHEV et les valeurs des colonnes A (Code client) et B (Attorney) pour obtenir des données à partir d’autres tables.

  1. Copiez la table qui contient les champs communs dans une nouvelle feuille de calcul et donnez-lui un nom.

  2. Cliquez sur Données > Outils de données > Relations pour ouvrir la boîte de dialogue Gérer les relations.

    Boîte de dialogue Gérer les relations
  3. Pour chaque relation répertoriée, notez les points suivants :

    • Champ qui lie les tables (répertoriées entre parenthèses dans la boîte de dialogue). Il s’agit de la valeur_recherchée de votre formule RECHERCHEV.

    • Nom de la table de recherche associée. Il s’agit de la table_matrice dans votre formule RECHERCHEV.

    • Champ (colonne) de la table de recherche associée qui contient les données souhaitées dans votre nouvelle colonne. Ces informations ne sont pas affichées dans la boîte de dialogue Gérer les relations. Vous devez examiner la table de recherche associée pour voir quel champ vous souhaitez récupérer. Vous souhaitez noter le numéro de colonne (A=1) : il s’agit de col_index_num dans votre formule.

  4. Pour ajouter un champ à la nouvelle table, entrez votre formule RECHERCHEV dans la première colonne vide à l’aide des informations que vous avez collectées à l’étape 3.

    Dans notre exemple, la colonne G utilise Attorney (valeur_recherchée) pour obtenir les données de taux de facturation de la quatrième colonne (col_index_num = 4) du tableau de la feuille de calcul Attorneys, tblAttorneys (table_matrice), avec la formule =RECHERCHEV([@Attorney],tbl_Attorneys,4,FALSE).

    La formule peut également utiliser une référence de cellule et une référence de plage. Dans notre exemple, il s’agit de =RECHERCHEV(A2,'Attorneys'! A:D,4,FAUX).

  5. Continuez à ajouter des champs jusqu’à ce que vous ayez tous les champs dont vous avez besoin. Si vous essayez de préparer un classeur contenant des fonctionnalités de données qui utilisent plusieurs tables, remplacez la source de données de la fonctionnalité de données par la nouvelle table.

Problème

Cause

Valeur incorrecte renvoyée

Si valeur_proche a la valeur VRAI ou est omis, la première colonne doit être triée par ordre alphabétique ou numérique. Si la première colonne n’est pas triée, la valeur de retour peut être une valeur inattendue. Triez la première colonne, ou utilisez FAUX pour une correspondance exacte.

#N/A dans la cellule

  • Si l’argument valeur_proche est VRAI, la valeur de l’argument valeur_cherchée est inférieure à la plus petite valeur dans la première colonne de table_matrice, vous obtiendrez #N/A.

  • Si valeur_proche est FAUX, la valeur d’erreur #N/A indique que le nombre exact est introuvable.

Pour plus d’informations sur la résolution des erreurs #N/A dans RECHERCHEV, voir Correction d’une erreur #N/A dans la fonction RECHERCHEV.

#REF! dans la cellule

Si l’argument no_index_col est supérieur au nombre de colonnes dans table_matrice, la valeur #REF! apparaît. renvoie la valeur d’erreur.

Pour plus d’informations sur la résolution des erreurs #VALEUR! erreurs dans RECHERCHEV, voir comment corriger une #REF ! erreur.

#VALEUR! dans la cellule

Si l’argument table_matrice est inférieur à 1, #VALEUR! apparaît. renvoie la valeur d’erreur.

Pour plus d’informations sur la résolution des erreurs #VALEUR! dans RECHERCHEV, voir Correction d’une erreur #VALEUR! dans la fonction RECHERCHEV.

#NOM? dans la cellule

La valeur d’erreur #NOM? signifie généralement qu’il manque des guillemets dans la formule. Pour rechercher le nom d’une personne, veillez à entourer le nom de guillemets dans la formule. Par exemple, entrez le nom sous la forme "Fontana" dans la formule =RECHERCHEV("Fontana";B2:E7;2;FAUX).

Pour plus d’informations, voir Comment corriger une erreur #NOM ?.

#SPILL ! dans la cellule

Cette erreur #SPILL! particulière signifie généralement que votre formule s’appuie sur une intersection implicite pour la valeur de recherche et utilise une colonne entière comme référence. Par exemple, =RECHERCHEV(A:A,A:C,2,FAUX). Vous pouvez résoudre le problème en ancrer la référence de recherche avec l’opérateur @ comme suit : =RECHERCHEV(@A:A,A:C,2,FAUX). Vous pouvez également utiliser la méthode RECHERCHEV traditionnelle et faire référence à une cellule unique au lieu d’une colonne entière : =RECHERCHEV(A2,A:C,2,FAUX).

Procédez comme suit

Pourquoi

Utilisez des références absolues pour l’argument valeur_proche.

L’utilisation des références absolues permet de recopier vers le bas une formule afin qu’elle recherche toujours la même plage de recherche exacte.

Découvrez comment utiliser les références de cellules absolues.

Ne stockez pas les valeurs numériques ou les dates sous forme de texte.

Si vous cherchez un nombre ou une date, vérifiez que les données de la première colonne de table_matrice ne sont pas enregistrées comme des valeurs texte. Si c’est le cas, il se peut que RECHERCHEV renvoie des valeurs incorrectes ou inattendues.

Triez la première colonne.

Triez la première colonne de table_matrice avant d’utiliser RECHERCHEV lorsque l’argument valeur_proche a la valeur VRAI.

Utilisez des caractères génériques.

Sivaleur_cherchéeest FAUSSE et lavaleur_cherchéereprésente une chaîne de texte, vous pouvez utiliser les caractères génériques, à savoir l’astérisque (*) et le point d’interrogation (?), dans l’argumentvaleur_cherchée. Un point d’interrogation correspond à un caractère quelconque. Un astérisque correspond à une séquence de caractères. Si vous recherchez un point d’interrogation ou un astérisque, tapez un tilde (~) devant ce caractère.

Par exemple, =RECHERCHEV("Fontan?",B2:E7,2,FAUX) recherche toutes les instances de Fontana avec une dernière lettre pouvant varier.

Vérifiez que vos données ne contiennent pas des caractères erronés.

Si vous cherchez des valeurs textuelles dans la première colonne, vérifiez que les données de la première colonne sont exemptes de tout espace d’en-tête, espace de fin, caractère non imprimable et que vous ne remarquez aucune utilisation incohérente des guillemets ou apostrophes droits (’ ou ") et courbes (‘ ou “). Si c’est le cas, il se peut que RECHERCHEV renvoie des valeurs incorrectes ou inattendues.

Pour obtenir des résultats précis, essayez d’utiliser la fonction EPURAGE ou la fonction SUPPRESPACE pour supprimer les espaces de fin après les valeurs de la table dans une cellule.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Carte de référence rapide : actualisateur RECHERCHEV
Carte de référence rapide : Conseils de dépannage RECHERCHEV
Comment corriger une erreur #VALUE! dans la fonction RECHERCHEV
Comment corriger une erreur #VALEUR! dans la fonction RECHERCHEV
Vue d’ensemble des formules dans Excell
Comment éviter les formules endommagées
Détecter les erreurs dans les formules
les fonctions Excel (alphabétique)
les fonctions Excel (par catégorie)
RECHERCHEV (aperçu gratuit)

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×