Vous pouvez modifier les propriétés d’une plage de données externes pour contrôler les données importées dans une feuille de calcul via une connexion à une source de données externe, telle qu’une base de données, une requête web ou un fichier texte.

Une plage de données externes est un nom défini ou un nom de table qui définit l’emplacement des données qui sont apportées à une feuille de calcul. Lorsque vous vous connectez à des données externes, Excel crée automatiquement une plage de données externes. La seule exception à ceci est un rapport de tableau croisé dynamique connecté à une source de données : un rapport de tableau croisé dynamique n’utilise pas de plage de données externe. Dans Excel, vous pouvez mise en forme et mise en forme une plage de données externe, ou l’utiliser dans des calculs, comme pour toute autre donnée.

Propriétés de plage de données externes

Une plage de données externes a des propriétés supplémentaires (à ne pas confondre avec les propriétés de requête ou de connexion) que vous pouvez utiliser pour contrôler les données, telles que la conservation de la mise en forme des cellules et de la largeur des colonnes. Vous pouvez modifier ces propriétés de plage de données externes en cliquant sur Propriétés dans le groupe Connexions sous l’onglet Données. A apporter les modifications suivantes :

  • Pour les plages de données externes créées à partir de Microsoft Query et de l’Assistant Connexion de données, utilisez la boîte de dialogue Propriétés des données externes.

  • Pour les plages de données externes créées à partir d’un fichier texte importé ou d’une requête web qui extrait des données HTML, utilisez la boîte de dialogue Propriétés de la plage de données externes.

  • Pour les plages de données externes créées à partir d’une requête web qui récupère des données XML, utilisez la boîte de dialogue Propriétés de map page XML.

  1. Sélectionnez la feuille de calcul dans laquelle vous souhaitez rechercher une plage de données externes.

  2. Dans la barre de formule, cliquez sur la flèche en côté de la zone Nom,puis sur le nom de la plage de données externes de votre choix.

  1. Sélectionnez Formules > Gestionnaire de noms.

  2. Dans la boîte de dialogue Gestionnaire de noms, cliquez sur le nom de la plage de données externe, puis cliquez sur Modifier. Vous pouvez également double-cliquer sur le nom.

  3. Dans la boîte de dialogue Modifier le nom, tapez le nouveau nom de la référence dans la zone Nom.

Remarque : Le bouton Fermer ferme uniquement la boîte de dialogue Gestionnaire de noms. Vous n’avez pas besoin de cliquer sur Fermer pour valider des modifications que vous avez déjà apportées.

Vous pouvez modifier la requête sous-jacente pour une plage de données externes créée à partir de Microsoft Query, d’un fichier texte importé, d’une requête web ou de l’Assistant Connexion de données.

  1. Cliquez sur une cellule dans la plage de données externes pour laquelle vous souhaitez modifier la requête sous-jacente.

  2. Sélectionnez Données > Propriétés.

  3. Dans la boîte de dialogue Propriétés des données externes, cliquez sur Propriétés de connexion Image du bouton .

  4. Dans la boîte de dialogue Propriétés de la connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

Pour plus d’informations sur la conception et la modification de requêtes dans Microsoft Query, voir l’aide de Microsoft Query.

  1. Cliquez sur une cellule dans la plage de données externes pour laquelle vous souhaitez modifier la requête sous-jacente.

  2. Sélectionnez Données> connexions & requêtes>'onglet Connexions, cliquez avec le bouton droit sur la connexion de votre choix, puis sélectionnez Propriétés.

  3. Dans la boîte de dialogue Propriétés de la connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

  4. Dans la boîte de dialogue Importer un fichier texte, cliquez sur Importer.

  5. Modifiez le fichier texte importé dans l’Assistant Importation de texte, puis cliquez sur Terminer.

    Pour plus d’informations sur l’importation de fichiers texte, voir Importer ou exporter des fichiers texte.

  1. Cliquez sur une cellule dans la plage de données externes pour laquelle vous souhaitez modifier la requête sous-jacente.

  2. Sélectionnez Données> Propriétés.

  3. Sélectionnez Données> connexions & requêtes>'onglet Connexions, cliquez avec le bouton droit sur la connexion de votre choix, puis sélectionnez Propriétés.

  4. Dans la boîte de dialogue Propriétés de la connexion, cliquez sur l’onglet Définition, puis sur Modifier la requête.

  5. A apporter des modifications à la requête web dans la boîte de dialogue Modifier la requête web, puis cliquez sur Terminer.

Pour plus d’informations sur la création et la modification de requêtes web, voir Connecter sur une page web.

  1. Cliquez sur une cellule dans la plage de données externes pour laquelle vous souhaitez modifier la requête sous-jacente.   

  2. Sélectionnez Données> Propriétés.

  3. Dans la boîte de dialogue Propriétés des données externes, cliquez sur Propriétés de connexion Image du bouton .

  4. Dans la boîte de dialogue Propriétés de la connexion, cliquez sur l’onglet Définition.

  5. Effectuez l’une des actions suivantes :

    • Dans la zone Type de commande, cliquez sur Table, puis, dans la zone de texte Commande, modifiez la valeur en nom de table, d’affichage ou de requête approprié.

    • Dans la zone Type de commande, cliquez sur SQL ou Par défaut, puis, dans la zone de texte Commande, modifiez l SQL de commande.

      Remarque : Selon la manière dont la connexion a été définie, il est possible que la zone de type Commande ne soit pas disponible (elle apparaît grisée).

  1. Dans la barre de formule, cliquez sur la flèche en côté de la zone Nom,puis sélectionnez le nom de la plage de données externes à copier.

    Pour une Excel tableau, sélectionnez le nom de la plage, puis appuyez sur Ctrl+A pour sélectionner les en-têtes de tableau.

    Si vous voulez inclure des étiquettes de colonnes ou des formules qui ne font pas partie de la plage de données externe, sélectionnez les cellules qui contiennent les étiquettes de colonnes ou les formules à copier. Cliquez sur la flèche en haut de la zone Nom de la barre de formule, puis sur le nom de la plage de données externes à copier.

  2. Sélectionnez Accueil > Copier.

  3. Basculez vers le workbook dans lequel vous voulez coller la plage de données externe.

  4. Cliquez sur la cellule supérieure gauche de la zone de collage.

    Pour vous assurer que la données externes ne remplace pas les données existantes, assurez-vous que la feuille de calcul ne possède aucune donnée sous ou à droite de la cellule sur qui vous cliquez.

  5. Sous l’onglet Accueil, dans le groupe Presse-papiers, cliquez sur Coller.

Remarque : Si vous copiez uniquement une partie d’une plage de données externe, la requête sous-jacente n’est pas copiée et les données copiées ne peuvent pas être actualisées.

Vous pouvez contrôler la façon de traiter un jeu de données plus petit ou plus grand qui est renvoyé à Excel l’actualisation des données.

  1. Sélectionnez Données> Propriétés.

  2. Dans la boîte de dialogue Propriétés de la plage de données externes,sous Si le nombre de lignes dans la plage de données change après actualisation, cliquez sur l’une des informations suivantes :

    • Insérer des cellules pour les nouvelles données, supprimer les cellules inutilisées

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées dans la source de données, les cellules se déplacent directement sous la plage de données externe vers le bas, mais les cellules à droite de la plage de données externes ne se déplacent pas.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules directement sous la plage de données externe monter, mais les cellules à droite de la plage de données externe ne se déplacent pas.

    • Insérer des lignes entières pour les nouvelles données, effacer les cellules inutilisées

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées dans la source de données, les cellules directement en dessous et à droite de la plage de données externe se déplacent vers le bas.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules directement sous et à droite de la plage de données externe ne se déplacent pas.

    • Overwrite existing cells with new data, clear unused cells

      Remarques : 

      • Lorsqu’une ou plusieurs lignes sont ajoutées dans la source de données, les cellules directement sous la plage de données externe sont écrasées, mais les cellules à droite de la plage de données externes ne se déplacent pas.

      • Lorsqu’une ou plusieurs lignes sont supprimées de la source de données, les cellules directement sous et à droite de la plage de données externe ne se déplacent pas.

  1. Sélectionnez Données> Propriétés.

  2. Sous Mise en forme et disposition des données,faites une ou plusieurs des choses suivantes :

    • Pour inclure les noms de champs comme première ligne, cochez la case Inclure les noms de champs.

      Remarque : Cette case à cocher est disponible uniquement pour une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou en une plage de données externes créée par programme.

    • Pour ajouter une colonne de numéros de lignes, cochez la case Inclure les numéros de ligne.

      Remarque : Cette case à cocher n’est pas disponible pour un fichier texte importé, un fichier XML ou une requête web.

    • Pour conserver la mise en forme de cellule que vous appliquez, cochez la case Conserver la mise en forme des cellules.

      Remarque : Pour une requête web, cette option est automatiquement effacée lorsque vous sélectionnez Mise en forme HTML complète dans la boîte de dialogue Options. Vous accédez à la boîte de dialogue Options à partir de la boîte de dialogue Modifier la requête.

    • Pour conserver la largeur des colonnes que vous définissez, cochez la case Ajuster la largeur de colonne.

    • Pour conserver le tri, le filtrage et la disposition des colonnes que vous appliquez, cochez la case Conserver le tri, le filtre ou la disposition des colonnes.

      Remarque : Cette case à cocher n’est pas disponible pour une requête web.

    • Pour conserver le filtrage de colonne que vous appliquez, cochez la case Conserver le filtre de colonne.

      Remarque : Cette case à cocher est disponible uniquement pour une requête web basée sur des données XML.

Remarque : La procédure suivante s’applique uniquement à une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou à une plage de données externes créée par programme. Toutes les plages de données externes créées à l’aide de l’interface utilisateur sont créées Excel tables. Ces tableaux sont développés automatiquement lorsque de nouvelles lignes sont ajoutées et remplissent des colonnes calculées vers le bas.

  1. Entrez une formule dans une cellule adjacente à la première ligne de données de la plage de données externe.

    Remarque : La première ligne de données peut être la première ou la deuxième ligne de la plage de données externe, selon que la première ligne contient ou non des en-têtes.

  2. Sélectionnez la cellule, puis double-cliquez sur la poignée de recopie pour copier la formule dans toutes les lignes de la plage de données externes.

  3. Cliquez sur une cellule de la plage de données externes.

  4. Sélectionnez Données> Propriétés.

  5. Dans la boîte de dialogue Propriétés de la plage de données externes, cochez la case Remplir les formules dans les colonnes adjacentes aux données.

    Remarque : Si la plage de données externes s’étend lorsque actualiser, Excel copie uniquement les formules qui sont immédiatement adjacentes à la plage de données externe ou à l’intérieur de celle-ci.

Le fait de figer une plage de données externes conserve les données, mais pas leur requête sous-jacente, de sorte qu’une plage de données externes figée ne peut pas être actualisée.

  1. Cliquez sur la feuille de calcul contenant Excel table à partir de laquelle vous souhaitez supprimer la connexion de données.

  2. Dans la barre de formule, cliquez sur la flèche en côté de la zone Nom,puis sur le nom de la plage de données externes à partir de laquelle vous voulez supprimer la connexion de données. La plage de données est ensuite sélectionnée.

  3. Sous l’onglet Outils, dans le groupe Données de la table externe, cliquez sur Dissocier. La plage de données continue d’porte le même nom, mais la connexion est supprimée.

Remarque : La procédure suivante s’applique uniquement à une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou à une plage de données externes créée par programme. Toutes les plages de données externes créées à l’aide de l’interface utilisateur sont créées Excel tables. Ces tableaux sont développés automatiquement lorsque de nouvelles lignes sont ajoutées et remplissent des colonnes calculées vers le bas.

  1. Sélectionnez Données> Propriétés.

  2. Sous Définition de requête,désochez la case Définition de la requête Enregistrer.

Remarque : Lorsque vous enregistrez votre fichier, la requête sous-jacente est supprimée du fichier. Toutefois, les fichiers de requête de base de données enregistrés (fichiers .dqy ou .odc) ne sont pas supprimés. Si vous avez enregistré la requête lorsque vous l’avez créée dans l’Assistant Requête ou dans Microsoft Query, le fichier de requête est enregistré sur votre ordinateur et vous pouvez l’utiliser à nouveau pour récupérer des données externes. Pour plus d’informations, voir l’aide de Microsoft Query.

Remarque : La procédure suivante s’applique uniquement à une plage de données externes créée à l’aide de l’Assistant Connexion de données ou de Microsoft Query (et non à un fichier texte ou une requête web importés), à une plage de données externes convertie à partir d’un programme Microsoft Office 2003 ou d’une plage de données externes créée par programme. Toutes les plages de données externes créées à l’aide de l’interface utilisateur sont créées Excel tables.

  1. Insérez une ligne vide au-dessus de la plage de données externe en faisant l’une des opérations suivantes :

    • Sélectionnez une cellule au-dessus de laquelle vous voulez insérer la nouvelle ligne. Ensuite, sous l’onglet Accueil, dans le groupe Cellules, cliquez sur la flèche à côté d’Insérer, puis sur Insérer des lignes dans la feuille. Étant donné que vous avez sélectionné une cellule, une nouvelle ligne est insérée au-dessus de la ligne actuelle.

    • Cliquez sur le sélecteur de ligne de la ligne au-dessus de laquelle vous souhaitez insérer une nouvelle ligne. Sous l’onglet Accueil, dans le groupe Cellules, cliquez sur Insérer. Étant donné que vous avez sélectionné une ligne entière, une nouvelle ligne est insérée au-dessus de la ligne sélectionnée.

  2. Tapez les étiquettes que vous souhaitez voir dans les cellules de la ligne vide.

  3. Cliquez sur une cellule de la plage de données externes.

  4. Sélectionnez Données> Propriétés.

  5. Dans la boîte de dialogue Propriétés de la plage de données externes, sous Mise en forme et disposition des données,cochez la case Inclure les noms des champs, puis cliquez sur OK.

  6. Pour supprimer les noms de champs existants et actualiser la plage de données externes, cliquez sur une cellule dans la plage de données externes, puis sur Actualiser les données Image du bouton.

Remarque : Lorsque vous récupérez des données d’une base de données, les modifications apportées aux noms de colonnes dans Microsoft Query sont conservées dans la plage de données externe. Pour plus d’informations sur la modification des noms de colonne dans la requête, voir l’aide de Microsoft Query.

  1. Cliquez sur la feuille de calcul qui contient la plage de données externes à supprimer.

  2. Dans la barre de formule, cliquez sur la flèche en côté de la zone Nom,puis sur le nom de la plage de données externes à supprimer.

    Si la plage de données externes est Excel tableau, appuyez sur Ctrl+A pour sélectionner la table entière.

  3. Pour supprimer la plage de données externes, appuyez sur supprimant.

  4. Pour supprimer la requête sous-jacente, cliquez sur Oui Excel vous y invite.

Voir aussi

Aide Power Query pour Excel

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?

Qu’est-ce qui a affecté votre expérience ?

Avez-vous d’autres commentaires ? (Facultatif)

Nous vous remercions pour vos commentaires.

×