Si vous avez déjà créé un mappé XML,vous pouvez l'utiliser pour importer des données XML dans des cellules mappées, mais il existe également plusieurs méthodes et commandes pour importer des données XML sans mappé XML.

Si vous avez un mappé XML, faites-le pour importer des données XML dans des cellules mappées :

  1. Dans le mappé XML, sélectionnez l'une des cellules mappées.

  2. Cliquez sur Développeur > Importer.

    Si vous ne voyez pas l’onglet Développeur, voir Afficher l’onglet Développeur.

  3. Dans la boîte de dialogue Importation XML, recherchez et sélectionnez le fichier de données XML (.xml) à importer, puis cliquez sur Importer.

Autres méthodes pour importer des données XML

Pour plus d'informations sur les problèmes, voir Problèmes courants lors de l'importation de données XML à la fin de cet article.

Importer un fichier de données XML en tant que tableau XML

  1. Cliquez sur Développeur > Importer.

    Si vous ne voyez pas l’onglet Développeur, voir Afficher l’onglet Développeur.

  2. Dans la boîte de dialogue Importation XML, recherchez et sélectionnez le fichier de données XML (.xml) à importer, puis cliquez sur Importer.

    Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

  3. Dans la boîte de dialogue Importer des données, faites l'une des choses suivantes :

    1. Sélectionnez un tableau XML dans une feuille de calcul existante pour importer le contenu du fichier de données XML dans un tableau XML de votre feuille de calcul à l'emplacement de cellule spécifié.

    2. Sélectionnez un tableau XML dans une nouvelle feuille de calcul pour importer le contenu du fichier dans un tableau XML dans une nouvelle feuille de calcul commençant à la cellule A1. Le schéma du fichier de données XML s'affiche dans le volet Tâches Source XML.

  4. Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

  5. Pour contrôler le comportement des données XML (par exemple, la reliure, le format et la disposition des données), cliquez sur Propriétés, qui affiche la boîte de dialogue propriétés du map page XML. Par exemple, les données existantes d'une plage mappée sont écrasées lorsque vous importez des données par défaut, mais vous pouvez modifier ce paramètre.

Importer plusieurs fichiers de données XML

  1. Sélectionnez une cellule mappée pour importer plusieurs fichiers XML dans un seul ensemble de cellules mappées.

    Si vous voulez importer plusieurs fichiers XML dans plusieurs ensembles de cellules mappées, cliquez sur une cellule n'importe où dans la feuille de calcul qui n'est pas mappée.

  2. Cliquez sur Développeur > Importer.

    Si vous ne voyez pas l’onglet Développeur, voir Afficher l’onglet Développeur.

  3. Dans la boîte de dialogue Importer un fichier XML, recherchez et sélectionnez le fichier de données XML (.xml) à importer.

    • Si les fichiers sont contigus, appuyez sur Shift, puis cliquez sur le premier et le dernier fichier dans la liste. Toutes les données des fichiers XML sont importées et y sont apposées.

    • Si les fichiers ne sont pas contigus, appuyez longuement sur Ctrl et cliquez sur chaque fichier à importer dans la liste.

  4. Cliquez sur Importer.

    Si vous avez sélectionné des fichiers non contigus, la boîte de dialogue Importation <nom de fichier >.xml s'affiche. Sélectionnez le maping XML correspondant au fichier de données XML que vous importez pour chaque fichier.

    Pour utiliser une seule carte pour tous les fichiers sélectionnés qui ne sont pas encore importés, sélectionnez Utiliser ce map point de contrôle XML pour tous les fichiers sélectionnés de ce schéma.

Importer plusieurs fichiers de données XML en tant que données externes

Pour importer plusieurs fichiers XML qui utilisent le même espace de noms mais différents schémas XML, vous pouvez utiliser la commande À partir de XML Data Import. Excel crée un mapil XML unique pour chaque fichier de données XML que vous importez.

Remarque : Si vous importez plusieurs fichiers XML qui ne définissent pas un espace de noms, ces fichiers XML sont traités comme s'ils utilisent le même espace de noms.

  1. Si vous utilisez un Excel avec un abonnementMicrosoft 365, cliquez sur Data >Get Data > From File > From XML.

    Si vous utilisez une Excel 2016 ou une > données à partir d'autres sources >'importation de données XML.

  2. Recherchez le lecteur, le dossier ou l'emplacement Internet contenant le fichier de données XML (.xml) que vous voulez importer.

  3. Sélectionnez le fichier et cliquez sur Ouvrir.

  4. Dans la boîte de dialogue Importer des données, faites l'une des choses suivantes :

    • Tableau XML dans une feuille de calcul existante    Le contenu du fichier est importé dans un nouveau tableau XML dans une nouvelle feuille de calcul. Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

    • Feuille de calcul existante    Les données XML sont importées dans un tableau à deux dimensions avec des lignes et des colonnes qui indiquent des balises XML comme en-tête de colonne et des données dans des lignes sous les en-tête de colonne. Le premier élément (le nœud racine) est utilisé comme un titre et s'affiche à l'emplacement de la cellule spécifié. Les autres balises sont triées par ordre alphabétique sur la deuxième ligne. Dans ce cas, Excel ne peut pas déduire un schéma et vous ne pouvez pas utiliser un map point de données XML.

    • Nouvelle feuille de calcul    Excel ajoute une nouvelle feuille de calcul à votre classez et place automatiquement les données XML dans le coin supérieur gauche de la nouvelle feuille de calcul. Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

  5. Pour contrôler le comportement des données XML, telles que la reliure, la mise en forme et la disposition des données, cliquez sur Propriétés, qui affiche la boîte de dialogue Propriétés du map page XML. Par exemple, les données existantes d'une plage mappée sont écrasées lorsque vous importez des données par défaut, mais vous pouvez modifier ce paramètre.

Ouvrir un fichier de données XML pour importer ses données

  1. Cliquez sur Fichier > Ouvrir.

    Si vous utilisez Excel 2007, cliquez sur Microsoft Office bouton Image du bouton Office >Ouvrir.

  2. Dans la boîte de dialogue Ouvrir, cliquez sur le lecteur, le dossier ou l'emplacement Internet contenant le fichier que vous voulez ouvrir.  

  3. Sélectionnez le fichier et cliquez sur Ouvrir.

  4. Si la boîte de dialogue Importer XML apparaît, le fichier que vous avez ouvert fait référence à une ou plusieurs feuilles de style XSLT (Extensible Stylesheet Language Transformation), et vous pouvez cliquer sur l'une des options suivantes :

    • Ouvrir le fichier sans appliquer de feuille de style    Les données XML sont importées dans un tableau à deux dimensions avec des lignes et des colonnes qui indiquent des balises XML comme en-tête de colonne et des données dans des lignes sous les en-tête de colonne. Le premier élément (le nœud racine) est utilisé comme un titre et s'affiche à l'emplacement de la cellule spécifié. Les autres balises sont triées par ordre alphabétique sur la deuxième ligne. Dans ce cas, Excel ne peut pas déduire un schéma et vous ne pouvez pas utiliser un map point de données XML.

    • Ouvrir le fichier avec la feuille de style suivante appliquée (sélectionnez-en une)    Sélectionnez la feuille de style à appliquer, puis cliquez sur OK. Les données XML sont formatées en fonction de la feuille de style que vous avez sélectionnée.

      Remarque : Les données XML sont ouvertes en lecture seule dans Excel afin de ne pas enregistrer accidentellement votre fichier source d'origine au format de fichier Excel Macro-Enabled (.xlsm). Dans ce cas, Excel ne peut pas déduire un schéma et vous ne pouvez pas utiliser un map point de données XML.

  5. Si la boîte de dialogue Ouvrir XML s'affiche, cela signifie que le fichier XML ne comprend aucune référence de feuille de style XSLT. Pour ouvrir le fichier, cliquez sur l'une des options suivantes :

    • Cliquez sur Un tableau XML pour créer un tableau XML dans un nouveau workbook.

      Le contenu du fichier est importé dans le tableau XML. Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

    • Cliquez en tant que workbook en lecture seule.

      Les données XML sont importées dans un tableau à deux dimensions avec des lignes et des colonnes qui indiquent des balises XML comme en-tête de colonne et des données dans des lignes sous les en-tête de colonne. Le premier élément (le nœud racine) est utilisé comme un titre et s'affiche à l'emplacement de la cellule spécifié. Les autres balises sont triées par ordre alphabétique sur la deuxième ligne. Dans ce cas, Excel ne peut pas déduire un schéma et vous ne pouvez pas utiliser un map point de données XML.

      Les données XML sont ouvertes en lecture seule dans Excel afin de ne pas enregistrer accidentellement votre fichier source d'origine au format de fichier Excel Macro-Enabled (.xlsm). Dans ce cas, Excel ne peut pas déduire un schéma et vous ne pouvez pas utiliser un map point de données XML.

    • Cliquez sur Utiliser le volet De tâches Source XML.

      Le schéma du fichier de données XML s'affiche dans le volet Tâches Source XML. Vous pouvez ensuite faire glisser des éléments du schéma vers la feuille de calcul pour mammmmiser ces éléments vers la feuille de calcul.

      Si le fichier de données XML ne fait pas référence à un schéma, Excel inférer le schéma à partir du fichier de données XML.

Problèmes courants lors de l'importation de données XML

Excel affiche la boîte de dialogue Erreur d'importation XML lorsqu'elle ne peut pas valider des données en fonction du map ms XML. Dans cette boîte de dialogue, cliquez sur Détails pour obtenir des informations supplémentaires sur chaque erreur. Le tableau suivant répertorie certaines erreurs d'importation courantes :

Erreur

Que s'est-il passé

Échec de la validation du schéma

Lorsque vous avez cliqué sur Valider les données par rapport au schéma pour l'importation et l'exportation dans la boîte de dialogue Propriétés du mapme XML, les données étaient importées, mais elles n'ont pas été validées par rapport au map ms XML spécifié.

Certaines données ont été importées en tant que texte

Certaines ou l'ensemble des données que vous avez importées ont été converties à partir de son type de données déclaré en texte. Pour utiliser ces données dans un calcul, vous devez convertir les données du texte en nombres ou en dates. Par exemple, une valeur de date convertie en texte ne fonctionne pas comme prévu dans la fonction ANNÉE tant que vous ne la convertissez pas en type de données Date. Excel convertit les données en texte lorsque :

  • Les données sont dans un format Excel prise en charge.

  • Les données sont incompatibles avec la Excel interne du type de données XSD. Pour résoudre ce problème, vérifiez chaque déclaration de type de données pour vous assurer que vos données XML sont valides conformément au schéma XML.

Erreur d'examen XML

L'asyur XML ne peut pas ouvrir le fichier XML spécifié. Assurez-vous que le fichier XML ne doit pas présenter d'erreurs de syntaxe et que le fichier XML est bien formé.

Je ne trouve pas un map sur XML qui correspond aux données

Ce problème peut se produire lorsque vous sélectionnez plusieurs fichiers de données XML à importer, et Excel ne parviennent pas à trouver un mapme XML correspondant pour l'un des fichiers. Pour le fichier nommé dans la barre de titre de la boîte de dialogue, importez tout d'abord un schéma approprié, puis retentez l'importation.

Un tableau XML ne peut pas être resserré pour tenir compte des données

Vous essayez d'ajouter des lignes en important ou en ajoutant des données au tableau XML, mais il n'y a pas d'espace pour le développer. Un tableau XML peut uniquement se développer à partir du bas. Par exemple, il peut y avoir un objet, tel qu'une image ou un autre tableau, juste en dessous du tableau XML qui empêche le tableau XML de se développer. Ou, pour que le tableau XML se développe, il dépassera la limite Excel ligne de 1 048 576. Pour résoudre ce problème, réorganisez les tableaux et objets de la feuille de calcul pour que le tableau XML se développe à partir du bas.

Le fichier XML spécifié ne fait pas référence à un schéma

Le fichier XML que vous essayez d'ouvrir ne fait pas référence à un schéma XML. Pour pouvoir travailler avec les données XML du fichier, Excel un schéma basé sur le contenu du fichier XML. Si ce schéma est incorrect ou insuffisant, supprimez-le de votre workbook. Ensuite, créez un fichier de schéma XML et modifiez le fichier de données XML de façon à ce que le fichier de données XML référence au schéma. Pour plus d'informations, voir Maser les éléments XML aux cellules d'un mapmel XML.

Remarque : Vous ne pouvez pas exporter le schéma Excel inféré en tant que fichier de données de schéma XML distinct (.xsd). Bien qu’il existe des éditeurs de schéma XML et d’autres méthodes de création de fichiers de schéma XML, il se peut que vous n’y ayez pas facilement accès ou que vous ne sachiez pas comment les utiliser.

Pour supprimer le schéma créé dans votre Excel, suivez ces étapes :

  1. Cliquez sur Source > développeur.

    Commandes XML sous l’onglet Développeur

    Si vous ne voyez pas l’onglet Développeur, voir Afficher l’onglet Développeur.

  2. Dans le volet Tâches Source XML, cliquez sur Cartes.

  3. Dans la boîte de dialogue Cartes données XML, cliquez sur l'Excel de mapil XML créée, puis cliquez sur Supprimer.

L'importation de plusieurs fichiers XML qui utilisent le même espace de noms mais des schémas différents ne fonctionne pas comme prévu

Lorsque vous travaillez avec plusieurs fichiers de données XML et schémas XML, vous créez généralement un mapme XML pour chaque schéma, mapmez les éléments de votre choix, puis importez chaque fichier de données XML dans le map ms XML approprié. À l'aide de la commande Importer pour ouvrir plusieurs fichiers XML avec le même espace de noms, vous ne pouvez utiliser qu'un seul schéma XML. Lorsque vous utilisez cette commande pour ouvrir plusieurs fichiers XML qui utilisent le même espace de noms mais différents schémas, vous pouvez obtenir des résultats inattendus. Par exemple, les données peuvent être écrasées ou les fichiers ne s'ouvrent pas.

Pour importer plusieurs fichiers XML qui utilisent le même espace de noms mais différents schémas XML, essayez d'utiliser la commande À partir de XML Data Import (cliquez sur Data > From Other Sources). Cette commande permet à plusieurs fichiers XML du même espace de noms d'utiliser plusieurs schémas XML. Excel crée un mapil XML unique pour chaque fichier de données XML que vous voulez importer.

Remarque : Si vous importez plusieurs fichiers XML qui ne définissent pas un espace de noms, ces fichiers XML sont traités comme s'ils utilisent le même espace de noms.

Afficher l’onglet Développeur

Si vous ne voyez pas l'onglet Développeur, vous devez l'afficher en suivant les conseils suivants :

  • Dans Excel 2013 et Excel 2010 :

    1. Cliquez sur Fichier > Options.

    2. Cliquez sur la catégorie Personnaliser le ruban.

    3. Sous Onglets principaux,cochez la case Développeur, puis cliquez sur OK.

  • Dans Excel 2007 :

    1. Cliquez sur le bouton Microsoft Office bouton Image du bouton Office> Excel Options.

    2. Cliquez sur la catégorie Populaire.

    3. Sous Les options principales pour l'Excel,cochez l'onglet Afficher le développeur dans la zone du ruban, puis cliquez sur OK.

Voir aussi

Sur vue du XML dans Excel

Mameler des éléments XML vers des cellules d'un map pas XML

Exporter des données XML

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?

Qu’est-ce qui a affecté votre expérience ?

Avez-vous d’autres commentaires ? (Facultatif)

Nous vous remercions pour vos commentaires.

×