Nous avons mis à Excel jour pour reconnaître la nouvelle ère japonaise, qui a commencé le 1er mai 2019.  Cela incluait la création du format de nombre Gannen (année japonaise1), et vous pouvez désormais modifier et enregistrer vos Excel de travail avec ce format.  

Pour appliquer le format de nombre Gannen, sélectionnez la ou les cellules à mettre en forme, puis appuyez sur Ctrl+1. Dans la boîte de dialogue Format de cellule, sélectionnez Date dans l’onglet Nombre. Sélectionnez le japonais dans la zone de chute Locale (emplacement) et le japonais Réser dans la zone de chute du type de calendrier. Assurez-vous que la case à cocher Utiliser Gannen pour afficher 1an est cochée, puis appuyez sur OK.

Image de la boîte de dialogue Format de cellule dans le volet Nombre avec le format de date Gannen appliqué.

Remarques : 

  • Nous sommes en train de déployer cette opération pour les Microsoft 365 utilisateurs. Pour les Excel de bureau, il est disponible avec la version 1909 (build 12026.20320)du canal actuel. Nous travaillons à l’activation de cette fonctionnalité sur d’autres points de terminaison (Mac, iOS et Android) dans un futur proche.

  • Si vous n’êtes pas sur le canal actuel (Excel 2013, Excel 2016, Excel 2019, canal Microsoft 365 Semi-Annual Enterprise (prévisualisation) ou canal Semi-Annual Enterprise), ou si vous avez des feuilles de calcul Excel avec des formules, des macros ou des formats personnalisés qui dépendent de représentation de ère japonaise, alors vous pouvez utiliser les options de mise en forme personnalisées pour la date Gannen affichée ci-dessous.

  • Pour nous faire part de vos commentaires sur le fonctionnement de l’expérience de la ère japonaise en Excel ou signaler des problèmes, consultez Excel > File > Feedback et utilisez les options Envoyer un sourire/un smileyown/Suggestion.

Affichant Gannen avec un format de nombre personnalisé lors de l’utilisation d’une version antérieure de Excel

  1. Sélectionnez la cellule ou la plage nécessitant une mise en forme.

  2. Appuyez sur Ctrl+1 pour lancer la boîte de dialogue Format de cellule.

  3. Sélectionnez l’ongletNombre, puis sélectionnez l’option personnaliséà partir de la sectioncatégorie.

  4. Copiez et collez la chaîne suivante dans la zone de texteType:

    [<=43585] [$-ja-JP]ggge »? » m »? » d »? » ; [>=43831]ggge »? » m »? » d »? » ; ggg »?? m »? » d »? »

    Application du format Gannen avec un numéro personnalisé à partir de Ctrl+1 >'onglet Nombre > numéro personnalisé.

  5. Appuyez sur OK pour appliquer la mise en forme aux cellules sélectionnées.

    Dans l’exemple suivant, voici comment la date a été affichée avant d’appliquer le format de nombre personnalisé:

    Image avec une date japonaise appliquée sans Gannen

    Ce résultat après avoir appliqué le format nombre personnalisé:

    Image avec Gannen appliqué

    Notez que la sortie est au format personnalisé, ce qui signifie que certaines fonctions de texte ne fonctionnent pas si vous en faites référence. Toutefois, de nombreuses fonctions de date telles que NETWORKDAYS() fonctionneront.

Affichant Gannen avec une fonction texte

Il est également possible d’afficher le format de date Gannen en utilisant une fonction texte.

Dans l’exemple ci-dessous, les cellules A5:A13 contiennent des valeurs de date et la cellule A2 contient la chaîne de format utilisée dans l’exemple précédent :

[<=43585] [$-ja-JP]ggge »? » m »? » d »? » ; [>=43831]ggge »? » m »? » d »? » ; ggg »?? m »? » d »? »

La formule =TEXTE(A5;$A$2) a été entrée dans la cellule C5 et copiée vers le bas dans les cellules C5:C13.

Image de l’application du format Gannen avec la fonction TEXTE : =TEXTE(A1,$B$2) où B2 héberge la chaîne de format Gannen.

Notez que la sortie est au format Général, ce qui signifie que certaines fonctions de texte ne fonctionnent pas si vous en faites référence.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×