Les opérateurs spécifient le type de calcul que vous voulez effectuer sur les éléments d'une formule (addition, soustraction, multiplication ou division). Cet article décrit l'ordre par défaut dans lequel les opérateurs agissent sur les éléments dans un calcul. Vous découvrirez également comment modifier cet ordre à l'aide de parenthèses.

Types d’opérateurs

Il existe quatre types d’opérateurs de calcul : arithmétiques, de comparaison, de concaténation de texte et de référence.

Pour effectuer des opérations mathématiques de base telles que l'addition, la soustraction ou la multiplication (ou combiner des nombres) et produire des résultats numériques, utilisez les opérateurs arithmétiques dans ce tableau.

Opérateur arithmétique

Signification

Exemple

+ (signe plus)

Addition

=3+3

– (signe moins)

Soustraction
Négation

=3-1
=-1

* (astérisque)

Multiplication

=3*3

/ (barre oblique)

Division

=3/3

% (signe pourcentage)

Pourcentage

=20 %

^ (signe insertion)

Exposant

=

Les opérateurs dans le tableau ci-dessous vous permet de comparer deux valeurs. Lorsque deux valeurs sont comparées à l'aide de ces opérateurs, le résultat est une valeur logique VRAI ou FAUX.

Opérateur de comparaison

Signification

Exemple

= (signe égal)

Égal à

=A1=B1

> (signe supérieur à)

Supérieur à

=A1>B1

< (signe inférieur à)

Inférieur à

=A1<B1

>= (signe supérieur ou égal à)

Supérieur ou égal à

=A1>=B1

<= (signe inférieur ou égal à)

Inférieur ou égal à

=A1<=B1

<> (signe différent)

Différent de

=A1<>B1

Utilisez le caractère « eter » (&) pour joindre ou concaténer une ou plusieurs chaînes de texte pour produire un seul élément de texte.

Opérateur de texte

Signification

Exemple

& (et commercial)

Connecte, ou concatène, deux valeurs pour produire une valeur de texte continu.

="Nord"&"vent »

Combinez des plages de cellules pour les calculs avec ces opérateurs.

Opérateurs de référence

Signification

Exemple

: (deux-points)

Opérateur de plage qui produit une référence à toutes les cellules comprises entre deux références, ces deux références étant incluses

=SOMME(B5:B15)

, (virgule)

Opérateur d'union qui combine plusieurs références en une seule référence.

=SOMME(B5:B15;D5:D15)

(espace)

Opérateur d'intersection qui produit une référence aux cellules communes aux deux références.

=SOMME(B7:D7 C6:C8)

# (livre)

Le symbole # est utilisé dans plusieurs contextes :

  • Utilisé dans le cadre d'un nom d'erreur.

  • Utilisé pour indiquer un espace insuffisant pour le rendu. Dans la plupart des cas, vous pouvez élargir la colonne jusqu'à ce que le contenu s'affiche correctement.

  • Opérateur de plage renversé, utilisé pour référencer une plage entière dans une formule de tableau dynamique.

  • #VALEUR!

  • #####

  • =SOMME(A2#)

@ (à)

Opérateur de référence, utilisé pour indiquer une intersection implicite dans une formule. 

=@A1:A10

=SOMME(Tableau1[@[Janvier]:[Décembre]])

Ordre dans lequel Excel effectue les opérations dans les formules

Dans certains cas, l'ordre dans lequel le calcul est effectué peut avoir une incidence sur la valeur de retour de la formule. Il est donc important de comprendre l'ordre, ainsi que la manière dont vous pouvez modifier l'ordre pour obtenir les résultats que vous attendez.

Les formules calculent les valeurs dans un ordre spécifique. Dans Excel, une formule commence toujours par le signe égal (=). Le signe égal Excel que les caractères qui suivent constituent une formule. Après ce signe égal, il peut y avoir une série d'éléments à calculer (les opérandes), qui sont séparés par des opérateurs de calcul. Excel calcule la formule de gauche à droite, selon un ordre spécifique pour chaque opérateur de la formule.

Si vous utilisez simultanément plusieurs opérateurs dans la même formule, Excel effectue les opérations dans l’ordre indiqué dans le tableau suivant. Si une formule contient des opérateurs de même priorité (comme c’est le cas, par exemple, pour une formule contenant un opérateur de multiplication et un opérateur de division), Excel traite les opérations de gauche à droite.

Opérateur

Description

: (deux-points)

(espace simple)

, (virgule)

Opérateurs de référence

Négation (comme dans –1)

%

Pourcentage

^

Exposant

* et /

Multiplication et division

+ et –

Addition et soustraction

&

Concaténation de deux chaînes de texte

=
< >
<=
>=
<>

Comparaison

Pour changer l’ordre de calcul, mettez entre parenthèses la partie de la formule qui doit être calculée en premier. Par exemple, la formule suivante a pour résultat la valeur 11, car la Excel calcule la multiplication avant l'addition. La formule multiplie d'abord 2 par 3, puis ajoute 5 au résultat.

=5+2*3

En revanche, si vous modifiez la syntaxe en faisant appel à des parenthèses, Excel additionne 5 et 2, puis multiplie le résultat par 3 pour obtenir 21.

=(5+2)*3

Dans l'exemple ci-dessous, les parenthèses entourant la première partie de la formule obligeront Excel à d'abord calculer B4+25, puis à diviser le résultat par la somme des valeurs des cellules D5, E5 et F5.

=(B4+25)/SOMME(D5:F5)

Regardez cette vidéo sur l'ordre des opérateurs Excel pour en savoir plus.

Comment Excel convertit des valeurs dans des formules

Lorsque vous entrez une formule, Excel des types de valeurs spécifiques pour chaque opérateur. Si vous entrez un type de valeur différent de celui prévu, Excel peut la convertir.

La formule

Produit

Explication

= « 1"+"2 »

3

Lorsque vous utilisez un signe plus (+), Excel attend des nombres dans la formule. Même si les guillemets signifient que « 1 » et « 2 » sont des valeurs de texte, Excel automatiquement convertit les valeurs de texte en nombres.

= 1+"4,00 $ »

5

Lorsqu'une formule attend un nombre, Excel convertit du texte s'il est dans un format qui serait généralement accepté pour un nombre.

= « 01/06/2001 »-« 01/05/2001 »

31

Excel du texte comme une date au format mm/j/mm/a, convertit les dates en numéros de série, puis calcule la différence entre elles.

=RT (« 8+1 »)

#VALEUR!

Excel convertir le texte en nombre, car le texte « 8+1 » ne peut pas être converti en nombre. Vous pouvez utiliser « 9 » ou « 8"+"1 » au lieu de « 8+1 » pour convertir le texte en nombre et renvoyer le résultat 3.

= « A"&VRAI

ATRUE

Lorsque le texte est attendu, Excel convertit en texte les nombres et les valeurs logiques tels que VRAI et FAUX.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?

Qu’est-ce qui a affecté votre expérience ?

Avez-vous d’autres commentaires ? (Facultatif)

Nous vous remercions pour vos commentaires.

×