Les opérateurs spécifient le type de calcul que vous souhaitez effectuer sur les éléments d’une formule, tels que l’addition, la soustraction, la multiplication ou la division. Dans cet article, vous allez découvrir l’ordre par défaut dans lequel les opérateurs agissent sur les éléments d’un calcul. Vous apprendrez également à modifier cet ordre à l’aide de parenthèses.

Types d’opérateurs

Il existe quatre types d’opérateurs de calcul : arithmétiques, de comparaison, de concaténation de texte et de référence.

Pour effectuer des opérations mathématiques de base telles que l’ajout, la soustraction ou la multiplication, ou pour combiner des nombres, et produire des résultats numériques, utilisez les opérateurs arithmétiques de cette table.

Opérateur arithmétique

Signification

Exemple

+ (signe plus)

Addition

=3+3

– (signe moins)

Soustraction
Négation

=3 à 1
=-1

* (astérisque)

Multiplication

=3*3

/ (barre oblique)

Division

=3/3

% (signe pourcentage)

Pourcentage

=20 %

^ (signe insertion)

Exposant

=2^3

Avec les opérateurs du tableau ci-dessous, vous pouvez comparer deux valeurs. Lorsque deux valeurs sont comparées à l’aide de ces opérateurs, le résultat est une valeur logique TRUE ou FALSE.

Opérateur de comparaison

Signification

Exemple

= (signe égal)

Égal à

=A1=B1

> (signe supérieur à)

Supérieur à

=A1>B1

< (signe inférieur à)

Inférieur à

=A1<B1

>= (signe supérieur ou égal à)

Supérieur ou égal à

=A1>=B1

<= (signe inférieur ou égal à)

Inférieur ou égal à

=A1<=B1

<> (signe différent)

Différent de

=A1<>B1

Utilisez l’esperluette (&) pour joindre ou concaténer une ou plusieurs chaînes de texte pour produire un seul morceau de texte.

Opérateur de texte

Signification

Exemple

& (et commercial)

Connecte ou concatène deux valeurs pour produire une valeur de texte continu.

="Nord"&"vent »

Combinez des plages de cellules pour les calculs avec ces opérateurs.

Opérateurs de référence

Signification

Exemple

: (deux-points)

Opérateur de plage qui produit une référence à toutes les cellules comprises entre deux références, ces deux références étant incluses

=SOMME(B5:B15)

, (virgule)

Opérateur Union, qui combine plusieurs références en une seule référence.

=SOMME(B5:B15,D5:D15)

(espace)

Opérateur d’intersection, qui produit une référence aux cellules communes aux deux références.

=SOMME(B7:D7 C6:C8)

# (livre)

Le symbole # est utilisé dans plusieurs contextes :

  • Utilisé dans le cadre d’un nom d’erreur.

  • Utilisé pour indiquer un espace insuffisant pour le rendu. Dans la plupart des cas, vous pouvez élargir la colonne jusqu’à ce que le contenu s’affiche correctement.

  • Opérateur de plage renversée, qui est utilisé pour référencer une plage entière dans une formule de tableau dynamique.

  • #VALEUR!

  • #####

  • =SOMME(A2#)

@ (à)

Opérateur de référence, qui est utilisé pour indiquer l’intersection implicite dans une formule. 

=@A1:A10

=SOMME(Table1[@[Janvier]:[Décembre]])

Ordre dans lequel Excel effectue les opérations dans les formules

Dans certains cas, l’ordre dans lequel le calcul est effectué peut affecter la valeur de retour de la formule. Il est donc important de comprendre l’ordre et la façon dont vous pouvez modifier l’ordre pour obtenir les résultats attendus.

Les formules calculent les valeurs dans un ordre spécifique. Dans Excel, une formule commence toujours par le signe égal (=). Le signe égal indique Excel que les caractères suivants constituent une formule. Après ce signe égal, il peut y avoir une série d’éléments à calculer (les opérandes), qui sont séparés par des opérateurs de calcul. Excel calcule la formule de gauche à droite, selon un ordre spécifique pour chaque opérateur de la formule.

Si vous utilisez simultanément plusieurs opérateurs dans la même formule, Excel effectue les opérations dans l’ordre indiqué dans le tableau suivant. Si une formule contient des opérateurs de même priorité (comme c’est le cas, par exemple, pour une formule contenant un opérateur de multiplication et un opérateur de division), Excel traite les opérations de gauche à droite.

Opérateur

Description

: (deux-points)

(espace simple)

, (virgule)

Opérateurs de référence

Négation (comme dans –1)

%

Pourcentage

^

Exposant

* et /

Multiplication et division

+ et –

Addition et soustraction

&

Concaténation de deux chaînes de texte

=
< >
<=
>=
<>

Comparaison

Pour changer l’ordre de calcul, mettez entre parenthèses la partie de la formule qui doit être calculée en premier. Par exemple, la formule suivante donne la valeur 11, car Excel calcule la multiplication avant l’addition. La formule multiplie d’abord 2 par 3, puis ajoute 5 au résultat.

=5+2*3

En revanche, si vous utilisez des parenthèses pour modifier la syntaxe, Excel ajoute 5 et 2 ensemble, puis multiplie le résultat par 3 pour produire 21.

=(5+2)*3

Dans l’exemple ci-dessous, les parenthèses qui entourent la première partie de la formule forcent Excel à calculer D4+25 en premier, puis divisent le résultat par la somme des valeurs des cellules D5, E5 et F5.

=(B4+25)/SOMME(D5:F5)

Regardez cette vidéo sur l’ordre des opérateurs dans Excel pour en savoir plus.

Comment Excel convertit des valeurs en formules

Lorsque vous entrez une formule, Excel attend des types de valeurs spécifiques pour chaque opérateur. Si vous entrez un type de valeur différent de celui attendu, Excel pouvez convertir la valeur.

La formule

Produit

Explication

= « 1"+"2 »

3

Lorsque vous utilisez un signe plus (+), Excel attend des nombres dans la formule. Même si les guillemets signifient que « 1 » et « 2 » sont des valeurs de texte, Excel convertit automatiquement les valeurs de texte en nombres.

= 1+"$4.00 »

5

Lorsqu’une formule attend un nombre, Excel convertit le texte s’il est dans un format qui serait généralement accepté pour un nombre.

= « 1/6/2001 »-« 5/1/2001 »

31

Excel interprète le texte comme une date au format mm/jj/aaaa, convertit les dates en numéros de série, puis calcule la différence entre elles.

=SQRT (« 8+1 »)

#VALEUR!

Excel ne peut pas convertir le texte en nombre, car le texte « 8+1 » ne peut pas être converti en nombre. Vous pouvez utiliser « 9 » ou « 8 » + « 1 » au lieu de « 8 +1 » pour convertir le texte en nombre et retourner le résultat de 3.

= « A"&TRUE

ATRUE

Lorsque du texte est attendu, Excel convertit des nombres et des valeurs logiques comme TRUE et FALSE en texte.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Office insiders

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×