SOMMEPROD (SOMMEPROD, fonction)

La fonction SOMMEPROD renvoie la somme des produits des plages ou matrices correspondantes. L'opération par défaut est la multiplication, mais l'addition, la soustraction et la division sont également possibles.

Dans cet exemple, nous allons utiliser SOMMEPROD pour renvoyer le total des ventes pour un article et une taille donnés :

Exemple d’utilisation de la fonction SOMMEPROD pour renvoyer les ventes totales lorsqu’elles sont fournies avec un nom de produit, une taille et des valeurs de ventes individuelles pour chaque produit.

SOMMEPROD correspond à toutes les instances de l'élément Y/Taille M et les additione, de sorte que pour cet exemple 21 plus 41 est égal à 62.

Syntaxe

Pour utiliser l'opération par défaut (multiplication) :

=SOMMEPROD(matrice1; [matrice2]; [matrice3]; ...)

La syntaxe de la fonction SOMMEPROD contient les arguments suivants :

Argument

Description

matrice1   

Obligatoire

Représente le premier argument de matrice dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

[matrice2], [matrice3],...    

Facultatif

Arguments de matrices 2 à 255 dont vous voulez multiplier les valeurs pour ensuite additionner leur produit.

Pour effectuer d'autres opérations arithmétiques

Utilisez SOMMEPROD comme d'habitude, mais remplacez les virgules séparant les arguments de matrice par les opérateurs arithmétiques de votre choix (*, /, +, -). Une fois toutes les opérations effectuées, les résultats sont additionés comme d'habitude.

Remarque : Si vous utilisez des opérateurs arithmétiques, envisagez de mettre vos arguments de matrice entre parenthèses et d'utiliser des parenthèses pour grouper les arguments de matrice afin de contrôler l'ordre des opérations arithmétiques.

Remarques

  • Les arguments matriciels ne doivent pas avoir les mêmes dimensions. Si tel n’est pas le cas, SOMMEPROD renvoie la valeur d’erreur #VALEUR! . Par exemple, =SOMMEPROD(C2:C10;D2:D5) retourne une erreur, car les plages ne sont pas de la même taille.

  • SOMMEPROD traite les entrées de matrice non numériques comme s'il s'avaient été des zéros.

  • Pour de meilleures performances, la colonne SOMMEPROD ne doit pas être utilisée avec des références de colonne complètes. Considérez =SOMMEPROD(A:A;B:B), ici la fonction multiplie les 1 048 576 cellules de la colonne A par les 1 048 576 cellules de la colonne B avant de les ajouter. 

Exemple 1

Exemple de la fonction SOMMEPROD utilisée pour renvoyer la somme des articles vendus lorsque le coût unitaire et la quantité sont fournis.

Pour créer la formule à l'aide de notre exemple de liste ci-dessus, tapez =SOMMEPROD(C2:C5;D2:D5), puis appuyez sur Entrée. Chaque cellule de la colonne C est multipliée par sa cellule correspondante dans la même ligne de la colonne D et les résultats sont ajoutés. Le montant total de ces courses est de 78,97 $.

Pour écrire une formule plus longue qui vous donne le même résultat, tapez =C2*D2+C3*D3+C4*D4+C5*D5, puis appuyez sur Entrée. Une fois que vous appuyez sur Entrée, le résultat est le même : 78,97 $. La cellule C2 est multipliée par D2 et son résultat est ajouté au résultat de la cellule C3 fois la cellule D3, et ainsi de suite.

Exemple 2

L'exemple suivant utilise SOMMEPROD pour renvoyer le total des ventes nettes par agent des ventes, où nous avons à la fois le total des ventes et des dépenses par agent. Dans ce cas, nous utilisons un tableau Excel,qui utilise des références structurées au lieu de plages Excel standard. Vous pouvez constater que les plages Ventes, Dépenses et Agent sont référencés par leur nom.

Exemple de fonction SOMMEPROD pour renvoyer le total des ventes par représentant des ventes lorsqu’il est fourni avec les ventes et les dépenses pour chacun d’eux.

La formule est la formule = SOMMEPROD(((Table1[Ventes])+(Tableau1[Dépenses]))*(Table1[Agent]=B8)) et renvoie la somme de toutes les ventes et dépenses de l'agent répertorié dans la cellule B8.

Exemple 3

Dans cet exemple, nous voulons renvoyer le total d'un article particulier vendu par une région donnée. Dans ce cas, combien de cerises la région Est a-t-elle vendue ?

Examen de l’utilisation de SOMMEPROD pour renvoyer la somme d’éléments par région. Dans ce cas, le nombre d’cerises vendus dans la région Est.

Ici, la formule est : =SOMMEPROD((B2:B9=B12)*(C2:C9=C12)*D2:D9). Il multiplie d'abord le nombre d'occurrences de l'Est par le nombre d'occurrences correspondantes d'cerises. Enfin, elle additione les valeurs des lignes correspondantes dans la colonne Ventes. Pour voir comment Excel calcule ce nombre, sélectionnez la cellule de formule, puis allez dans Formules > Évaluer > Évaluer.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Effectuer des calculs conditionnels sur des plages de cellules

Somme basée sur plusieurs critères avec SOMME.SI.ENS

Compter en fonction de plusieurs critères avec la fonction FONCTION.SI.ENS

Moyenne basée sur plusieurs critères avec la fonction MOYENNE.SI.ENS

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×